]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
launcher: inline commandline options help from manpage
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
ba685303 3%bcond_without cups # with cups
2108baf2 4%bcond_without debuginfo # disable debuginfo creation (it is huge)
ba685303 5%bcond_without gconf # with GConf
8171fe68 6%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
2108baf2 7%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
ba685303 8%bcond_without libjpegturbo # use libjpeg-turbo features
6c8531c6 9%bcond_without nacl # build Native Client support
ba685303 10%bcond_without pulseaudio # with pulseaudio
2108baf2
ER
11%bcond_without sandboxing # with sandboxing
12%bcond_with selinux # with SELinux (need policy first)
13%bcond_with shared_libs # with shared libs
14%bcond_with sse2 # use SSE2 instructions
ba685303 15%bcond_without system_flac # system flac
7d0dbc8d 16%bcond_with system_ffmpeg # system ffmpeg instead of ffmpegsumo
01b4dc8e 17%bcond_with system_harfbuzz # system harfbuzz
ba685303 18%bcond_without system_jsoncpp # system jsoncpp
62950103
ER
19%bcond_without system_libexif # system libexif
20%bcond_without system_libmtp # system libmtp
ba685303
ER
21%bcond_without system_libusb # system libusb-1
22%bcond_without system_libwebp # system libwebp
4884fc99 23%bcond_without system_libxnvctrl # system libxnvctrl
126ea630 24%bcond_without system_minizip # system minizip
62950103 25%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
75a27c2e 26%bcond_with system_protobuf # system protobuf
ba685303
ER
27%bcond_without system_speex # system speex
28%bcond_with system_sqlite # system sqlite
9bd2659c 29%bcond_without system_libsrtp # system srtp (can be used if using bundled libjingle)
ba685303 30%bcond_with system_v8 # system v8
4b411ffe 31%bcond_without system_libvpx # system libvpx
ba685303 32%bcond_without system_yasm # system yasm
1c00315b 33%bcond_without system_zlib # system zlib
d2781a31 34%bcond_without tcmalloc # use tcmalloc
7e136323 35%bcond_without verbose # verbose build (V=1)
0c480b89 36
c6325ea2
ER
37%if %{with nacl}
38# temporary hack as seems this does not work: http://codereview.chromium.org/8890043
39# nacl_bootstrap.c:(.text.load_elf_file+0x707): undefined reference to `__stack_chk_fail'
40#14:08:04 @baggins> glen: yes, I added SSP in rpm5, add -lssp to link flags to fix it
41#14:19:42 @baggins> it doesn't hurt to add -lssp here and there, and we'll be a bit more secure
42#14:51:06 @baggins> as-needed will take care of unneeded lib
43#14:52:03 @baggins> -lssp comes with gcc
107b55fe 44%define _ssp_cflags %{nil}
c6325ea2
ER
45%endif
46
6d92f81c 47# TODO
f1b276d4 48# - check system sqlite linking problems
2108baf2 49# - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
a3140cd1 50# - use_system_ssl (use_openssl: http://crbug.com/62803)
d617ab39 51# - use_system_hunspell
32a2443e 52# - use_system_stlport
a3140cd1
ER
53# - other defaults: src/build/common.gypi
54
e53ecfb5 55# NOTES:
4fe038cb
ER
56# - mute BEEP mixer if you do not want to hear horrible system bell when
57# pressing home/end in url bar or more ^F search results on page.
7c638678 58# - space considerations:
6d877f0c 59# - unpacked sources: ~574MiB
c1ecd31f 60# - built code: ~1.4GiB (x86_64/i686)
f1b276d4 61# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 62# - to look for new tarball, use update-source.sh script
f1b276d4 63
e68aa7e7 64# NOTE TO USERS:
c8b02491 65# To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
a3cc7091 66# http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
c8b02491 67# http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
e68aa7e7 68
2a415062
ER
69%define branch 24.0.1312
70%define basever 52
0320ccad 71%define patchver 69
a3140cd1 72%define gyp_rev 1014
11ad81c4 73Summary: A WebKit powered web browser
05f72ae2 74Name: chromium-browser
f73369da
ER
75%if "%{?patchver}" != ""
76Version: %{branch}.%{patchver}
77%else
78Version: %{branch}.%{basever}
79%endif
80Release: 1
05f72ae2 81License: BSD, LGPL v2+ (ffmpeg)
e53ecfb5 82Group: X11/Applications/Networking
3c73e180 83Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
24623500 84# Source0-md5: bcc3976e61b9ce715ba9c85d46df72f1
3c73e180
ER
85%if "%{?patchver}" != ""
86Patch0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
0320ccad 87# Patch0-md5: 130262d245d6833200cef43e61b641c2
3c73e180 88%endif
37ceaf05 89Source1: %{name}.default
8b53130d
ER
90Source2: %{name}.sh
91Source3: %{name}.desktop
56c6e811
ER
92Source5: find-lang.sh
93Source6: update-source.sh
94Source7: clean-source.sh
836b1cac 95Source8: get-source.sh
0562b864 96Source9: master_preferences.json
48b341f5 97Patch1: plugin-searchdirs.patch
70258ccd 98#Patch2: system-nspr.patch
7abc645c 99Patch3: disable_dlog_and_dcheck_in_release_builds.patch
72cb20c1 100Patch4: path-libpdf.patch
0e5636cb 101Patch6: get-webkit_revision.patch
5aa5df39 102Patch7: dlopen_sonamed_gl.patch
4765ddf1 103Patch8: chromium_useragent.patch.in
c0808220 104Patch9: chromium-ppapi.patch
8456d676 105Patch10: system-libxnvctrl.patch
1347c76c
AM
106# https://bugs.gentoo.org/show_bug.cgi?id=393471
107# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 108Patch11: chromium-revert-jpeg-swizzle-r2.patch
5997e180
ER
109Patch15: nacl-build-irt.patch
110Patch16: nacl-linkingfix.patch
9516ca97 111Patch18: nacl-no-untar.patch
08b25440 112Patch19: system-jsoncpp.patch
126ea630 113Patch22: pulse_fix-157876.patch
8fb1dc98 114Patch23: no-pnacl.patch
6897926c 115Patch24: nacl-verbose.patch
c5b396f3
ER
116Patch25: gnome3-volume-control.patch
117Patch26: master-prefs-path.patch
d2781a31 118Patch27: tcmalloc-glibc2.16.patch
750b48f7 119URL: http://www.chromium.org/Home
ae3fe89f 120%{?with_gconf:BuildRequires: GConf2-devel}
f1b276d4 121BuildRequires: OpenGL-GLU-devel
05f72ae2
ER
122BuildRequires: alsa-lib-devel
123BuildRequires: atk-devel
124BuildRequires: bison
11ad81c4 125BuildRequires: bzip2-devel
5997e180
ER
126%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
127%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
128%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 129%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 130%{?with_cups:BuildRequires: cups-devel}
2bc5cf47 131BuildRequires: dbus-glib-devel
92965b0e 132BuildRequires: elfutils-devel
77f32fa3 133BuildRequires: expat-devel
7d0dbc8d 134%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 1.0}
8f5f6775 135%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 136BuildRequires: flex
11ad81c4 137BuildRequires: fontconfig-devel
f1b276d4 138BuildRequires: glib2-devel
05f72ae2 139BuildRequires: gperf
bbad64b7 140BuildRequires: gtest-devel
8b53130d 141BuildRequires: gtk+2-devel
01b4dc8e 142%{?with_system_harfbuzz:BuildRequires: harfbuzz-devel}
a3140cd1 143%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 144BuildRequires: hicolor-icon-theme
ed514974 145%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
8456d676 146%{?with_system_libxvnctrl:BuildRequires: libXNVCtrl-devel >= 310.19}
05f72ae2 147BuildRequires: libevent-devel
8456d676 148%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
7f40f3f4 149%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 150BuildRequires: libicu-devel >= 4.6
39c71b4c 151%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 152%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
8456d676 153%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
05f72ae2 154BuildRequires: libpng-devel
e266589e 155%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 156BuildRequires: libstdc++-devel
ba685303 157%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
4b411ffe 158%{?with_system_libvpx:BuildRequires: libvpx-devel >= 0.9.5-2}
dd1509bd 159%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.1.99}
f1b276d4 160BuildRequires: libxml2-devel
11ad81c4 161BuildRequires: libxslt-devel
f1b276d4 162BuildRequires: lzma
535cb410 163BuildRequires: man-db
62950103 164%{?with_system_minizip:BuildRequires: minizip-devel}
05f72ae2 165BuildRequires: nspr-devel
f1b276d4 166BuildRequires: nss-devel >= 1:3.12.3
8456d676 167%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
35902862 168BuildRequires: pam-devel
f1b276d4 169BuildRequires: pango-devel
48b341f5 170BuildRequires: perl-modules
171BuildRequires: pkgconfig
75a27c2e 172%{?with_system_protobuf:BuildRequires: protobuf-devel}
ae3fe89f 173%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 174BuildRequires: python
46cdefee 175#BuildRequires: python-gyp >= 1-%{gyp_rev}
48b341f5 176BuildRequires: python-modules
92965b0e 177BuildRequires: python-ply
0cad051b 178BuildRequires: rpm >= 4.4.9-56
f1b276d4 179BuildRequires: rpmbuild(macros) >= 1.453
0cad051b 180%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
f1b276d4 181BuildRequires: sqlite3-devel >= 3.6.1
9bd2659c 182%{?with_system_libsrtp:BuildRequires: srtp-devel >= 1.4.4}
89f0dde4 183BuildRequires: subversion
0cad051b 184BuildRequires: tar >= 1:1.22
0a424ee2 185BuildRequires: udev-devel
2303ed45 186BuildRequires: util-linux
c14cd342 187%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 188BuildRequires: which
f1b276d4 189BuildRequires: xorg-lib-libXScrnSaver-devel
2bc5cf47
KK
190BuildRequires: xorg-lib-libXt-devel
191BuildRequires: xorg-lib-libXtst-devel
836b1cac 192BuildRequires: xz
a3140cd1 193%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 194%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 195Requires: browser-plugins >= 2.0
0cad051b 196Requires: desktop-file-utils
8f5f6775 197%{?with_system_flac:Requires: flac >= 1.2.1-7}
6f5daa23
ER
198# requires any TTF font actually
199Requires: fonts-TTF-bitstream-vera
0eb19b0b 200Requires: hicolor-icon-theme
c1edaafa 201%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
4b411ffe 202%{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
b809ab60 203Requires: lsb-release
3700ba38 204Requires: shared-mime-info
4dc49133 205Requires: xdg-utils >= 1.0.2-4
e53ecfb5 206Provides: wwwbrowser
c3582150 207Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 208Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 209ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 210BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 211
589d90ea 212%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 213
e7fa0817
ER
214# Usage: gyp_with BCOND_NAME [OPTION_NAME]
215%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 216
6b113615
ER
217%if %{without debuginfo}
218%define _enable_debug_packages 0
219%endif
220
11ad81c4 221%description
80838854
ER
222Chromium is an open-source browser project that aims to build a safer,
223faster, and more stable way for all Internet users to experience the
224web.
225
226Chromium serves as a base for Google Chrome, which is Chromium
227rebranded (name and logo) with very few additions such as usage
228tracking and an auto-updater system.
229
f1b276d4
ER
230%package l10n
231Summary: chromium-browser language packages
232Group: I18n
233Requires: %{name} = %{version}-%{release}
234
235%description l10n
236Chromium is an open-source browser project that aims to build a safer,
237faster, and more stable way for all Internet users to experience the
238web.
239
240This package contains language packages for 50 languages:
241
e7fa0817
ER
242ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
243he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
244pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
245zh-TW
f1b276d4
ER
246
247%prep
3c73e180
ER
248%setup -qc
249%if "%{?patchver}" != ""
250cd %{name}-%{branch}.%{basever}
251%patch0 -p1
252cd ..
253%endif
254mv %{name}-%{branch}.%{basever}/src .
589d90ea 255
05f72ae2
ER
256# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
257# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
0c480b89
ER
258. ./src/chrome/VERSION
259ver=$MAJOR.$MINOR.$BUILD.$PATCH
a3140cd1
ER
260test "$ver" = %{version}
261
262gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 263test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 264
836b1cac 265v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
33b04c7d 266
4765ddf1
ER
267# add chromium and pld to useragent
268%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
269sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
270 -e 's/@BUILD_DIST_NAME@/PLD/g' \
271 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
74a58b60 272 < %{PATCH8} | %{__patch} -p1
4765ddf1 273
56c6e811
ER
274%{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
275ln -s %{SOURCE7} src
f1b276d4 276
05f72ae2 277%patch1 -p1
7abc645c 278%patch3 -p1
72cb20c1 279%patch4 -p1
0e5636cb 280%patch6 -p1
5aa5df39 281%patch7 -p1
e9abb380 282%patch15 -p1
77f32fa3 283cd src
c0808220 284%patch9 -p0
70258ccd 285#%patch2 -p1
f4a8da6a 286%{!?with_libjpegturbo:%patch11 -p0}
5997e180 287%patch16 -p1
08b25440 288%patch19 -p1
2d6e464b 289%patch22 -p1
c5b396f3 290%patch25 -p1
d2781a31 291%patch27 -p1
1347c76c 292cd ..
9516ca97 293%patch18 -p1
0562b864 294%patch23 -p1
6897926c 295%patch24 -p1
c5b396f3 296%patch26 -p1
0c480b89 297
828bdd1a 298cd src
e9abb380
ER
299
300# Missing gyp files in tarball.
301# https://code.google.com/p/chromium/issues/detail?id=144823
302if [ -e chrome/test/data/nacl/nacl_test_data.gyp ]; then
303 echo "tarball fixed, please remove workaround"
304 exit 1
305fi
306
307install -d chrome/test/data/nacl
308cat > chrome/test/data/nacl/nacl_test_data.gyp <<-EOF
309{
310 'targets': [
311 {
312 'target_name': 'nacl_tests',
313 'type': 'none',
314 },
315 ],
316}
317EOF
318
75a27c2e
ER
319sh -x clean-source.sh \
320 %{!?with_nacl:nacl=0} \
321 %{!?with_system_protobuf:protobuf=0} \
322 %{!?with_system_v8:v8=0} \
323 %{!?with_system_zlib:zlib=0} \
324 %{nil}
fded59be 325
e266589e 326%build
f1b276d4 327cd src
5997e180
ER
328
329%if %{with nacl}
fded59be 330if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
dcea0d6b
ER
331# Make symlinks for NaCL
332install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,lib,lib32,nacl}
2e4113fd 333
dcea0d6b 334cd native_client/toolchain/linux_x86_newlib/x86_64-nacl/bin
2e4113fd 335__cc='%{__cc}'
f64e73f6 336if [ "${__cc#ccache}" != "$__cc" ]; then
2e4113fd
ER
337 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
338 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
339 %{__sed} -i -e '1i#!/bin/sh' gcc g++
340 chmod +x gcc g++
341else
342 ln -s %{_bindir}/x86_64-nacl-gcc gcc
343 ln -s %{_bindir}/x86_64-nacl-g++ g++
344fi
5997e180
ER
345ln -s %{_bindir}/x86_64-nacl-ar ar
346ln -s %{_bindir}/x86_64-nacl-as as
347ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
348ln -s %{_bindir}/x86_64-nacl-strip x86-64-nacl-strip
349ln -s %{_bindir}/x86_64-nacl-strip strip
dcea0d6b
ER
350ln -s %{_prefix}/x86_64-nacl/lib/*.a ../lib
351ln -s %{_prefix}/x86_64-nacl/lib/32/*.a ../lib32
352ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
353cd ../../../../..
fded59be 354fi
5997e180
ER
355%endif
356
c5b396f3 357test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
673aee14
ER
358test -e Makefile || %{__python} build/gyp_chromium \
359 --format=make \
360 -Goutput_dir=../out \
361 build/all.gyp \
f1b276d4
ER
362%ifarch %{ix86}
363 -Dtarget_arch=ia32 \
364%endif
365%ifarch %{x8664}
0c480b89
ER
366 -Dtarget_arch=x64 \
367%endif
7b454a31
AM
368%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
369 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4
ER
370%endif
371%if %{with sandboxing}
372 -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
373 -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
374%endif
375 %{!?debug:-Dwerror=} \
c980b122 376 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 377 %{?with_shared_libs:-Dlibrary=shared_library} \
6e2c5572 378 %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1 -Dproprietary_codecs=1} \
b5a3dda3 379 -Dinclude_tests=0 \
c0808220 380%if %{with nacl}
038f76b9 381 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
382 -Ddisable_glibc_untar=1 \
383 -Ddisable_newlib_untar=1 \
8fb1dc98
ER
384 -Ddisable_glibc=1 \
385 -Ddisable_pnacl=1 \
386 -Dbuild_pnacl_newlib=0 \
c0808220 387%else
8fb1dc98 388 -Ddisable_pnacl_untar=1 \
c0808220
ER
389 -Ddisable_nacl=1 \
390%endif
a3140cd1
ER
391 %{!?with_sse2:-Ddisable_sse2=1} \
392 %{?with_selinux:-Dselinux=1} \
e7fa0817 393 %{gyp_with cups} \
8dda6bbc 394 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
e7fa0817
ER
395 %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
396 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
397 %{gyp_with pulseaudio} \
7d0dbc8d 398 %{gyp_with system_ffmpeg} \
8f5f6775 399 %{gyp_with system_flac} \
01b4dc8e 400 %{gyp_with system_harfbuzz} \
62950103
ER
401 %{gyp_with system_libexif} \
402 %{gyp_with system_libmtp} \
9bd2659c 403 %{gyp_with system_libsrtp} \
581aec44 404 %{gyp_with system_libusb} \
4b411ffe 405 %{gyp_with system_libvpx} \
ba685303 406 %{gyp_with system_libwebp} \
4884fc99 407 %{gyp_with system_libxnvctrl} \
126ea630 408 %{gyp_with system_minizip} \
62950103 409 %{gyp_with system_opus} \
75a27c2e 410 %{gyp_with system_protobuf} \
e7fa0817
ER
411 %{gyp_with system_speex} \
412 %{gyp_with system_sqlite} \
413 %{gyp_with system_v8} \
414 %{gyp_with system_yasm} \
415 %{gyp_with system_zlib} \
0c480b89 416 -Duse_system_bzip2=1 \
62950103 417 -Duse_system_expat=1 \
0b214002 418 -Duse_system_icu=1 \
f1b276d4 419 -Duse_system_libevent=1 \
0c480b89 420 -Duse_system_libjpeg=1 \
f1b276d4
ER
421 -Duse_system_libpng=1 \
422 -Duse_system_libxml=1 \
423 -Duse_system_libxslt=1 \
7f40f3f4 424 -Duse_system_xdg_utils=1 \
d8ba130c 425 %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
44f353ec
AM
426 -Dlinux_use_gold_binary=0 \
427 -Dlinux_use_gold_flags=0
11ad81c4 428
48ffbc5e 429%{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
f1b276d4
ER
430 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
431 %{?with_verbose:V=1} \
432 CC="%{__cc}" \
433 CXX="%{__cxx}" \
b7adf6b1 434 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
f1b276d4
ER
435 CC.host="%{__cc}" \
436 CXX.host="%{__cxx}" \
b7adf6b1 437 LDFLAGS.host="%{rpmldflags}" \
7b454a31
AM
438 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
439 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
11ad81c4 440
535cb410
ER
441cd ../out/%{!?debug:Release}%{?debug:Debug}
442MANWIDTH=80 man ./chrome.1 > man.out
443%{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
444
11ad81c4
AM
445%install
446rm -rf $RPM_BUILD_ROOT
56c6e811 447install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
37ceaf05 448 $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
e266589e 449
673aee14 450cd out/%{!?debug:Release}%{?debug:Debug}
37ceaf05 451cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4 452install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
535cb410
ER
453%{__sed} -i -e '
454 s,@libdir@,%{_libdir}/%{name},
455
456 /@OPTIONS@/ {
457 r options.txt
458 d
459 }
460' $RPM_BUILD_ROOT%{_bindir}/%{name}
97fac491 461cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
7f40f3f4 462cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 463install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
e53ecfb5 464install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
fcc48c19 465%if %{without system_ffmpeg}
f1b276d4 466install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 467%endif
e7fa0817 468cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
0562b864 469cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
164020eb 470
c0808220
ER
471%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
472
164020eb
ER
473%if %{with nacl}
474# Install Native Client files on platforms that support it.
475install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
476install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
477%ifarch %{x8664}
478install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
479%endif
480%ifarch %{ix86}
481install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
482%endif
483%endif
484
0c480b89
ER
485cd -
486
0eb19b0b
ER
487for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
488 size=${icon##*/product_logo_}
489 size=${size%.png}
490
491 # this will skip non-numeric (22_mono_invert, 22_mono)
492 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
493 test -d "$dir" || continue
494
495 install -d $RPM_BUILD_ROOT$dir
496 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
497done
7f40f3f4 498
13840bc2
AM
499%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
500# http://code.google.com/p/chromium/issues/detail?id=24507
501gecko-mediaplayer*.so
502EOF
11ad81c4 503
589d90ea
ER
504# find locales
505%find_lang %{name}.lang
e7fa0817 506# always package en-US
f1b276d4 507%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 508
11ad81c4
AM
509%clean
510rm -rf $RPM_BUILD_ROOT
511
f1b276d4 512%post
0eb19b0b 513%update_icon_cache hicolor
b7a6e4ee 514%update_desktop_database
f1b276d4
ER
515%update_browser_plugins
516
517%postun
518if [ "$1" = 0 ]; then
0eb19b0b 519 %update_icon_cache hicolor
f1b276d4
ER
520 %update_browser_plugins
521fi
522
1d2b9616 523%files
11ad81c4 524%defattr(644,root,root,755)
531537e5 525%doc src/{AUTHORS,LICENSE}
f1b276d4
ER
526%{_browserpluginsconfdir}/browsers.d/%{name}.*
527%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
528%dir %{_sysconfdir}/%{name}
529%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
0562b864 530%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
f1b276d4
ER
531%attr(755,root,root) %{_bindir}/%{name}
532%{_mandir}/man1/%{name}.1*
11ad81c4 533%{_desktopdir}/*.desktop
0eb19b0b 534%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 535%dir %{_libdir}/%{name}
e9abb380 536%{_libdir}/%{name}/chrome*.pak
c14cd342 537%{_libdir}/%{name}/content_resources.pak
97fac491 538%{_libdir}/%{name}/resources.pak
589d90ea 539%dir %{_libdir}/%{name}/locales
f1b276d4
ER
540%{_libdir}/%{name}/locales/en-US.pak
541%dir %{_libdir}/%{name}/resources
a3140cd1 542%{_libdir}/%{name}/resources/inspector
f1b276d4
ER
543%dir %{_libdir}/%{name}/themes
544%dir %{_libdir}/%{name}/extensions
545%dir %{_libdir}/%{name}/plugins
546%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 547# These unique permissions are intentional and necessary for the sandboxing
e53ecfb5 548%attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
f1b276d4
ER
549
550# ffmpeg libs
fcc48c19 551%if %{without system_ffmpeg}
f1b276d4 552%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 553%endif
f1b276d4 554
164020eb
ER
555%if %{with nacl}
556%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
557%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
558%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
559%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
560%endif
561
f1b276d4
ER
562%files l10n -f %{name}.lang
563%defattr(644,root,root,755)
This page took 0.159792 seconds and 4 git commands to generate.