]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
use GNOME3 gnome-volume-control in Th
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
ba685303 3%bcond_without cups # with cups
2108baf2
ER
4%bcond_without debuginfo # disable debuginfo creation (it is huge)
5%bcond_without ffmpegsumo # build with ffmpegsumo
ba685303 6%bcond_without gconf # with GConf
8171fe68 7%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
2108baf2 8%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
ba685303 9%bcond_without libjpegturbo # use libjpeg-turbo features
6c8531c6 10%bcond_without nacl # build Native Client support
ba685303 11%bcond_without pulseaudio # with pulseaudio
2108baf2
ER
12%bcond_without sandboxing # with sandboxing
13%bcond_with selinux # with SELinux (need policy first)
14%bcond_with shared_libs # with shared libs
15%bcond_with sse2 # use SSE2 instructions
ba685303
ER
16%bcond_without system_flac # system flac
17%bcond_without system_jsoncpp # system jsoncpp
18%bcond_without system_libusb # system libusb-1
19%bcond_without system_libwebp # system libwebp
20%bcond_without system_speex # system speex
21%bcond_with system_sqlite # system sqlite
3ee15dec 22%bcond_without system_srtp # system srtp (can be used if using bundled libjingle)
ba685303
ER
23%bcond_with system_v8 # system v8
24%bcond_without system_vpx # system vpx
25%bcond_without system_yasm # system yasm
4c272135
ER
26# system zlib disabled because of mixed-source.patch
27# https://code.google.com/p/chromium/issues/detail?id=143623
ba685303
ER
28%bcond_with system_zlib # system zlib
29%bcond_with tcmalloc # use tcmalloc
7e136323 30%bcond_without verbose # verbose build (V=1)
0c480b89 31
c6325ea2
ER
32%if %{with nacl}
33# temporary hack as seems this does not work: http://codereview.chromium.org/8890043
34# nacl_bootstrap.c:(.text.load_elf_file+0x707): undefined reference to `__stack_chk_fail'
35#14:08:04 @baggins> glen: yes, I added SSP in rpm5, add -lssp to link flags to fix it
36#14:19:42 @baggins> it doesn't hurt to add -lssp here and there, and we'll be a bit more secure
37#14:51:06 @baggins> as-needed will take care of unneeded lib
38#14:52:03 @baggins> -lssp comes with gcc
107b55fe 39%define _ssp_cflags %{nil}
c6325ea2
ER
40%endif
41
6d92f81c 42# TODO
f1b276d4 43# - check system sqlite linking problems
2108baf2 44# - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
a3140cd1 45# - use_system_ssl (use_openssl: http://crbug.com/62803)
32a2443e 46# - use_system_ffmpeg && build_ffmpegsumo
d617ab39 47# - use_system_hunspell
32a2443e 48# - use_system_stlport
a3140cd1
ER
49# - other defaults: src/build/common.gypi
50
e53ecfb5 51# NOTES:
4fe038cb
ER
52# - mute BEEP mixer if you do not want to hear horrible system bell when
53# pressing home/end in url bar or more ^F search results on page.
2108baf2
ER
54# - build -bp: 1.2G
55# - build i686: -bc: 2.7G; -bb: ~1.0GB
e8e15592 56# - build x86_64: ~1.9G
f1b276d4 57# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 58# - to look for new tarball, use update-source.sh script
f1b276d4 59
e68aa7e7 60# NOTE TO USERS:
c8b02491 61# To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
a3cc7091 62# http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
c8b02491 63# http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
e68aa7e7 64
a3140cd1 65%define gyp_rev 1014
11ad81c4 66Summary: A WebKit powered web browser
05f72ae2 67Name: chromium-browser
9516ca97 68Version: 23.0.1271.64
9fdabe76 69Release: 2
05f72ae2 70License: BSD, LGPL v2+ (ffmpeg)
e53ecfb5 71Group: X11/Applications/Networking
9516ca97
ER
72Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.tar.xz
73# Source0-md5: 6c467affd292ee9a9020ac91147969c8
37ceaf05 74Source1: %{name}.default
8b53130d
ER
75Source2: %{name}.sh
76Source3: %{name}.desktop
56c6e811
ER
77Source5: find-lang.sh
78Source6: update-source.sh
79Source7: clean-source.sh
836b1cac 80Source8: get-source.sh
9516ca97 81#Patch0: system-libs.patch
48b341f5 82Patch1: plugin-searchdirs.patch
83Patch2: gyp-system-minizip.patch
7abc645c 84Patch3: disable_dlog_and_dcheck_in_release_builds.patch
72cb20c1 85Patch4: path-libpdf.patch
48b341f5 86Patch5: options-support.patch
0e5636cb 87Patch6: get-webkit_revision.patch
5aa5df39 88Patch7: dlopen_sonamed_gl.patch
4765ddf1 89Patch8: chromium_useragent.patch.in
c0808220 90Patch9: chromium-ppapi.patch
1347c76c
AM
91# https://bugs.gentoo.org/show_bug.cgi?id=393471
92# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 93Patch11: chromium-revert-jpeg-swizzle-r2.patch
5997e180
ER
94Patch15: nacl-build-irt.patch
95Patch16: nacl-linkingfix.patch
e9abb380 96Patch17: system-icu.patch
9516ca97 97Patch18: nacl-no-untar.patch
08b25440 98Patch19: system-jsoncpp.patch
ed514974 99Patch20: system-speex.patch
3ee15dec 100Patch21: system-srtp.patch
2d6e464b 101Patch22: gnome3-volume-control.patch
750b48f7 102URL: http://www.chromium.org/Home
ae3fe89f 103%{?with_gconf:BuildRequires: GConf2-devel}
f1b276d4 104BuildRequires: OpenGL-GLU-devel
05f72ae2
ER
105BuildRequires: alsa-lib-devel
106BuildRequires: atk-devel
107BuildRequires: bison
11ad81c4 108BuildRequires: bzip2-devel
5997e180
ER
109%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
110%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
111%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 112%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 113%{?with_cups:BuildRequires: cups-devel}
2bc5cf47 114BuildRequires: dbus-glib-devel
77f32fa3 115BuildRequires: expat-devel
8f5f6775 116%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 117BuildRequires: flex
11ad81c4 118BuildRequires: fontconfig-devel
f1b276d4 119BuildRequires: glib2-devel
05f72ae2 120BuildRequires: gperf
8b53130d 121BuildRequires: gtk+2-devel
a3140cd1 122%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 123BuildRequires: hicolor-icon-theme
ed514974 124%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
05f72ae2 125BuildRequires: libevent-devel
7f40f3f4 126%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 127BuildRequires: libicu-devel >= 4.6
39c71b4c 128%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 129%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
05f72ae2 130BuildRequires: libpng-devel
e266589e 131%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 132BuildRequires: libstdc++-devel
ba685303 133%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
32a2443e 134%{?with_system_vpx:BuildRequires: libvpx-devel >= 0.9.5-2}
dd1509bd 135%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.1.99}
f1b276d4 136BuildRequires: libxml2-devel
11ad81c4 137BuildRequires: libxslt-devel
f1b276d4 138BuildRequires: lzma
11ad81c4 139BuildRequires: minizip-devel
05f72ae2 140BuildRequires: nspr-devel
f1b276d4 141BuildRequires: nss-devel >= 1:3.12.3
35902862 142BuildRequires: pam-devel
f1b276d4 143BuildRequires: pango-devel
48b341f5 144BuildRequires: perl-modules
145BuildRequires: pkgconfig
ae3fe89f 146%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 147BuildRequires: python
46cdefee 148#BuildRequires: python-gyp >= 1-%{gyp_rev}
48b341f5 149BuildRequires: python-modules
0cad051b 150BuildRequires: rpm >= 4.4.9-56
f1b276d4 151BuildRequires: rpmbuild(macros) >= 1.453
0cad051b 152%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
f1b276d4 153BuildRequires: sqlite3-devel >= 3.6.1
3ee15dec 154%{?with_system_srtp:BuildRequires: srtp-devel >= 1.4.4}
89f0dde4 155BuildRequires: subversion
0cad051b 156BuildRequires: tar >= 1:1.22
0a424ee2 157BuildRequires: udev-devel
2303ed45 158BuildRequires: util-linux
c14cd342 159%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 160BuildRequires: which
f1b276d4 161BuildRequires: xorg-lib-libXScrnSaver-devel
2bc5cf47
KK
162BuildRequires: xorg-lib-libXt-devel
163BuildRequires: xorg-lib-libXtst-devel
836b1cac 164BuildRequires: xz
a3140cd1 165%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 166%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 167Requires: browser-plugins >= 2.0
0cad051b 168Requires: desktop-file-utils
8f5f6775 169%{?with_system_flac:Requires: flac >= 1.2.1-7}
0eb19b0b 170Requires: hicolor-icon-theme
c1edaafa 171%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
32a2443e 172%{?with_system_vpx:Requires: libvpx >= 0.9.5-2}
4dc49133 173Requires: xdg-utils >= 1.0.2-4
e53ecfb5 174Provides: wwwbrowser
c3582150 175Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 176Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 177ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 178BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 179
589d90ea 180%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 181
e7fa0817
ER
182# Usage: gyp_with BCOND_NAME [OPTION_NAME]
183%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 184
6b113615
ER
185%if %{without debuginfo}
186%define _enable_debug_packages 0
187%endif
188
11ad81c4 189%description
80838854
ER
190Chromium is an open-source browser project that aims to build a safer,
191faster, and more stable way for all Internet users to experience the
192web.
193
194Chromium serves as a base for Google Chrome, which is Chromium
195rebranded (name and logo) with very few additions such as usage
196tracking and an auto-updater system.
197
f1b276d4
ER
198%package l10n
199Summary: chromium-browser language packages
200Group: I18n
201Requires: %{name} = %{version}-%{release}
202
203%description l10n
204Chromium is an open-source browser project that aims to build a safer,
205faster, and more stable way for all Internet users to experience the
206web.
207
208This package contains language packages for 50 languages:
209
e7fa0817
ER
210ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
211he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
212pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
213zh-TW
f1b276d4
ER
214
215%prep
836b1cac 216%setup -q
589d90ea 217
05f72ae2
ER
218# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
219# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
0c480b89
ER
220. ./src/chrome/VERSION
221ver=$MAJOR.$MINOR.$BUILD.$PATCH
a3140cd1
ER
222test "$ver" = %{version}
223
224gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 225test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 226
836b1cac 227v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
33b04c7d 228
4765ddf1
ER
229# add chromium and pld to useragent
230%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
231sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
232 -e 's/@BUILD_DIST_NAME@/PLD/g' \
233 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
74a58b60 234 < %{PATCH8} | %{__patch} -p1
4765ddf1 235
56c6e811
ER
236%{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
237ln -s %{SOURCE7} src
f1b276d4 238
9516ca97 239#%patch0 -p1
05f72ae2
ER
240%patch1 -p1
241%patch2 -p1
7abc645c 242%patch3 -p1
72cb20c1 243%patch4 -p1
05f72ae2 244%patch5 -p1
0e5636cb 245%patch6 -p1
5aa5df39 246%patch7 -p1
e9abb380 247%patch15 -p1
77f32fa3 248cd src
c0808220 249%patch9 -p0
f4a8da6a 250%{!?with_libjpegturbo:%patch11 -p0}
5997e180 251%patch16 -p1
e9abb380 252%patch17 -p0
08b25440 253%patch19 -p1
3ee15dec 254%patch21 -p1
2d6e464b 255%patch22 -p1
1347c76c 256cd ..
9516ca97 257%patch18 -p1
ed514974 258%patch20 -p1
0c480b89 259
828bdd1a 260cd src
e9abb380
ER
261
262# Missing gyp files in tarball.
263# https://code.google.com/p/chromium/issues/detail?id=144823
264if [ -e chrome/test/data/nacl/nacl_test_data.gyp ]; then
265 echo "tarball fixed, please remove workaround"
266 exit 1
267fi
268
269install -d chrome/test/data/nacl
270cat > chrome/test/data/nacl/nacl_test_data.gyp <<-EOF
271{
272 'targets': [
273 {
274 'target_name': 'nacl_tests',
275 'type': 'none',
276 },
277 ],
278}
279EOF
280
4c272135 281sh -x clean-source.sh %{!?with_system_v8:v8=0} %{!?with_nacl:nacl=0} libxml=0 %{!?with_system_zlib:zlib=0}
164020eb 282
e266589e 283%build
f1b276d4 284cd src
5997e180
ER
285
286%if %{with nacl}
287rm -rf native_client/toolchain/linux_x86_newlib
288# Make symlinks for nacl
289cd native_client/toolchain
290install -d linux_x86_newlib/x86_64-nacl/bin
291install -d linux_x86_newlib/x86_64-nacl/lib
292install -d linux_x86_newlib/x86_64-nacl/lib32
293install -d linux_x86_newlib/x86_64-nacl/nacl/include/bits
294install -d linux_x86_newlib/x86_64-nacl/nacl/include/machine
295install -d linux_x86_newlib/x86_64-nacl/nacl/include/sys
c0808220
ER
296# link newlib toolchain to glibc as well, see gentoo bug #417019
297#ln -s linux_x86_newlib linux_x86
5997e180
ER
298cd linux_x86_newlib/x86_64-nacl/bin
299ln -s %{_bindir}/x86_64-nacl-gcc gcc
300ln -s %{_bindir}/x86_64-nacl-g++ g++
301ln -s %{_bindir}/x86_64-nacl-ar ar
302ln -s %{_bindir}/x86_64-nacl-as as
303ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
304ln -s %{_bindir}/x86_64-nacl-strip x86-64-nacl-strip
305ln -s %{_bindir}/x86_64-nacl-strip strip
306ln -s %{_prefix}/x86_64-nacl/lib/*.a ../lib/
307ln -s %{_prefix}/x86_64-nacl/lib/32/*.a ../lib32/
308cd ../nacl/include
309for i in $(find %{_prefix}/x86_64-nacl/include -type f | grep -v "c++"); do
310 ln -s $i ${i#%{_prefix}/x86_64-nacl/include/}
311done
312cd ../../../../../..
313%endif
314
164020eb 315test -e Makefile || %{__python} build/gyp_chromium --format=make build/all.gyp \
f1b276d4
ER
316%ifarch %{ix86}
317 -Dtarget_arch=ia32 \
318%endif
319%ifarch %{x8664}
0c480b89
ER
320 -Dtarget_arch=x64 \
321%endif
7b454a31
AM
322%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
323 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4
ER
324%endif
325%if %{with sandboxing}
326 -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
327 -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
328%endif
329 %{!?debug:-Dwerror=} \
c980b122 330 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 331 %{?with_shared_libs:-Dlibrary=shared_library} \
37b05e5e 332 -Dbuild_ffmpegsumo=%{?with_ffmpegsumo:1}%{!?with_ffmpegsumo:0} \
a3140cd1
ER
333 -Dffmpeg_branding=Chrome \
334 -Dproprietary_codecs=1 \
c0808220 335%if %{with nacl}
c0808220 336 -Ddisable_glibc=1 \
038f76b9 337 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
338 -Ddisable_glibc_untar=1 \
339 -Ddisable_newlib_untar=1 \
340 -Ddisable_pnacl_untar=1 \
c0808220
ER
341%else
342 -Ddisable_nacl=1 \
343%endif
6c8531c6 344 -Ddisable_pnacl=1 \
a3140cd1
ER
345 %{!?with_sse2:-Ddisable_sse2=1} \
346 %{?with_selinux:-Dselinux=1} \
e7fa0817 347 %{gyp_with cups} \
e7fa0817
ER
348 %{gyp_with gconf} \
349 %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
350 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
351 %{gyp_with pulseaudio} \
8f5f6775 352 %{gyp_with system_flac} \
581aec44 353 %{gyp_with system_libusb} \
ba685303 354 %{gyp_with system_libwebp} \
e7fa0817
ER
355 %{gyp_with system_speex} \
356 %{gyp_with system_sqlite} \
357 %{gyp_with system_v8} \
32a2443e 358 %{gyp_with system_vpx} \
e7fa0817
ER
359 %{gyp_with system_yasm} \
360 %{gyp_with system_zlib} \
0c480b89 361 -Duse_system_bzip2=1 \
0b214002 362 -Duse_system_icu=1 \
f1b276d4 363 -Duse_system_libevent=1 \
0c480b89 364 -Duse_system_libjpeg=1 \
f1b276d4
ER
365 -Duse_system_libpng=1 \
366 -Duse_system_libxml=1 \
367 -Duse_system_libxslt=1 \
7f40f3f4 368 -Duse_system_xdg_utils=1 \
d8ba130c 369 %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
44f353ec
AM
370 -Dlinux_use_gold_binary=0 \
371 -Dlinux_use_gold_flags=0
11ad81c4 372
f1b276d4
ER
373%{__make} chrome %{?with_sandboxing:chrome_sandbox} \
374 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
375 %{?with_verbose:V=1} \
376 CC="%{__cc}" \
377 CXX="%{__cxx}" \
b7adf6b1 378 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
f1b276d4
ER
379 CC.host="%{__cc}" \
380 CXX.host="%{__cxx}" \
b7adf6b1 381 LDFLAGS.host="%{rpmldflags}" \
7b454a31
AM
382 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
383 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
11ad81c4
AM
384
385%install
386rm -rf $RPM_BUILD_ROOT
56c6e811 387install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
37ceaf05 388 $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
e266589e 389
f1b276d4 390cd src/out/%{!?debug:Release}%{?debug:Debug}
37ceaf05 391cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4
ER
392install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
393%{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
97fac491 394cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
7f40f3f4 395cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 396install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
e53ecfb5 397install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
d561483d 398%if %{with ffmpegsumo}
f1b276d4 399install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 400%endif
e7fa0817 401cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
164020eb 402
c0808220
ER
403%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
404
164020eb
ER
405%if %{with nacl}
406# Install Native Client files on platforms that support it.
407install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
408install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
409%ifarch %{x8664}
410install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
411%endif
412%ifarch %{ix86}
413install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
414%endif
415%endif
416
0c480b89
ER
417cd -
418
0eb19b0b
ER
419for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
420 size=${icon##*/product_logo_}
421 size=${size%.png}
422
423 # this will skip non-numeric (22_mono_invert, 22_mono)
424 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
425 test -d "$dir" || continue
426
427 install -d $RPM_BUILD_ROOT$dir
428 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
429done
7f40f3f4 430
13840bc2
AM
431%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
432# http://code.google.com/p/chromium/issues/detail?id=24507
433gecko-mediaplayer*.so
434EOF
11ad81c4 435
589d90ea
ER
436# find locales
437%find_lang %{name}.lang
e7fa0817 438# always package en-US
f1b276d4 439%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 440
11ad81c4
AM
441%clean
442rm -rf $RPM_BUILD_ROOT
443
f1b276d4 444%post
0eb19b0b 445%update_icon_cache hicolor
b7a6e4ee 446%update_desktop_database
f1b276d4
ER
447%update_browser_plugins
448
449%postun
450if [ "$1" = 0 ]; then
0eb19b0b 451 %update_icon_cache hicolor
f1b276d4
ER
452 %update_browser_plugins
453fi
454
1d2b9616 455%files
11ad81c4 456%defattr(644,root,root,755)
f1b276d4
ER
457%{_browserpluginsconfdir}/browsers.d/%{name}.*
458%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
459%dir %{_sysconfdir}/%{name}
460%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
f1b276d4
ER
461%attr(755,root,root) %{_bindir}/%{name}
462%{_mandir}/man1/%{name}.1*
11ad81c4 463%{_desktopdir}/*.desktop
0eb19b0b 464%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 465%dir %{_libdir}/%{name}
e9abb380 466%{_libdir}/%{name}/chrome*.pak
c14cd342 467%{_libdir}/%{name}/content_resources.pak
97fac491 468%{_libdir}/%{name}/resources.pak
589d90ea 469%dir %{_libdir}/%{name}/locales
f1b276d4
ER
470%{_libdir}/%{name}/locales/en-US.pak
471%dir %{_libdir}/%{name}/resources
a3140cd1 472%{_libdir}/%{name}/resources/inspector
f1b276d4
ER
473%dir %{_libdir}/%{name}/themes
474%dir %{_libdir}/%{name}/extensions
475%dir %{_libdir}/%{name}/plugins
476%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 477# These unique permissions are intentional and necessary for the sandboxing
e53ecfb5 478%attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
f1b276d4
ER
479
480# ffmpeg libs
d561483d 481%if %{with ffmpegsumo}
f1b276d4 482%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 483%endif
f1b276d4 484
164020eb
ER
485%if %{with nacl}
486%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
487%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
488%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
489%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
490%endif
491
f1b276d4
ER
492%files l10n -f %{name}.lang
493%defattr(644,root,root,755)
This page took 0.150776 seconds and 4 git commands to generate.