]> git.pld-linux.org Git - packages/chromium-browser.git/blame - chromium-browser.spec
build with system mesa (9.0 seems building ok)
[packages/chromium-browser.git] / chromium-browser.spec
CommitLineData
0c480b89
ER
1#
2# Conditional build:
ba685303 3%bcond_without cups # with cups
2108baf2 4%bcond_without debuginfo # disable debuginfo creation (it is huge)
ba685303 5%bcond_without gconf # with GConf
8171fe68 6%bcond_without kerberos # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
2108baf2 7%bcond_without keyring # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
71d49434 8%bcond_with gps # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
ba685303 9%bcond_without libjpegturbo # use libjpeg-turbo features
6c8531c6 10%bcond_without nacl # build Native Client support
ba685303 11%bcond_without pulseaudio # with pulseaudio
2108baf2
ER
12%bcond_without sandboxing # with sandboxing
13%bcond_with selinux # with SELinux (need policy first)
14%bcond_with shared_libs # with shared libs
15%bcond_with sse2 # use SSE2 instructions
ba685303 16%bcond_without system_flac # system flac
4e881737 17%bcond_without system_ffmpeg # system ffmpeg instead of ffmpegsumo
108c5f7c 18%bcond_without system_harfbuzz # system harfbuzz
ba685303 19%bcond_without system_jsoncpp # system jsoncpp
62950103
ER
20%bcond_without system_libexif # system libexif
21%bcond_without system_libmtp # system libmtp
ba685303
ER
22%bcond_without system_libusb # system libusb-1
23%bcond_without system_libwebp # system libwebp
4884fc99 24%bcond_without system_libxnvctrl # system libxnvctrl
25d4e23c 25%bcond_without system_mesa # system Mesa
126ea630 26%bcond_without system_minizip # system minizip
62950103 27%bcond_without system_opus # system opus codec support, http://www.opus-codec.org/examples/
108c5f7c 28%bcond_without system_protobuf # system protobuf
bbdce24d 29%bcond_with system_re2 # system re2
ba685303
ER
30%bcond_without system_speex # system speex
31%bcond_with system_sqlite # system sqlite
9bd2659c 32%bcond_without system_libsrtp # system srtp (can be used if using bundled libjingle)
ba685303 33%bcond_with system_v8 # system v8
7b8f219a 34%bcond_with system_libvpx # system libvpx
ba685303 35%bcond_without system_yasm # system yasm
1c00315b 36%bcond_without system_zlib # system zlib
d2781a31 37%bcond_without tcmalloc # use tcmalloc
7e136323 38%bcond_without verbose # verbose build (V=1)
0c480b89 39
6d92f81c 40# TODO
f1b276d4 41# - check system sqlite linking problems
2108baf2 42# - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
a3140cd1 43# - use_system_ssl (use_openssl: http://crbug.com/62803)
d617ab39 44# - use_system_hunspell
32a2443e 45# - use_system_stlport
a3140cd1 46# - other defaults: src/build/common.gypi
7b8f219a 47# - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
a3140cd1 48
e53ecfb5 49# NOTES:
4fe038cb
ER
50# - mute BEEP mixer if you do not want to hear horrible system bell when
51# pressing home/end in url bar or more ^F search results on page.
7c638678 52# - space considerations:
0bb93ab2 53# - unpacked sources: ~490MiB
c1ecd31f 54# - built code: ~1.4GiB (x86_64/i686)
f1b276d4 55# - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
84fa20a9 56# - to look for new tarball, use update-source.sh script
f1b276d4 57
e68aa7e7 58# NOTE TO USERS:
c8b02491 59# To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
a3cc7091 60# http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
c8b02491 61# http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
e68aa7e7 62
f2f193c6
ER
63%define branch 26.0.1410
64%define basever 12
92fcbe12 65#define patchver 70
a3140cd1 66%define gyp_rev 1014
11ad81c4 67Summary: A WebKit powered web browser
05f72ae2 68Name: chromium-browser
f73369da
ER
69%if "%{?patchver}" != ""
70Version: %{branch}.%{patchver}
71%else
72Version: %{branch}.%{basever}
73%endif
25d4e23c 74Release: 0.29
05f72ae2 75License: BSD, LGPL v2+ (ffmpeg)
e53ecfb5 76Group: X11/Applications/Networking
25d4e23c 77Source0: http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{branch}.%{basever}.tar.gz
b60866e3 78# Source0-md5: d005fc9e50c28a2e3c71eee7310417f4
3c73e180
ER
79%if "%{?patchver}" != ""
80Patch0: http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
f6284fe2 81# Patch0-md5: 37675cd75c578d26d6210259877f3947
3c73e180 82%endif
37ceaf05 83Source1: %{name}.default
8b53130d
ER
84Source2: %{name}.sh
85Source3: %{name}.desktop
56c6e811
ER
86Source5: find-lang.sh
87Source6: update-source.sh
88Source7: clean-source.sh
836b1cac 89Source8: get-source.sh
0562b864 90Source9: master_preferences.json
48b341f5 91Patch1: plugin-searchdirs.patch
70258ccd 92#Patch2: system-nspr.patch
7abc645c 93Patch3: disable_dlog_and_dcheck_in_release_builds.patch
72cb20c1 94Patch4: path-libpdf.patch
0e5636cb 95Patch6: get-webkit_revision.patch
5aa5df39 96Patch7: dlopen_sonamed_gl.patch
4765ddf1 97Patch8: chromium_useragent.patch.in
c0808220 98Patch9: chromium-ppapi.patch
8456d676 99Patch10: system-libxnvctrl.patch
1347c76c
AM
100# https://bugs.gentoo.org/show_bug.cgi?id=393471
101# libjpeg-turbo >= 1.1.90 supports that feature
f4a8da6a 102Patch11: chromium-revert-jpeg-swizzle-r2.patch
108c5f7c 103Patch12: system-ffmpeg.patch
5997e180
ER
104Patch15: nacl-build-irt.patch
105Patch16: nacl-linkingfix.patch
9516ca97 106Patch18: nacl-no-untar.patch
08b25440 107Patch19: system-jsoncpp.patch
6897926c 108Patch24: nacl-verbose.patch
c5b396f3
ER
109Patch25: gnome3-volume-control.patch
110Patch26: master-prefs-path.patch
d2781a31 111Patch27: tcmalloc-glibc2.16.patch
25d4e23c 112Patch28: system-mesa.patch
750b48f7 113URL: http://www.chromium.org/Home
ae3fe89f 114%{?with_gconf:BuildRequires: GConf2-devel}
7b8f219a 115%{?with_system_mesa:BuildRequires: Mesa-libGL-devel}
25d4e23c 116%{?with_system_mesa:BuildRequires: Mesa-libGLES-devel}
7b8f219a
ER
117%{?with_system_mesa:BuildRequires: Mesa-libGLU-devel}
118%{?with_system_mesa:BuildRequires: Mesa-libOSMesa-devel}
05f72ae2
ER
119BuildRequires: alsa-lib-devel
120BuildRequires: atk-devel
121BuildRequires: bison
11ad81c4 122BuildRequires: bzip2-devel
5997e180
ER
123%{?with_nacl:BuildRequires: crossnacl-binutils >= 2.20.1}
124%{?with_nacl:BuildRequires: crossnacl-gcc >= 4.4.3}
125%{?with_nacl:BuildRequires: crossnacl-gcc-c++ >= 4.4.3}
9516ca97 126%{?with_nacl:BuildRequires: crossnacl-newlib >= 1.20.0-3}
ae3fe89f 127%{?with_cups:BuildRequires: cups-devel}
92965b0e 128BuildRequires: elfutils-devel
77f32fa3 129BuildRequires: expat-devel
7d0dbc8d 130%{?with_system_ffmpeg:BuildRequires: ffmpeg-devel >= 1.0}
8f5f6775 131%{?with_system_flac:BuildRequires: flac-devel >= 1.2.1-7}
11ad81c4 132BuildRequires: fontconfig-devel
f1b276d4 133BuildRequires: glib2-devel
05f72ae2 134BuildRequires: gperf
71d49434 135%{?with_gps:BuildRequires: gpsd-devel}
bbad64b7 136BuildRequires: gtest-devel
8b53130d 137BuildRequires: gtk+2-devel
01b4dc8e 138%{?with_system_harfbuzz:BuildRequires: harfbuzz-devel}
a3140cd1 139%{?with_kerberos:BuildRequires: heimdal-devel}
0eb19b0b 140BuildRequires: hicolor-icon-theme
ed514974 141%{?with_system_jsoncpp:BuildRequires: jsoncpp-devel}
ef121064 142%{?with_system_libxnvctrl:BuildRequires: libXNVCtrl-devel >= 310.19}
05f72ae2 143BuildRequires: libevent-devel
8456d676 144%{?with_system_libexif:BuildRequires: libexif-devel >= 1:0.6.21}
7f40f3f4 145%{?with_keyring:BuildRequires: libgnome-keyring-devel}
0b214002 146BuildRequires: libicu-devel >= 4.6
39c71b4c 147%{!?with_libjpegturbo:BuildRequires: libjpeg-devel}
f4a8da6a 148%{?with_libjpegturbo:BuildRequires: libjpeg-turbo-devel >= 1.2.0}
8456d676 149%{?with_system_libmtp:BuildRequires: libmtp-devel >= 1.1.3}
05f72ae2 150BuildRequires: libpng-devel
e266589e 151%{?with_selinux:BuildRequires: libselinux-devel}
05f72ae2 152BuildRequires: libstdc++-devel
ba685303 153%{?with_system_libusb:BuildRequires: libusb-devel >= 1.0}
4b411ffe 154%{?with_system_libvpx:BuildRequires: libvpx-devel >= 0.9.5-2}
dd1509bd 155%{?with_system_libwebp:BuildRequires: libwebp-devel >= 0.1.99}
f1b276d4 156BuildRequires: libxml2-devel
11ad81c4 157BuildRequires: libxslt-devel
535cb410 158BuildRequires: man-db
62950103 159%{?with_system_minizip:BuildRequires: minizip-devel}
05f72ae2 160BuildRequires: nspr-devel
f1b276d4 161BuildRequires: nss-devel >= 1:3.12.3
8456d676 162%{?with_system_opus:BuildRequires: opus-devel >= 1.0.2}
35902862 163BuildRequires: pam-devel
f1b276d4 164BuildRequires: pango-devel
ef121064 165BuildRequires: pciutils-devel
48b341f5 166BuildRequires: perl-modules
167BuildRequires: pkgconfig
75a27c2e 168%{?with_system_protobuf:BuildRequires: protobuf-devel}
ae3fe89f 169%{?with_pulseaudio:BuildRequires: pulseaudio-devel}
f1b276d4 170BuildRequires: python
46cdefee 171#BuildRequires: python-gyp >= 1-%{gyp_rev}
48b341f5 172BuildRequires: python-modules
92965b0e 173BuildRequires: python-ply
71d49434 174%{?with_system_re2:BuildRequires: re2-devel}
0cad051b 175BuildRequires: rpm >= 4.4.9-56
f1b276d4 176BuildRequires: rpmbuild(macros) >= 1.453
0cad051b 177%{?with_system_speex:BuildRequires: speex-devel >= 1:1.2-rc1}
f1b276d4 178BuildRequires: sqlite3-devel >= 3.6.1
9bd2659c 179%{?with_system_libsrtp:BuildRequires: srtp-devel >= 1.4.4}
89f0dde4 180BuildRequires: subversion
0cad051b 181BuildRequires: tar >= 1:1.22
0a424ee2 182BuildRequires: udev-devel
7d1152d4 183BuildRequires: usbutils
2303ed45 184BuildRequires: util-linux
c14cd342 185%{?with_system_v8:BuildRequires: v8-devel >= 3.7}
0826c245 186BuildRequires: which
f1b276d4 187BuildRequires: xorg-lib-libXScrnSaver-devel
836b1cac 188BuildRequires: xz
a3140cd1 189%{?with_system_yasm:BuildRequires: yasm}
f1b276d4 190%{?with_system_zlib:BuildRequires: zlib-devel}
e53ecfb5 191Requires: browser-plugins >= 2.0
0cad051b 192Requires: desktop-file-utils
8f5f6775 193%{?with_system_flac:Requires: flac >= 1.2.1-7}
ae20377c
ER
194# crashes if no fontconfig font present
195Requires: fonts-Type1-urw
0eb19b0b 196Requires: hicolor-icon-theme
56403697 197Requires: libevent >= 2.0.21
c1edaafa 198%{?with_libjpegturbo:Requires: libjpeg-turbo >= 1.2.0}
4b411ffe 199%{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
b809ab60 200Requires: lsb-release
3700ba38 201Requires: shared-mime-info
4dc49133 202Requires: xdg-utils >= 1.0.2-4
2cbfc1a4 203Requires: xorg-lib-libX11 >= 1.4.99.1
e53ecfb5 204Provides: wwwbrowser
c3582150 205Obsoletes: chromium-browser-bookmark_manager < 5.0.388.0
a3140cd1 206Obsoletes: chromium-browser-inspector < 15.0.863.0
2351db3b 207ExclusiveArch: %{ix86} %{x8664} arm
11ad81c4 208BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11ad81c4 209
589d90ea 210%define find_lang sh find-lang.sh %{buildroot}
2446ebb3 211
e7fa0817
ER
212# Usage: gyp_with BCOND_NAME [OPTION_NAME]
213%define gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
589d90ea 214
6b113615
ER
215%if %{without debuginfo}
216%define _enable_debug_packages 0
217%endif
218
11ad81c4 219%description
80838854
ER
220Chromium is an open-source browser project that aims to build a safer,
221faster, and more stable way for all Internet users to experience the
222web.
223
224Chromium serves as a base for Google Chrome, which is Chromium
225rebranded (name and logo) with very few additions such as usage
226tracking and an auto-updater system.
227
f1b276d4
ER
228%package l10n
229Summary: chromium-browser language packages
230Group: I18n
231Requires: %{name} = %{version}-%{release}
232
233%description l10n
234Chromium is an open-source browser project that aims to build a safer,
235faster, and more stable way for all Internet users to experience the
236web.
237
238This package contains language packages for 50 languages:
239
e7fa0817
ER
240ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
241he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
242pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
243zh-TW
f1b276d4
ER
244
245%prep
3c73e180
ER
246%setup -qc
247%if "%{?patchver}" != ""
248cd %{name}-%{branch}.%{basever}
249%patch0 -p1
250cd ..
251%endif
252mv %{name}-%{branch}.%{basever}/src .
589d90ea 253
05f72ae2
ER
254# Google's versioning is interesting. They never reset "BUILD", which is how we jumped
255# from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
0c480b89
ER
256. ./src/chrome/VERSION
257ver=$MAJOR.$MINOR.$BUILD.$PATCH
a3140cd1
ER
258test "$ver" = %{version}
259
260gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
2d2c8139 261test "$gyp_rev" = %{gyp_rev} || :
05f72ae2 262
836b1cac 263v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
33b04c7d 264
4765ddf1
ER
265# add chromium and pld to useragent
266%define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
267sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
25d4e23c
ER
268 -e 's/@BUILD_DIST_NAME@/PLD/g' \
269 -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
270 < %{PATCH8} | %{__patch} -p1
4765ddf1 271
56c6e811
ER
272%{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
273ln -s %{SOURCE7} src
f1b276d4 274
05f72ae2 275%patch1 -p1
7abc645c 276%patch3 -p1
72cb20c1 277%patch4 -p1
0e5636cb 278%patch6 -p1
5aa5df39 279%patch7 -p1
42e551c9 280%patch10 -p1
e9abb380 281%patch15 -p1
77f32fa3 282cd src
c0808220 283%patch9 -p0
70258ccd 284#%patch2 -p1
f4a8da6a 285%{!?with_libjpegturbo:%patch11 -p0}
108c5f7c 286%patch12 -p1
5997e180 287%patch16 -p1
08b25440 288%patch19 -p1
d2781a31 289%patch27 -p1
1347c76c 290cd ..
f2f193c6 291%patch25 -p1
9516ca97 292%patch18 -p1
6897926c 293%patch24 -p1
c5b396f3 294%patch26 -p1
25d4e23c 295%patch28 -p1
0c480b89 296
828bdd1a 297cd src
e9abb380 298
75a27c2e
ER
299sh -x clean-source.sh \
300 %{!?with_nacl:nacl=0} \
bbdce24d
ER
301 %{!?with_system_libvpx:libvpx=0} \
302 %{!?with_system_libxnvctrl:libXNVCtrl=0} \
25d4e23c 303 %{!?with_system_mesa:mesa=0} \
75a27c2e 304 %{!?with_system_protobuf:protobuf=0} \
bbdce24d 305 %{!?with_system_re2:re2=0} \
75a27c2e
ER
306 %{!?with_system_v8:v8=0} \
307 %{!?with_system_zlib:zlib=0} \
308 %{nil}
fded59be 309
e266589e 310%build
f1b276d4 311cd src
5997e180
ER
312
313%if %{with nacl}
108c5f7c 314rm -rf native_client/toolchain/linux_x86_newlib
fded59be 315if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
dcea0d6b 316# Make symlinks for NaCL
108c5f7c 317install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
2e4113fd 318
108c5f7c
ER
319cd native_client/toolchain/linux_x86_newlib
320ln -s x86_64-nacl/bin bin
321cd x86_64-nacl/bin
2e4113fd 322__cc='%{__cc}'
f64e73f6 323if [ "${__cc#ccache}" != "$__cc" ]; then
2e4113fd
ER
324 echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
325 echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
326 %{__sed} -i -e '1i#!/bin/sh' gcc g++
327 chmod +x gcc g++
328else
329 ln -s %{_bindir}/x86_64-nacl-gcc gcc
330 ln -s %{_bindir}/x86_64-nacl-g++ g++
331fi
108c5f7c
ER
332ln -s gcc x86_64-nacl-gcc
333ln -s g++ x86_64-nacl-g++
334ln -s %{_bindir}/x86_64-nacl-ar .
5997e180
ER
335ln -s %{_bindir}/x86_64-nacl-ar ar
336ln -s %{_bindir}/x86_64-nacl-as as
108c5f7c 337ln -s %{_bindir}/x86_64-nacl-ranlib .
5997e180 338ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
108c5f7c 339ln -s %{_bindir}/x86_64-nacl-strip .
5997e180 340ln -s %{_bindir}/x86_64-nacl-strip strip
108c5f7c
ER
341ln -s %{_prefix}/x86_64-nacl/lib ../lib
342ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
dcea0d6b
ER
343ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
344cd ../../../../..
fded59be 345fi
5997e180
ER
346%endif
347
c5b396f3 348test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
b4d75247
ER
349test -e Makefile || \
350 CC="%{__cc}" \
351 CXX="%{__cxx}" \
352 LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
353 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
354 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
355%{__python} build/gyp_chromium \
673aee14
ER
356 --format=make \
357 -Goutput_dir=../out \
358 build/all.gyp \
f1b276d4
ER
359%ifarch %{ix86}
360 -Dtarget_arch=ia32 \
361%endif
362%ifarch %{x8664}
0c480b89
ER
363 -Dtarget_arch=x64 \
364%endif
7b454a31
AM
365%if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
366 -Dno_strict_aliasing=1 -Dgcc_version=44 \
f1b276d4
ER
367%endif
368%if %{with sandboxing}
369 -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
370 -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
371%endif
372 %{!?debug:-Dwerror=} \
c980b122 373 %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
f1b276d4 374 %{?with_shared_libs:-Dlibrary=shared_library} \
6e2c5572 375 %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1 -Dproprietary_codecs=1} \
b5a3dda3 376 -Dinclude_tests=0 \
c0808220 377%if %{with nacl}
038f76b9 378 -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
9516ca97
ER
379 -Ddisable_glibc_untar=1 \
380 -Ddisable_newlib_untar=1 \
8fb1dc98
ER
381 -Ddisable_glibc=1 \
382 -Ddisable_pnacl=1 \
383 -Dbuild_pnacl_newlib=0 \
c0808220 384%else
8fb1dc98 385 -Ddisable_pnacl_untar=1 \
c0808220
ER
386 -Ddisable_nacl=1 \
387%endif
a3140cd1
ER
388 %{!?with_sse2:-Ddisable_sse2=1} \
389 %{?with_selinux:-Dselinux=1} \
7d1152d4 390 -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
05998197
ER
391 -Dlinux_link_libpci=1 \
392 %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
71d49434 393 %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
05998197
ER
394 -Dlinux_use_gold_binary=0 \
395 -Dlinux_use_gold_flags=0 \
e7fa0817 396 %{gyp_with cups} \
8dda6bbc 397 %{gyp_with gconf} -Dlinux_link_gsettings=0 \
e7fa0817
ER
398 %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
399 %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
400 %{gyp_with pulseaudio} \
7d0dbc8d 401 %{gyp_with system_ffmpeg} \
8f5f6775 402 %{gyp_with system_flac} \
01b4dc8e 403 %{gyp_with system_harfbuzz} \
62950103
ER
404 %{gyp_with system_libexif} \
405 %{gyp_with system_libmtp} \
9bd2659c 406 %{gyp_with system_libsrtp} \
581aec44 407 %{gyp_with system_libusb} \
4b411ffe 408 %{gyp_with system_libvpx} \
ba685303 409 %{gyp_with system_libwebp} \
4884fc99 410 %{gyp_with system_libxnvctrl} \
7b8f219a 411 %{gyp_with system_mesa} \
126ea630 412 %{gyp_with system_minizip} \
62950103 413 %{gyp_with system_opus} \
75a27c2e 414 %{gyp_with system_protobuf} \
bbdce24d 415 %{gyp_with system_re2} \
e7fa0817
ER
416 %{gyp_with system_speex} \
417 %{gyp_with system_sqlite} \
418 %{gyp_with system_v8} \
419 %{gyp_with system_yasm} \
420 %{gyp_with system_zlib} \
0c480b89 421 -Duse_system_bzip2=1 \
62950103 422 -Duse_system_expat=1 \
0b214002 423 -Duse_system_icu=1 \
f1b276d4 424 -Duse_system_libevent=1 \
0c480b89 425 -Duse_system_libjpeg=1 \
f1b276d4
ER
426 -Duse_system_libpng=1 \
427 -Duse_system_libxml=1 \
428 -Duse_system_libxslt=1 \
7f40f3f4 429 -Duse_system_xdg_utils=1 \
11ad81c4 430
b4d75247 431# need {CC/CXX/LDFLAGS}.host overrides for v8 build
48ffbc5e 432%{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
f1b276d4
ER
433 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
434 %{?with_verbose:V=1} \
f1b276d4
ER
435 CC.host="%{__cc}" \
436 CXX.host="%{__cxx}" \
b4d75247 437 LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
11ad81c4 438
535cb410
ER
439cd ../out/%{!?debug:Release}%{?debug:Debug}
440MANWIDTH=80 man ./chrome.1 > man.out
441%{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
442
11ad81c4
AM
443%install
444rm -rf $RPM_BUILD_ROOT
56c6e811 445install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
37ceaf05 446 $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
e266589e 447
673aee14 448cd out/%{!?debug:Release}%{?debug:Debug}
37ceaf05 449cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
f1b276d4 450install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
535cb410
ER
451%{__sed} -i -e '
452 s,@libdir@,%{_libdir}/%{name},
453
454 /@OPTIONS@/ {
455 r options.txt
456 d
457 }
458' $RPM_BUILD_ROOT%{_bindir}/%{name}
97fac491 459cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
7f40f3f4 460cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
f1b276d4 461install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
e53ecfb5 462install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
fcc48c19 463%if %{without system_ffmpeg}
f1b276d4 464install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
dd46de65 465%endif
e7fa0817 466cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
0562b864 467cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
164020eb 468
c0808220
ER
469%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
470
164020eb
ER
471%if %{with nacl}
472# Install Native Client files on platforms that support it.
473install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
474install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
475%ifarch %{x8664}
476install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
477%endif
478%ifarch %{ix86}
479install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
480%endif
481%endif
482
0c480b89
ER
483cd -
484
0eb19b0b
ER
485for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
486 size=${icon##*/product_logo_}
487 size=${size%.png}
488
489 # this will skip non-numeric (22_mono_invert, 22_mono)
490 dir=%{_iconsdir}/hicolor/${size}x${size}/apps
491 test -d "$dir" || continue
492
493 install -d $RPM_BUILD_ROOT$dir
494 cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
495done
7f40f3f4 496
13840bc2
AM
497%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
498# http://code.google.com/p/chromium/issues/detail?id=24507
499gecko-mediaplayer*.so
500EOF
11ad81c4 501
589d90ea
ER
502# find locales
503%find_lang %{name}.lang
e7fa0817 504# always package en-US
f1b276d4 505%{__sed} -i -e '/en-US.pak/d' %{name}.lang
589d90ea 506
11ad81c4
AM
507%clean
508rm -rf $RPM_BUILD_ROOT
509
f1b276d4 510%post
0eb19b0b 511%update_icon_cache hicolor
b7a6e4ee 512%update_desktop_database
f1b276d4
ER
513%update_browser_plugins
514
515%postun
516if [ "$1" = 0 ]; then
0eb19b0b 517 %update_icon_cache hicolor
f1b276d4
ER
518 %update_browser_plugins
519fi
520
1d2b9616 521%files
11ad81c4 522%defattr(644,root,root,755)
531537e5 523%doc src/{AUTHORS,LICENSE}
f1b276d4
ER
524%{_browserpluginsconfdir}/browsers.d/%{name}.*
525%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
37ceaf05
ER
526%dir %{_sysconfdir}/%{name}
527%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
0562b864 528%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
f1b276d4
ER
529%attr(755,root,root) %{_bindir}/%{name}
530%{_mandir}/man1/%{name}.1*
11ad81c4 531%{_desktopdir}/*.desktop
0eb19b0b 532%{_iconsdir}/hicolor/*/apps/%{name}.png
0c480b89 533%dir %{_libdir}/%{name}
e9abb380 534%{_libdir}/%{name}/chrome*.pak
c14cd342 535%{_libdir}/%{name}/content_resources.pak
97fac491 536%{_libdir}/%{name}/resources.pak
589d90ea 537%dir %{_libdir}/%{name}/locales
f1b276d4
ER
538%{_libdir}/%{name}/locales/en-US.pak
539%dir %{_libdir}/%{name}/resources
a3140cd1 540%{_libdir}/%{name}/resources/inspector
f1b276d4
ER
541%dir %{_libdir}/%{name}/themes
542%dir %{_libdir}/%{name}/extensions
543%dir %{_libdir}/%{name}/plugins
544%attr(755,root,root) %{_libdir}/%{name}/%{name}
0c480b89 545# These unique permissions are intentional and necessary for the sandboxing
e53ecfb5 546%attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
f1b276d4
ER
547
548# ffmpeg libs
fcc48c19 549%if %{without system_ffmpeg}
f1b276d4 550%attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
dd46de65 551%endif
f1b276d4 552
164020eb
ER
553%if %{with nacl}
554%attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
555%attr(755,root,root) %{_libdir}/%{name}/nacl_helper
556%attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
557%attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
558%endif
559
f1b276d4
ER
560%files l10n -f %{name}.lang
561%defattr(644,root,root,755)
This page took 0.171553 seconds and 4 git commands to generate.