]> git.pld-linux.org Git - packages/cherokee.git/blame - cherokee.spec
- converted to UTF-8
[packages/cherokee.git] / cherokee.spec
CommitLineData
01abcdff
JB
1#
2# Conditional build:
1bdedc57 3%bcond_without php # adds PHP support
01abcdff 4%bcond_with mono # adds ASPX support
01d41beb 5%bcond_with gnomevfs # compile the gnomevfs handler (broken)
01abcdff
JB
6%bcond_without gnutls # build with tls=gnutls
7%bcond_with openssl # build with tls=openssl
01d41beb
ER
8#
9%if %{with gnutls} || %{with openssl}
10%define with_tls 1
11%endif
12Summary: Fast, Flexible and Lightweight Web server
fd499fdf 13Summary(pl.UTF-8): Cherokee - serwer WWW
0e85b34f 14Name: cherokee
01d41beb 15Version: 0.4.29
c61a601c 16Release: 0.15
01d41beb 17License: GPL v2
8c503f01 18Group: Networking/Daemons
01d41beb
ER
19Source0: http://www.0x50.org/download/0.4/0.4.29/%{name}-%{version}.tar.gz
20# Source0-md5: 854e6e61a69781746496012658d8ef98
21Source1: %{name}.init
22Source2: %{name}.sysconfig
1bdedc57
ER
23Patch0: %{name}-config.patch
24Patch1: %{name}-php-path.patch
01d41beb 25URL: http://www.0x50.org/
1bdedc57
ER
26BuildRequires: autoconf
27BuildRequires: automake
0e85b34f 28BuildRequires: fcgi-devel
01d41beb
ER
29%{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
30%{?with_gnutls:BuildRequires: gnutls-devel >= 0.9.99}
31%{?with_openssl:BuildRequires: openssl-devel}
cfbc51f9 32BuildRequires: pam-devel
01d41beb 33BuildRequires: pcre-devel
cfbc51f9 34BuildRequires: pkgconfig
1bdedc57 35BuildRequires: rpmbuild(macros) >= 1.268
cfbc51f9 36BuildRequires: zlib-devel
1bdedc57
ER
37Requires(post,postun): /sbin/ldconfig
38Requires(post,preun): rc-scripts
39Requires(postun): /usr/sbin/groupdel
40Requires(postun): /usr/sbin/userdel
41Requires(pre): /bin/id
42Requires(pre): /usr/bin/getgid
43Requires(pre): /usr/sbin/groupadd
44Requires(pre): /usr/sbin/useradd
45Provides: group(cherokee)
46Provides: group(http)
47Provides: user(cherokee)
bdfcbc7b 48Provides: webserver
8c503f01 49BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
0e85b34f 50
01d41beb
ER
51%define _sysconfdir /etc/cherokee
52%define _wwwhome /home/services/%{name}
53%define _wwwroot %{_wwwhome}/html
54
0e85b34f 55%description
01d41beb
ER
56Cherokee is a flexible, very fast, lightweight Web server. It is
57implemented entirely in C, and has no dependencies beyond a standard C
a40f27e9 58library. It is embeddable and extensible with plug-ins. It supports
01d41beb
ER
59on-the-fly configuration by reading files or strings, TLS/SSL (via
60GNUTLS or OpenSSL), virtual hosts, authentication, cache friendly
61features, PHP, custom error management, and much more.
0e85b34f 62
fd499fdf 63%description -l pl.UTF-8
a40f27e9 64Cherokee to elastyczny, bardzo szybki i lekki serwer WWW. Jest
fd499fdf
JR
65zaimplementowany całkowicie w C i nie ma zależności poza standardową
66biblioteką C. Jest osadzalny i rozbudowywalny poprzez wtyczki.
67Obsługuje konfigurację w locie poprzez odczyt plików lub łańcuchów
68znaków, TLS/SSL (poprzez GNUTLS lub OpenSSL), hosty wirtualne,
69uwierzytelnianie, opcje związane z pamięcią podręczną, PHP, własne
70zarządzanie błędami i wiele więcej.
8c503f01 71
0e85b34f 72%package devel
8c503f01 73Summary: Header files for Cherokee web server
fd499fdf 74Summary(pl.UTF-8): Pliki nagłówkowe dla serwera WWW Cherokee
8c503f01 75Group: Development/Libraries
01abcdff 76Requires: %{name} = %{version}-%{release}
0e85b34f 77
78%description devel
8c503f01
JB
79Header files for Cherokee web server.
80
fd499fdf
JR
81%description devel -l pl.UTF-8
82Pliki nagłówkowe dla serwera WWW Cherokee.
0e85b34f 83
84%prep
85%setup -q
1bdedc57
ER
86%patch0 -p1
87%patch1 -p1
0e85b34f 88
89%build
1bdedc57
ER
90%{__aclocal} -I m4
91%{__autoconf}
92%{__autoheader}
93%{__automake}
0e85b34f 94%configure \
01d41beb 95 --sysconfdir=/etc \
1bdedc57 96 --enable-os-string="PLD Linux" \
01d41beb 97 --with-wwwroot=%{_wwwroot} \
cfbc51f9 98 --disable-static \
01d41beb
ER
99 %{?with_gnomevfs:--enable-gnomevfs} \
100 %{?with_tls:--enable-tls=%{?with_gnutls:gnutls}%{?with_openssl:openssl}} \
101 --enable-pthreads \
1bdedc57 102 %{?with_php:--with-php=%{_prefix}} \
01d41beb
ER
103 %{?with_mono:--with-mono=DIR}
104
0e85b34f 105%{__make}
106
107%install
108rm -rf $RPM_BUILD_ROOT
2911a3cb 109install -d $RPM_BUILD_ROOT{/etc/{pam.d,sysconfig,rc.d/init.d},/var/log/%{name}}
8c503f01
JB
110
111%{__make} install \
112 DESTDIR=$RPM_BUILD_ROOT
113
01d41beb
ER
114install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
115install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
116
1bdedc57
ER
117# users don't need this
118mv $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/cherokee-panic
119mv $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/cherokee_logrotate
120
cfbc51f9
JB
121# modules dlopened by *.so
122rm -f $RPM_BUILD_ROOT%{_libdir}/cherokee/lib*.la
123
01d41beb
ER
124# unify manual dir
125rm -rf html
126mv $RPM_BUILD_ROOT%{_docdir}/%{name} html
127
8c503f01
JB
128%clean
129rm -rf $RPM_BUILD_ROOT
0e85b34f 130
1bdedc57
ER
131%pre
132%groupadd -g 161 cherokee
133%groupadd -g 51 http
134%useradd -u 161 -d %{_wwwhome} -c "Cherokee User" -g cherokee cherokee
135%addusertogroup cherokee http
136
01d41beb
ER
137%post
138/sbin/ldconfig
139/sbin/chkconfig --add %{name}
c61a601c
ER
140%service %{name} restart "Cherokee webserver"
141exit 0
01d41beb
ER
142
143%preun
144if [ "$1" = "0" ]; then
145 %service %{name} stop
146 /sbin/chkconfig --del %{name}
147fi
148
1bdedc57
ER
149%postun
150/sbin/ldconfig
151if [ "$1" = "0" ]; then
c61a601c
ER
152 %userremove cherokee
153 %groupremove cherokee
1bdedc57
ER
154 %groupremove http
155fi
cfbc51f9 156
0e85b34f 157%files
158%defattr(644,root,root,755)
01d41beb 159%doc AUTHORS ChangeLog TODO html
0adbe1dc
ER
160%dir %attr(750,root,root) %{_sysconfdir}
161%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cherokee.conf
162%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/icons.conf
163%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/advanced.conf
164%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mime.conf
165%dir %attr(750,root,root) %{_sysconfdir}/mods-available
166%dir %attr(750,root,root) %{_sysconfdir}/mods-enabled
167%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mods-available/admin
168%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mods-available/ssl
169%dir %attr(750,root,root) %{_sysconfdir}/sites-available
170%dir %attr(750,root,root) %{_sysconfdir}/sites-enabled
171%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sites-available/default
172%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sites-available/example.com
1bdedc57 173%config(missingok) %{_sysconfdir}/sites-enabled/default
0adbe1dc 174%dir %attr(750,root,root) %{_sysconfdir}/ssl
01d41beb 175
2911a3cb 176%config(noreplace) %verify(not md5 mtime size) /etc/pam.d/cherokee
01d41beb
ER
177%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cherokee
178%attr(754,root,root) /etc/rc.d/init.d/cherokee
179
180%attr(755,root,root) %{_bindir}/cget
01d41beb 181%attr(755,root,root) %{_sbindir}/cherokee
1bdedc57
ER
182%attr(755,root,root) %{_sbindir}/cherokee-panic
183%attr(755,root,root) %{_sbindir}/cherokee_logrotate
01d41beb 184
0e85b34f 185%dir %{_libdir}/cherokee
1bdedc57 186%attr(755,root,root) %{_libdir}/cherokee/libplugin_admin.so
01d41beb
ER
187%attr(755,root,root) %{_libdir}/cherokee/libplugin_cgi.so
188%attr(755,root,root) %{_libdir}/cherokee/libplugin_combined.so
189%attr(755,root,root) %{_libdir}/cherokee/libplugin_common.so
190%attr(755,root,root) %{_libdir}/cherokee/libplugin_dirlist.so
191%attr(755,root,root) %{_libdir}/cherokee/libplugin_error_redir.so
192%attr(755,root,root) %{_libdir}/cherokee/libplugin_fastcgi.so
193%attr(755,root,root) %{_libdir}/cherokee/libplugin_file.so
194%attr(755,root,root) %{_libdir}/cherokee/libplugin_gzip.so
195%attr(755,root,root) %{_libdir}/cherokee/libplugin_htdigest.so
196%attr(755,root,root) %{_libdir}/cherokee/libplugin_htpasswd.so
197%attr(755,root,root) %{_libdir}/cherokee/libplugin_ncsa.so
198%attr(755,root,root) %{_libdir}/cherokee/libplugin_nn.so
199%attr(755,root,root) %{_libdir}/cherokee/libplugin_pam.so
200%attr(755,root,root) %{_libdir}/cherokee/libplugin_phpcgi.so
201%attr(755,root,root) %{_libdir}/cherokee/libplugin_plain.so
202%attr(755,root,root) %{_libdir}/cherokee/libplugin_read_config.so
203%attr(755,root,root) %{_libdir}/cherokee/libplugin_redir.so
204%attr(755,root,root) %{_libdir}/cherokee/libplugin_server_info.so
205%attr(755,root,root) %{_libdir}/cherokee/libplugin_w3c.so
206%attr(755,root,root) %{_libdir}/libcherokee-base.so.*.*.*
207%attr(755,root,root) %{_libdir}/libcherokee-client.so.*.*.*
208%attr(755,root,root) %{_libdir}/libcherokee-config.so.*.*.*
209%attr(755,root,root) %{_libdir}/libcherokee-server.so.*.*.*
210
8c503f01 211%{_mandir}/man1/cherokee.1*
01d41beb
ER
212%{_mandir}/man1/cget.1*
213%{_mandir}/man1/cherokee_logrotate.1*
214
215%{_datadir}/cherokee
216
217%dir %{_wwwhome}
0adbe1dc
ER
218%dir %{_wwwroot}
219%config(missingok) %{_wwwroot}/*
220
221%dir %attr(750,root,logs) /var/log/%{name}
0e85b34f 222
223%files devel
8c503f01 224%defattr(644,root,root,755)
0e85b34f 225%attr(755,root,root) %{_bindir}/cherokee-config
01d41beb
ER
226
227%{_libdir}/libcherokee-base.la
228%{_libdir}/libcherokee-client.la
229%{_libdir}/libcherokee-config.la
230%{_libdir}/libcherokee-server.la
231
8c503f01
JB
232%{_includedir}/cherokee
233%{_pkgconfigdir}/cherokee.pc
234%{_aclocaldir}/cherokee.m4
235%{_mandir}/man1/cherokee-config.1*
This page took 0.084592 seconds and 4 git commands to generate.