]> git.pld-linux.org Git - packages/cherokee.git/blame - cherokee.spec
- admin subpackage separated
[packages/cherokee.git] / cherokee.spec
CommitLineData
abf5f06b 1# TODO:
56ea9d0b
JK
2# - does it requires spawn-fcgi?
3# - move modules to subpackages. At least, those with extra dependencies.
01abcdff
JB
4#
5# Conditional build:
3319fba3 6%bcond_without geoip # without GeoIP support
56ea9d0b
JK
7%bcond_without mysql # without MySQL support
8%bcond_without ldap # without LDAP support
9%bcond_without ffmpeg # without ffmpeg support
01d41beb 10#
01d41beb 11Summary: Fast, Flexible and Lightweight Web server
56ec7482 12Summary(pl.UTF-8): Cherokee - serwer WWW
0e85b34f 13Name: cherokee
3b7d94a5 14Version: 0.99.44
d8832580 15Release: 0.1
01d41beb 16License: GPL v2
8c503f01 17Group: Networking/Daemons
d8832580 18Source0: http://www.cherokee-project.com/download/0.99/%{version}/%{name}-%{version}.tar.gz
3b7d94a5 19# Source0-md5: 268e7130c12b441523de963f95b9b85d
01d41beb
ER
20Source1: %{name}.init
21Source2: %{name}.sysconfig
1bdedc57
ER
22Patch0: %{name}-config.patch
23Patch1: %{name}-php-path.patch
3b5f252d 24Patch2: %{name}-panic_path.patch
72ce7982 25URL: http://www.cherokee-project.com/
90a7df58 26%{?with_geoip:BuildRequires: GeoIP-devel}
1bdedc57
ER
27BuildRequires: autoconf
28BuildRequires: automake
56ea9d0b 29%{?with_ffmpeg:BuildRequires: ffmpeg-devel}
3319fba3 30BuildRequires: libtool
56ea9d0b
JK
31%{?with_mysql:BuildRequires: mysql-devel}
32%{?with_ldap:BuildRequires: openldap-devel}
abf5f06b 33BuildRequires: openssl-devel
cfbc51f9 34BuildRequires: pam-devel
01d41beb 35BuildRequires: pcre-devel
abf5f06b 36BuildRequires: php-fcgi
cfbc51f9 37BuildRequires: pkgconfig
8c2165c6 38BuildRequires: python-docutils
3319fba3 39BuildRequires: rpm-pythonprov
1bdedc57 40BuildRequires: rpmbuild(macros) >= 1.268
cfbc51f9 41BuildRequires: zlib-devel
1bdedc57
ER
42Requires(post,preun): rc-scripts
43Requires(postun): /usr/sbin/groupdel
44Requires(postun): /usr/sbin/userdel
45Requires(pre): /bin/id
46Requires(pre): /usr/bin/getgid
47Requires(pre): /usr/sbin/groupadd
48Requires(pre): /usr/sbin/useradd
d8be9859 49Requires: %{name}-libs = %{version}-%{release}
3319fba3 50Suggests: php-fcgi
e8c0b4db 51Suggests: %{name}-admin = %{version}-%{release}
1bdedc57
ER
52Provides: group(cherokee)
53Provides: group(http)
54Provides: user(cherokee)
bdfcbc7b 55Provides: webserver
8c503f01 56BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
0e85b34f 57
01d41beb
ER
58%define _sysconfdir /etc/cherokee
59%define _wwwhome /home/services/%{name}
60%define _wwwroot %{_wwwhome}/html
61
0e85b34f 62%description
01d41beb
ER
63Cherokee is a flexible, very fast, lightweight Web server. It is
64implemented entirely in C, and has no dependencies beyond a standard C
a40f27e9 65library. It is embeddable and extensible with plug-ins. It supports
abf5f06b 66on-the-fly configuration by reading files or strings, TLS/SSL via
67OpenSSL, virtual hosts, authentication, cache friendly features, PHP,
68custom error management, and much more.
0e85b34f 69
fd499fdf 70%description -l pl.UTF-8
a40f27e9 71Cherokee to elastyczny, bardzo szybki i lekki serwer WWW. Jest
fd499fdf
JR
72zaimplementowany całkowicie w C i nie ma zależności poza standardową
73biblioteką C. Jest osadzalny i rozbudowywalny poprzez wtyczki.
74Obsługuje konfigurację w locie poprzez odczyt plików lub łańcuchów
abf5f06b 75znaków, TLS/SSL poprzez OpenSSL, hosty wirtualne, uwierzytelnianie,
76opcje związane z pamięcią podręczną, PHP, własne zarządzanie błędami i
77wiele więcej.
8c503f01 78
e8c0b4db
JK
79%package admin
80Summary: Cherokee web server administration interface
81Summary(pl.UTF-8): Interfejs administracyjny serwera WWW Cherokee
82Group: Networking/Daemons
83Requires: python
84Requires: python-modules
85Requires: %{name} = %{version}-%{release}
d8be9859 86
e8c0b4db
JK
87%description admin
88Cherokee web server administration interface.
d8be9859 89
e8c0b4db
JK
90%description admin -l pl.UTF-8
91Interfejs administracyjny serwera WWW Cherokee.
d8be9859 92
0e85b34f 93%package devel
8c503f01 94Summary: Header files for Cherokee web server
56ec7482 95Summary(pl.UTF-8): Pliki nagłówkowe dla serwera WWW Cherokee
8c503f01 96Group: Development/Libraries
d8be9859 97Requires: %{name}-libs = %{version}-%{release}
0e85b34f 98
99%description devel
8c503f01
JB
100Header files for Cherokee web server.
101
fd499fdf
JR
102%description devel -l pl.UTF-8
103Pliki nagłówkowe dla serwera WWW Cherokee.
0e85b34f 104
e8c0b4db
JK
105%package libs
106Summary: Cherokee web server libraries
107Summary(pl.UTF-8): Biblioteki serwera WWW Cherokee
108Group: Libraries
109
110%description libs
111Cherokee web server libraries.
112
113%description libs -l pl.UTF-8
114Biblioteki serwera WWW Cherokee.
115
0e85b34f 116%prep
117%setup -q
1bdedc57
ER
118%patch0 -p1
119%patch1 -p1
3b5f252d 120%patch2 -p1
0e85b34f 121
122%build
3319fba3 123%{__libtoolize}
1bdedc57
ER
124%{__aclocal} -I m4
125%{__autoconf}
126%{__autoheader}
127%{__automake}
abf5f06b 128export PHPCGI=%{_bindir}/php.fcgi
0e85b34f 129%configure \
cfbc51f9 130 --disable-static \
3319fba3 131 --enable-os-string="PLD Linux" \
3319fba3
KK
132 --sysconfdir=/etc \
133 --with-wwwroot=%{_wwwroot} \
abf5f06b 134 --with-wwwuser=cherokee \
135 --with-wwwgroup=http \
56ea9d0b
JK
136 %{!?with_geoip:--without-geoip} \
137 %{!?with_mysql:--without-mysql} \
138 %{!?with_ffmpeg:--without-ffmpeg} \
139 %{!?with_ldap:--without-ldap}
0e85b34f 140%{__make}
141
142%install
143rm -rf $RPM_BUILD_ROOT
2911a3cb 144install -d $RPM_BUILD_ROOT{/etc/{pam.d,sysconfig,rc.d/init.d},/var/log/%{name}}
8c503f01
JB
145
146%{__make} install \
147 DESTDIR=$RPM_BUILD_ROOT
148
01d41beb
ER
149install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
150install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
151
1bdedc57
ER
152# users don't need this
153mv $RPM_BUILD_ROOT{%{_bindir},%{_sbindir}}/cherokee-panic
1bdedc57 154
cfbc51f9
JB
155# modules dlopened by *.so
156rm -f $RPM_BUILD_ROOT%{_libdir}/cherokee/lib*.la
157
01d41beb
ER
158# unify manual dir
159rm -rf html
160mv $RPM_BUILD_ROOT%{_docdir}/%{name} html
161
3b7d94a5
JK
162# provided via %doc
163rm $RPM_BUILD_ROOT/etc/cherokee/cherokee.conf.perf_sample
164
165%find_lang %{name}
166
8c503f01
JB
167%clean
168rm -rf $RPM_BUILD_ROOT
0e85b34f 169
1bdedc57
ER
170%pre
171%groupadd -g 161 cherokee
172%groupadd -g 51 http
173%useradd -u 161 -d %{_wwwhome} -c "Cherokee User" -g cherokee cherokee
174%addusertogroup cherokee http
175
01d41beb 176%post
01d41beb 177/sbin/chkconfig --add %{name}
c61a601c
ER
178%service %{name} restart "Cherokee webserver"
179exit 0
01d41beb
ER
180
181%preun
182if [ "$1" = "0" ]; then
183 %service %{name} stop
184 /sbin/chkconfig --del %{name}
185fi
186
1bdedc57 187%postun
1bdedc57 188if [ "$1" = "0" ]; then
c61a601c
ER
189 %userremove cherokee
190 %groupremove cherokee
1bdedc57
ER
191 %groupremove http
192fi
cfbc51f9 193
d8be9859
JB
194%post libs -p /sbin/ldconfig
195%postun libs -p /sbin/ldconfig
196
e8c0b4db 197%files
0e85b34f 198%defattr(644,root,root,755)
3b7d94a5 199%doc AUTHORS ChangeLog html contrib/*to*.py performance.conf.sample
0adbe1dc
ER
200%dir %attr(750,root,root) %{_sysconfdir}
201%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cherokee.conf
01d41beb 202
2911a3cb 203%config(noreplace) %verify(not md5 mtime size) /etc/pam.d/cherokee
01d41beb
ER
204%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cherokee
205%attr(754,root,root) /etc/rc.d/init.d/cherokee
206
207%attr(755,root,root) %{_bindir}/cget
72ce7982 208%attr(755,root,root) %{_bindir}/cherokee-tweak
01d41beb 209%attr(755,root,root) %{_sbindir}/cherokee
3319fba3
KK
210%attr(755,root,root) %{_sbindir}/cherokee-panic
211%attr(755,root,root) %{_sbindir}/cherokee-worker
01d41beb 212
0e85b34f 213%dir %{_libdir}/cherokee
1bdedc57 214%attr(755,root,root) %{_libdir}/cherokee/libplugin_admin.so
72ce7982 215%attr(755,root,root) %{_libdir}/cherokee/libplugin_and.so
abf5f06b 216%attr(755,root,root) %{_libdir}/cherokee/libplugin_authlist.so
217%attr(755,root,root) %{_libdir}/cherokee/libplugin_bind.so
01d41beb
ER
218%attr(755,root,root) %{_libdir}/cherokee/libplugin_cgi.so
219%attr(755,root,root) %{_libdir}/cherokee/libplugin_combined.so
220%attr(755,root,root) %{_libdir}/cherokee/libplugin_common.so
3319fba3 221%attr(755,root,root) %{_libdir}/cherokee/libplugin_custom_error.so
abf5f06b 222%attr(755,root,root) %{_libdir}/cherokee/libplugin_custom.so
56ea9d0b 223%{?with_mysql:%attr(755,root,root) %{_libdir}/cherokee/libplugin_dbslayer.so}
3319fba3 224%attr(755,root,root) %{_libdir}/cherokee/libplugin_deflate.so
72ce7982 225%attr(755,root,root) %{_libdir}/cherokee/libplugin_directory.so
01d41beb 226%attr(755,root,root) %{_libdir}/cherokee/libplugin_dirlist.so
abf5f06b 227%attr(755,root,root) %{_libdir}/cherokee/libplugin_empty_gif.so
3319fba3 228%attr(755,root,root) %{_libdir}/cherokee/libplugin_error_nn.so
01d41beb 229%attr(755,root,root) %{_libdir}/cherokee/libplugin_error_redir.so
abf5f06b 230%attr(755,root,root) %{_libdir}/cherokee/libplugin_evhost.so
231%attr(755,root,root) %{_libdir}/cherokee/libplugin_exists.so
72ce7982 232%attr(755,root,root) %{_libdir}/cherokee/libplugin_extensions.so
3b7d94a5 233#%attr(755,root,root) %{_libdir}/cherokee/libplugin_fastcgi.so
8c2165c6 234%attr(755,root,root) %{_libdir}/cherokee/libplugin_fcgi.so
01d41beb 235%attr(755,root,root) %{_libdir}/cherokee/libplugin_file.so
abf5f06b 236%attr(755,root,root) %{_libdir}/cherokee/libplugin_from.so
237%attr(755,root,root) %{_libdir}/cherokee/libplugin_fullpath.so
0a169935 238%{?with_geoip:%attr(755,root,root) %{_libdir}/cherokee/libplugin_geoip.so}
01d41beb 239%attr(755,root,root) %{_libdir}/cherokee/libplugin_gzip.so
72ce7982 240%attr(755,root,root) %{_libdir}/cherokee/libplugin_header.so
01d41beb
ER
241%attr(755,root,root) %{_libdir}/cherokee/libplugin_htdigest.so
242%attr(755,root,root) %{_libdir}/cherokee/libplugin_htpasswd.so
abf5f06b 243%attr(755,root,root) %{_libdir}/cherokee/libplugin_ip_hash.so
56ea9d0b 244%{?with_ldap:%attr(755,root,root) %{_libdir}/cherokee/libplugin_ldap.so}
abf5f06b 245%attr(755,root,root) %{_libdir}/cherokee/libplugin_libssl.so
246%attr(755,root,root) %{_libdir}/cherokee/libplugin_method.so
56ea9d0b 247%{?with_mysql:%attr(755,root,root) %{_libdir}/cherokee/libplugin_mysql.so}
01d41beb 248%attr(755,root,root) %{_libdir}/cherokee/libplugin_ncsa.so
72ce7982
PZ
249%attr(755,root,root) %{_libdir}/cherokee/libplugin_not.so
250%attr(755,root,root) %{_libdir}/cherokee/libplugin_or.so
01d41beb 251%attr(755,root,root) %{_libdir}/cherokee/libplugin_pam.so
01d41beb 252%attr(755,root,root) %{_libdir}/cherokee/libplugin_plain.so
3b7d94a5
JK
253%attr(755,root,root) %{_libdir}/cherokee/libplugin_post_report.so
254%attr(755,root,root) %{_libdir}/cherokee/libplugin_post_track.so
3319fba3 255%attr(755,root,root) %{_libdir}/cherokee/libplugin_proxy.so
01d41beb 256%attr(755,root,root) %{_libdir}/cherokee/libplugin_redir.so
abf5f06b 257%attr(755,root,root) %{_libdir}/cherokee/libplugin_rehost.so
258%attr(755,root,root) %{_libdir}/cherokee/libplugin_render_rrd.so
72ce7982 259%attr(755,root,root) %{_libdir}/cherokee/libplugin_request.so
8c2165c6 260%attr(755,root,root) %{_libdir}/cherokee/libplugin_round_robin.so
abf5f06b 261%attr(755,root,root) %{_libdir}/cherokee/libplugin_rrd.so
8c2165c6 262%attr(755,root,root) %{_libdir}/cherokee/libplugin_scgi.so
abf5f06b 263%attr(755,root,root) %{_libdir}/cherokee/libplugin_secdownload.so
01d41beb 264%attr(755,root,root) %{_libdir}/cherokee/libplugin_server_info.so
abf5f06b 265%attr(755,root,root) %{_libdir}/cherokee/libplugin_ssi.so
266%attr(755,root,root) %{_libdir}/cherokee/libplugin_streaming.so
267%attr(755,root,root) %{_libdir}/cherokee/libplugin_target_ip.so
3b7d94a5 268%attr(755,root,root) %{_libdir}/cherokee/libplugin_url_arg.so
abf5f06b 269%attr(755,root,root) %{_libdir}/cherokee/libplugin_uwsgi.so
270%attr(755,root,root) %{_libdir}/cherokee/libplugin_wildcard.so
01d41beb 271
01d41beb 272%{_mandir}/man1/cget.1*
72ce7982 273%{_mandir}/man1/cherokee.1*
3319fba3
KK
274%{_mandir}/man1/cherokee-tweak.1*
275%{_mandir}/man1/cherokee-worker.1*
01d41beb 276
72ce7982 277%dir %{_datadir}/cherokee
72ce7982
PZ
278%{_datadir}/cherokee/deps
279%{_datadir}/cherokee/icons
72ce7982 280%{_datadir}/cherokee/themes
01d41beb
ER
281
282%dir %{_wwwhome}
0adbe1dc
ER
283%dir %{_wwwroot}
284%config(missingok) %{_wwwroot}/*
285
3319fba3 286%dir %attr(750,cherokee,logs) /var/log/%{name}
0e85b34f 287
e8c0b4db
JK
288%files admin -f %{name}.lang
289%defattr(644,root,root,755)
290%attr(755,root,root) %{_sbindir}/cherokee-admin
291%{_mandir}/man1/cherokee-admin.1*
292%dir %{_datadir}/cherokee/admin
293%{_datadir}/cherokee/admin/cherokee.conf.sample
294%{_datadir}/cherokee/admin/performance.conf.sample
295%{_datadir}/cherokee/admin/*.html
296%attr(755,root,root) %{_datadir}/cherokee/admin/*.py
297%{_datadir}/cherokee/admin/static
298
d8be9859
JB
299%files libs
300%defattr(644,root,root,755)
301%attr(755,root,root) %{_libdir}/libcherokee-base.so.*.*.*
302%attr(755,root,root) %ghost %{_libdir}/libcherokee-base.so.0
303%attr(755,root,root) %{_libdir}/libcherokee-client.so.*.*.*
304%attr(755,root,root) %ghost %{_libdir}/libcherokee-client.so.0
305%attr(755,root,root) %{_libdir}/libcherokee-config.so.*.*.*
306%attr(755,root,root) %ghost %{_libdir}/libcherokee-config.so.0
307%attr(755,root,root) %{_libdir}/libcherokee-server.so.*.*.*
308%attr(755,root,root) %ghost %{_libdir}/libcherokee-server.so.0
309
0e85b34f 310%files devel
8c503f01 311%defattr(644,root,root,755)
0e85b34f 312%attr(755,root,root) %{_bindir}/cherokee-config
72ce7982 313%attr(755,root,root) %{_libdir}/libcherokee-base.so
72ce7982 314%attr(755,root,root) %{_libdir}/libcherokee-client.so
72ce7982 315%attr(755,root,root) %{_libdir}/libcherokee-config.so
72ce7982 316%attr(755,root,root) %{_libdir}/libcherokee-server.so
d8be9859
JB
317%{_libdir}/libcherokee-base.la
318%{_libdir}/libcherokee-client.la
319%{_libdir}/libcherokee-config.la
320%{_libdir}/libcherokee-server.la
8c503f01
JB
321%{_includedir}/cherokee
322%{_pkgconfigdir}/cherokee.pc
323%{_aclocaldir}/cherokee.m4
324%{_mandir}/man1/cherokee-config.1*
This page took 0.073186 seconds and 4 git commands to generate.