]> git.pld-linux.org Git - packages/chef.git/blame - chef.spec
up to 11.6.0
[packages/chef.git] / chef.spec
CommitLineData
8354a17e
ER
1#
2# Conditional build:
3%bcond_with tests # build without tests
4
e307965b
ER
5Summary: A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure
6Name: chef
f0820095
ER
7Version: 11.6.0
8Release: 1
e307965b
ER
9License: Apache v2.0
10Group: Development/Languages
e307965b 11Source0: http://rubygems.org/downloads/%{name}-%{version}.gem
f0820095 12# Source0-md5: 3e8f67a5d11144573cf2c8d520ca39a6
5cb2f1b0 13Source1: %{name}.rb
7abbc83b 14Patch0: platform-pld.patch
bc8e6547 15Patch1: FHS.patch
31feaf16 16Patch2: https://github.com/glensc/chef/compare/poldek.patch
fd17fe50 17# Patch2-md5: de55627051f1e0486d29814eb305c7f4
7fbe09ae 18Patch3: https://github.com/glensc/chef/compare/pld-knife-boostrap.patch
d261b596 19# Patch3-md5: bfc884469fad7b5aa46341402be5fccd
2a1bbc08 20URL: http://wiki.opscode.com/display/chef
303651f6
ER
21BuildRequires: rpm-rubyprov
22BuildRequires: rpmbuild(macros) >= 1.656
68cfa14e
ER
23BuildRequires: sed >= 4.0
24%if %{with tests}
8354a17e 25BuildRequires: ruby-abstract
f0820095
ER
26BuildRequires: ruby-chef-zero < 2
27BuildRequires: ruby-chef-zero >= 1.4
8354a17e 28BuildRequires: ruby-mixlib-authentication >= 1.3.0
55a45456 29BuildRequires: ruby-net-ssh-multi >= 1.1.0
f0820095
ER
30BuildRequires: ruby-puma < 2
31BuildRequires: ruby-puma >= 1.6
68cfa14e
ER
32BuildRequires: ruby-rack
33BuildRequires: ruby-rake
8354a17e 34#BuildRequires: ruby-rdoc
55a45456 35BuildRequires: ruby-rest-client >= 1.0.4
68cfa14e
ER
36BuildRequires: ruby-rspec-core >= 2.12.0
37BuildRequires: ruby-rspec-expectations >= 2.12.0
38BuildRequires: ruby-rspec-mocks >= 2.12.0
8354a17e
ER
39#BuildRequires: ruby-rspec_junit_formatter
40#BuildRequires: ruby-sdoc
68cfa14e 41%endif
97e7edae 42Requires: lsb-release
31feaf16 43Requires: poldek >= 0.30
f0820095 44Requires: ruby >= 1:1.9.3.429-4
bce16be1 45Requires: ruby-erubis
2a1bbc08 46Requires: ruby-highline >= 1.6.9
2a1bbc08
ER
47Requires: ruby-json >= 1.4.4
48Requires: ruby-mixlib-authentication >= 1.3.0
49Requires: ruby-mixlib-cli >= 1.3.0
bce16be1
ER
50Requires: ruby-mixlib-config >= 1.1.2
51Requires: ruby-mixlib-log >= 1.3.0
2a1bbc08
ER
52Requires: ruby-mixlib-shellout
53Requires: ruby-net-ssh >= 2.6
54Requires: ruby-net-ssh-multi >= 1.1.0
55Requires: ruby-ohai >= 0.6.0
2a1bbc08 56Requires: ruby-rest-client >= 1.0.4
bce16be1 57Requires: ruby-rubygems
2a1bbc08 58Requires: ruby-yajl >= 1.1
e307965b
ER
59BuildArch: noarch
60BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62%description
63A systems integration framework, built to bring the benefits of
64configuration management to your entire infrastructure.
65
66%prep
303651f6 67%setup -q
7abbc83b 68%patch0 -p1
bc8e6547 69%patch1 -p1
31feaf16 70%patch2 -p1
7fbe09ae 71%patch3 -p1
e307965b 72
68cfa14e
ER
73%{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
74
8354a17e
ER
75%build
76%if %{with tests}
77rspec spec
78%endif
79
e307965b
ER
80%install
81rm -rf $RPM_BUILD_ROOT
958b507e 82install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir},%{_mandir}/man1} \
bc8e6547 83 $RPM_BUILD_ROOT{%{_sysconfdir},/var/{cache,lib}}/%{name}
68cfa14e 84cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
e307965b 85cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
958b507e 86cp -a distro/common/man/* $RPM_BUILD_ROOT%{_mandir}
e307965b 87
5cb2f1b0 88cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/chef.rb
303651f6 89
bce16be1
ER
90%clean
91rm -rf $RPM_BUILD_ROOT
92
e307965b
ER
93%files
94%defattr(644,root,root,755)
2a1bbc08 95%doc README.md CONTRIBUTING.md
303651f6 96%dir %{_sysconfdir}/%{name}
5cb2f1b0 97%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/chef.rb
2a1bbc08 98%attr(755,root,root) %{_bindir}/chef-apply
e307965b 99%attr(755,root,root) %{_bindir}/chef-client
f0820095 100%attr(755,root,root) %{_bindir}/chef-service-manager
2a1bbc08 101%attr(755,root,root) %{_bindir}/chef-shell
e307965b
ER
102%attr(755,root,root) %{_bindir}/chef-solo
103%attr(755,root,root) %{_bindir}/knife
104%attr(755,root,root) %{_bindir}/shef
958b507e
ER
105%{_mandir}/man1/chef-shell.1*
106%{_mandir}/man1/knife-bootstrap.1*
107%{_mandir}/man1/knife-client.1*
108%{_mandir}/man1/knife-configure.1*
109%{_mandir}/man1/knife-cookbook-site.1*
110%{_mandir}/man1/knife-cookbook.1*
111%{_mandir}/man1/knife-data-bag.1*
112%{_mandir}/man1/knife-environment.1*
113%{_mandir}/man1/knife-exec.1*
114%{_mandir}/man1/knife-index.1*
115%{_mandir}/man1/knife-node.1*
116%{_mandir}/man1/knife-role.1*
117%{_mandir}/man1/knife-search.1*
118%{_mandir}/man1/knife-ssh.1*
119%{_mandir}/man1/knife-status.1*
120%{_mandir}/man1/knife-tag.1*
121%{_mandir}/man1/knife.1*
122%{_mandir}/man8/chef-client.8*
123%{_mandir}/man8/chef-expander.8*
124%{_mandir}/man8/chef-expanderctl.8*
125%{_mandir}/man8/chef-server-webui.8*
126%{_mandir}/man8/chef-server.8*
127%{_mandir}/man8/chef-solo.8*
128%{_mandir}/man8/chef-solr.8*
68cfa14e
ER
129%{ruby_vendorlibdir}/chef.rb
130%{ruby_vendorlibdir}/chef
303651f6 131
bc8e6547
ER
132%dir /var/lib/%{name}
133%dir /var/cache/%{name}
This page took 0.239804 seconds and 4 git commands to generate.