]> git.pld-linux.org Git - packages/chef.git/blame - chef.spec
up to 11.10.0
[packages/chef.git] / chef.spec
CommitLineData
4613dfe7
ER
1# NOTE:
2# - check releases here: https://github.com/opscode/chef/releases
3
8354a17e
ER
4# Conditional build:
5%bcond_with tests # build without tests
6
e307965b
ER
7Summary: A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure
8Name: chef
5165006a
ER
9Version: 11.10.0
10Release: 1
e307965b
ER
11License: Apache v2.0
12Group: Development/Languages
e307965b 13Source0: http://rubygems.org/downloads/%{name}-%{version}.gem
5165006a 14# Source0-md5: ede47f0c92ad10bd08399228dbf1d8c7
5cb2f1b0 15Source1: %{name}.rb
02d95ccd 16Source2: %{name}.tmpfiles
5c13348f
ER
17Source3: https://raw.github.com/stevendanna/knife-hacks/master/shell/knife_completion.sh
18# Source3-md5: a4c1e41370be8088a59ddb3b2e7ea397
7abbc83b 19Patch0: platform-pld.patch
bc8e6547 20Patch1: FHS.patch
31feaf16 21Patch2: https://github.com/glensc/chef/compare/poldek.patch
ffde0717 22# Patch2-md5: 8fd92d572b7ebce759e9034097bfc399
7fbe09ae 23Patch3: https://github.com/glensc/chef/compare/pld-knife-boostrap.patch
d261b596 24# Patch3-md5: bfc884469fad7b5aa46341402be5fccd
4613dfe7 25URL: https://wiki.opscode.com/display/chef/
303651f6 26BuildRequires: rpm-rubyprov
5c13348f 27BuildRequires: rpmbuild(macros) >= 1.673
68cfa14e
ER
28BuildRequires: sed >= 4.0
29%if %{with tests}
30BuildRequires: ruby-rack
31BuildRequires: ruby-rake
5165006a
ER
32BuildRequires: ruby-rspec-core < 2.15
33BuildRequires: ruby-rspec-core >= 2.14.0
34BuildRequires: ruby-rspec-expectations < 2.15
35BuildRequires: ruby-rspec-expectations >= 2.14.0
36BuildRequires: ruby-rspec-mocks < 2.15
37BuildRequires: ruby-rspec-mocks >= 2.14.0
38BuildRequires: ruby-rspec_junit_formatter
68cfa14e 39%endif
97e7edae 40Requires: lsb-release
31feaf16 41Requires: poldek >= 0.30
f0820095 42Requires: ruby >= 1:1.9.3.429-4
e8757686 43Requires: ruby-diff-lcs < 2
e8757686 44Requires: ruby-diff-lcs >= 1.2.4
5165006a
ER
45Requires: ruby-erubis < 3
46Requires: ruby-erubis >= 2.7
47Requires: ruby-highline < 2
2a1bbc08 48Requires: ruby-highline >= 1.6.9
5165006a 49Requires: ruby-json <= 1.8.1
2a1bbc08 50Requires: ruby-json >= 1.4.4
e8757686
ER
51Requires: ruby-mime-types < 2
52Requires: ruby-mime-types >= 1.16
5165006a
ER
53Requires: ruby-mixlib-authentication < 2
54Requires: ruby-mixlib-authentication >= 1.3
55Requires: ruby-mixlib-cli < 2
56Requires: ruby-mixlib-cli >= 1.4
e8757686
ER
57Requires: ruby-mixlib-config < 3
58Requires: ruby-mixlib-config >= 2.0
5165006a
ER
59Requires: ruby-mixlib-log < 2
60Requires: ruby-mixlib-log >= 1.3
61Requires: ruby-mixlib-shellout < 2
62Requires: ruby-mixlib-shellout >= 1.3
63Requires: ruby-net-ssh < 3
2a1bbc08 64Requires: ruby-net-ssh >= 2.6
5165006a
ER
65Requires: ruby-net-ssh-multi < 2
66Requires: ruby-net-ssh-multi >= 1.1
e8757686
ER
67Requires: ruby-ohai < 7
68Requires: ruby-ohai >= 6.0
5165006a 69Requires: ruby-rest-client < 1.7.0
2a1bbc08 70Requires: ruby-rest-client >= 1.0.4
bce16be1 71Requires: ruby-rubygems
5165006a 72Requires: ruby-yajl < 2
2a1bbc08 73Requires: ruby-yajl >= 1.1
5165006a 74Suggests: chef-zero >= 1.7
e307965b
ER
75BuildArch: noarch
76BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
820f7abc
ER
78# do not generate python dependency, yum support is optional
79%define _noautoreqfiles %{ruby_vendorlibdir}/chef/provider/package/yum-dump.py
80
e307965b
ER
81%description
82A systems integration framework, built to bring the benefits of
83configuration management to your entire infrastructure.
84
5c13348f
ER
85%package -n bash-completion-knife
86Summary: bash-completion for knife
87Summary(pl.UTF-8): bashowe uzupełnianie nazw dla knifea
88Group: Applications/Shells
89Requires: %{name} >= 0.10
90Requires: bash-completion >= 2.0
91
92%description -n bash-completion-knife
93This package provides bash-completion for knife.
94
95%description -n bash-completion-knife -l pl.UTF-8
96Pakiet ten dostarcza bashowe uzupełnianie nazw dla knifea.
97
be8cf7bb
ER
98%package -n knife
99Summary: knife - Chef Server API client utility
100Group: Development/Languages
101Requires: %{name} = %{version}-%{release}
102
103%description -n knife
104Knife is a command-line utility used to manage data on a Chef server
105through the HTTP(S) API. Knife is organized into groups of subcommands
106centered around the various object types in Chef. Each category of
107subcommand is documented in its own manual page.
108
e307965b 109%prep
303651f6 110%setup -q
7abbc83b 111%patch0 -p1
bc8e6547 112%patch1 -p1
31feaf16 113%patch2 -p1
7fbe09ae 114%patch3 -p1
e307965b 115
68cfa14e
ER
116%{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
117
5165006a
ER
118# cleanup backups after patching
119find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
120
121grep --exclude-dir=spec --exclude-dir=distro -r /var/chef . && exit 1
122
8354a17e
ER
123%build
124%if %{with tests}
125rspec spec
126%endif
127
e307965b
ER
128%install
129rm -rf $RPM_BUILD_ROOT
f972dda7
ER
130install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_bindir},%{_mandir}/man1,%{systemdtmpfilesdir}} \
131 $RPM_BUILD_ROOT%{ruby_vendorlibdir}/chef/reporting \
132 $RPM_BUILD_ROOT/var/{run/%{name},cache/%{name},lib/%{name}/{roles,data_bags,environments,backup}}
66164e90 133
68cfa14e 134cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
e307965b 135cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
958b507e 136cp -a distro/common/man/* $RPM_BUILD_ROOT%{_mandir}
23fa8236 137%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/README.md
e307965b 138
5cb2f1b0 139cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/chef.rb
02d95ccd 140cp -p %{SOURCE2} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
303651f6 141
5c13348f
ER
142install -d $RPM_BUILD_ROOT%{bash_compdir}
143cp -p %{SOURCE3} $RPM_BUILD_ROOT%{bash_compdir}/knife
144
bce16be1
ER
145%clean
146rm -rf $RPM_BUILD_ROOT
147
e307965b
ER
148%files
149%defattr(644,root,root,755)
2a1bbc08 150%doc README.md CONTRIBUTING.md
303651f6 151%dir %{_sysconfdir}/%{name}
5cb2f1b0 152%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/chef.rb
2a1bbc08 153%attr(755,root,root) %{_bindir}/chef-apply
e307965b 154%attr(755,root,root) %{_bindir}/chef-client
f0820095 155%attr(755,root,root) %{_bindir}/chef-service-manager
2a1bbc08 156%attr(755,root,root) %{_bindir}/chef-shell
e307965b 157%attr(755,root,root) %{_bindir}/chef-solo
e307965b 158%attr(755,root,root) %{_bindir}/shef
958b507e 159%{_mandir}/man1/chef-shell.1*
be8cf7bb
ER
160%{_mandir}/man8/chef-client.8*
161%{_mandir}/man8/chef-solo.8*
162%{ruby_vendorlibdir}/chef.rb
163%{ruby_vendorlibdir}/chef
164%exclude %{ruby_vendorlibdir}/chef/knife
165%exclude %{ruby_vendorlibdir}/chef/application/knife.rb
166%exclude %{ruby_vendorlibdir}/chef/chef_fs/knife.rb
167%exclude %{ruby_vendorlibdir}/chef/knife.rb
168%{systemdtmpfilesdir}/chef.conf
169
170%dir /var/lib/%{name}
171%dir /var/lib/%{name}/roles
172%dir /var/lib/%{name}/data_bags
173%dir /var/lib/%{name}/environments
7e5aff6c 174%dir %attr(750,root,root) /var/lib/%{name}/backup
be8cf7bb
ER
175
176%dir /var/cache/%{name}
177%dir /var/run/%{name}
178
179%files -n knife
180%defattr(644,root,root,755)
181%attr(755,root,root) %{_bindir}/knife
182%{ruby_vendorlibdir}/chef/knife.rb
183%{ruby_vendorlibdir}/chef/knife
184%{ruby_vendorlibdir}/chef/application/knife.rb
185%{ruby_vendorlibdir}/chef/chef_fs/knife.rb
958b507e
ER
186%{_mandir}/man1/knife-bootstrap.1*
187%{_mandir}/man1/knife-client.1*
188%{_mandir}/man1/knife-configure.1*
189%{_mandir}/man1/knife-cookbook-site.1*
190%{_mandir}/man1/knife-cookbook.1*
191%{_mandir}/man1/knife-data-bag.1*
23fa8236
ER
192%{_mandir}/man1/knife-delete.1*
193%{_mandir}/man1/knife-deps.1*
194%{_mandir}/man1/knife-diff.1*
195%{_mandir}/man1/knife-download.1*
196%{_mandir}/man1/knife-edit.1*
958b507e
ER
197%{_mandir}/man1/knife-environment.1*
198%{_mandir}/man1/knife-exec.1*
23fa8236
ER
199%{_mandir}/man1/knife-index-rebuild.1*
200%{_mandir}/man1/knife-list.1*
958b507e 201%{_mandir}/man1/knife-node.1*
23fa8236
ER
202%{_mandir}/man1/knife-raw.1*
203%{_mandir}/man1/knife-recipe-list.1*
958b507e
ER
204%{_mandir}/man1/knife-role.1*
205%{_mandir}/man1/knife-search.1*
23fa8236 206%{_mandir}/man1/knife-show.1*
958b507e
ER
207%{_mandir}/man1/knife-ssh.1*
208%{_mandir}/man1/knife-status.1*
209%{_mandir}/man1/knife-tag.1*
23fa8236
ER
210%{_mandir}/man1/knife-upload.1*
211%{_mandir}/man1/knife-user.1*
212%{_mandir}/man1/knife-xargs.1*
958b507e 213%{_mandir}/man1/knife.1*
303651f6 214
5c13348f
ER
215%files -n bash-completion-knife
216%defattr(644,root,root,755)
217%{bash_compdir}/knife
This page took 0.105849 seconds and 4 git commands to generate.