]> git.pld-linux.org Git - packages/busybox.git/blame - busybox.spec
- rel 3; fixes CVE-2014-4607
[packages/busybox.git] / busybox.spec
CommitLineData
e7982b05 1# TODO:
a54ace54
CM
2# - review patch 3. Updated to 1.17.3, but the code changed so much it's unclear
3# if it still serves a purpose
4# - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
5# - make internal commands work even if busybox is not in /bin/busybox (initrd)
6# or when /proc is not mounted (static / normal)
598da0d3 7#
2678f462 8# Conditional build:
b5011fd7 9# alternative busybox config file (replaces default one) you should
4a69c6c5 10# define cfgfile macro, i.e.
d635bde0 11#
6f6b5afa 12# rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
a54ace54 13#
2678f462
JB
14%bcond_with altconfig # use alternative config (defined by cfgfile)
15%bcond_with linkfl # creates links to busybox binary and puts them into file list
63de0802 16%bcond_without dynamic # don't build dynamic (base) version
3637c580
JR
17%bcond_without static # don't build static version
18%bcond_without initrd # don't build initrd version
19%bcond_with dietlibc # build dietlibc-based initrd and static versions
20%bcond_with glibc # build glibc-based initrd and static versions
494a100b 21%bcond_without verbose # verbose build
d635bde0 22# Options below are useful, when you want fileutils and grep providing.
23# For example, ash package requires fileutils and grep.
2678f462
JB
24%bcond_with fileutl_prov # adds fileutils providing
25%bcond_with grep_prov # adds grep providing
d635bde0 26# Option below is useful, when busybox is built with shell support.
2678f462 27%bcond_with sh_prov # adds /bin/sh providing
6b50dd3e 28# WARNING! Shell, fileutils and grep providing may depend on config file!
d635bde0 29# Fileutils, grep and shell provided with busybox have not such
30# functionality as their GNU countenders.
2678f462 31#
c15e3058 32%ifnarch %{ix86} %{x8664} ppc
1735ff25
MM
33%define with_glibc 1
34%endif
dce89576 35Summary: Set of common Unix utilities for embeded systems
718bff43
ER
36Summary(pl.UTF-8): Zestaw narzędzi uniksowych dla systemów wbudowanych
37Summary(pt_BR.UTF-8): BusyBox é um conjunto de utilitários UNIX em um único binário
ee61dafa 38Name: busybox
586f52e3 39# stable line only
6477eb94 40Version: 1.22.1
9bdfc4a3 41Release: 3
bbbc183d 42License: GPL v2
d79d7625 43Group: Applications
693dc2a0 44Source0: http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
6477eb94 45# Source0-md5: 337d1a15ab1cb1d4ed423168b1eb7d7e
4f8fe04f
AM
46Source1: %{name}.config
47Source2: %{name}-initrd.config
8f98fac8 48%{?with_altconfig:Source3: %{cfgfile}}
6477eb94
AM
49Patch100: http://busybox.net/downloads/fixes-1.22.1/busybox-1.22.1-ash.patch
50# Patch100-md5: 538d8cddbdfc449239b25a40bc8d1575
51Patch101: http://busybox.net/downloads/fixes-1.22.1/busybox-1.22.1-date.patch
52# Patch101-md5: bc381f9ceb3824141c968f5bc4353943
53Patch102: http://busybox.net/downloads/fixes-1.22.1/busybox-1.22.1-iplink.patch
54# Patch102-md5: 24686ec2750a8703feb57fc9c6aaed1d
494a100b
AM
55Patch103: http://busybox.net/downloads/fixes-1.22.1/busybox-1.22.1-nc.patch
56# Patch103-md5: 69eecaae5f812d08655dfdf34b60503f
9bdfc4a3
AM
57Patch104: http://busybox.net/downloads/fixes-1.22.1/busybox-1.22.1-lzop.patch
58# Patch104-md5: 14fb3bf7ffaba153b3cad385677b18c3
59Patch105: http://busybox.net/downloads/fixes-1.22.1/busybox-1.22.1-zcat-no-ext.patch
60# Patch105-md5: 158c8c4c73db6d920bdd7d4b9b65b2a5
b2b9509f 61Patch1: %{name}-logconsole.patch
62Patch2: %{name}-printf-gettext.patch
63Patch3: %{name}-loadfont.patch
29a4a582
JR
64Patch4: %{name}-kernel_headers.patch
65Patch5: %{name}-insmod-morearchs.patch
66Patch6: %{name}-dhcp.patch
67Patch7: %{name}-fix_64_archs.patch
29a4a582 68Patch9: %{name}-ash-export-PATH.patch
87902b66 69URL: http://www.busybox.net/
255676bf 70BuildRequires: gcc >= 3.2
839c36a5 71BuildRequires: perl-tools-pod
d41f35db 72BuildRequires: rpmbuild(macros) >= 1.652
ef0df9c1 73%if %{with initrd} || %{with static}
6f6b5afa 74 %if %{with dietlibc}
1735ff25 75BuildRequires: dietlibc-static
6f6b5afa 76 %else
77 %if %{with glibc}
1735ff25 78BuildRequires: glibc-static
6f6b5afa 79 %else
cbbddfaa 80%if "%{_target_base_arch}" != "%{_host_base_arch}"
9922ba41 81BuildRequires: cross%{_target_base_arch}-uClibc-static
9a45af3a 82%else
9922ba41 83 %ifarch ppc %{x8664}
c574afd9 84BuildRequires: uClibc-static >= 3:0.9.30.1
9922ba41 85 %else
c574afd9 86BuildRequires: uClibc-static >= 3:0.9.30.1
9922ba41 87 %endif
9a45af3a 88%endif
6f6b5afa 89 %endif
90 %endif
1735ff25 91%endif
a54ace54 92%{?with_sh_prov:Provides: /bin/sh}
2678f462
JB
93%{?with_fileutl_prov:Provides: fileutils}
94%{?with_grep_prov:Provides: grep}
ee61dafa
MM
95BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
96
e7982b05 97%define _bindir /bin
fc11b50f 98
cbbddfaa 99%if "%{_target_base_arch}" != "%{_host_base_arch}"
9922ba41 100 %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
101%else
102 %define CrossOpts %{nil}
103%endif
104
558ca139
JR
105%define filterout_ld -Wl,-z,(combreloc|relro)
106
ee61dafa 107%description
65512310 108BusyBox combines tiny versions of many common UNIX utilities into a
109single small executable. It provides minimalist replacements for most
110of the utilities you usually find in fileutils, shellutils, findutils,
111textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
112POSIX environment for any small or embedded system. The utilities in
113BusyBox generally have fewer options than their full-featured GNU
114cousins; however, the options that are included provide the expected
115functionality and behave very much like their GNU counterparts.
116
117BusyBox has been written with size-optimization and limited resources
118in mind. It is also extremely modular so you can easily include or
119exclude commands (or features) at compile time. This makes it easy to
120customize your embedded systems. To create a working system, just add
121a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
122ae).
ee61dafa 123
c499e458
JR
124%description -l pl.UTF-8
125BusyBox składa małe wersje wielu narzędzi uniksowych w jeden mały plik
126wykonywalny. Zapewnia minimalne zastępniki większości narzędzi
b7f899e9 127zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
c499e458
JR
128tar itp. BusyBox daje w miarę kompletne środowisko POSIX dla małych
129lub wbudowanych systemów. Narzędzia mają mniej opcji niż ich pełne
130odpowiedniki GNU, ale mają podstawową funkcjonalność. Do działającego
b7f899e9
JB
131systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
132(np. elvis-tiny albo ae).
133
c499e458
JR
134%description -l pt_BR.UTF-8
135BusyBox combina versões reduzidas de muitos utilitários UNIX num único
136executável, fornecendo substitutos minimalistas para muitos dos
137executáveis encontrados em pacotes como fileutils, shellutils,
138findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
139em geral têm menos opções que os utilitários GNU, mas as opções
68092394 140implementadas comportam-se de maneira similar aos equivalentes GNU.
141
34ec6041
JB
142%package static
143Summary: Static busybox
718bff43 144Summary(pl.UTF-8): Statycznie skonsolidowany busybox
34ec6041 145Group: Applications
34ec6041
JB
146
147%description static
148Static busybox.
149
c499e458 150%description static -l pl.UTF-8
dfafd31f 151Statycznie skonsolidowany busybox.
34ec6041 152
52db7bd4
MM
153%package initrd
154Summary: Static busybox for initrd
718bff43 155Summary(pl.UTF-8): Statycznie skonsolidowany busybox dla initrd
11aa4d91 156Group: Base
1857f402 157Conflicts: geninitrd < 10000.20
52db7bd4
MM
158
159%description initrd
160Static busybox for initrd.
161
c499e458 162%description initrd -l pl.UTF-8
dfafd31f 163Statycznie skonsolidowany busybox dla initrd.
52db7bd4 164
ee61dafa 165%prep
693dc2a0 166%setup -q
6477eb94
AM
167%patch100 -p1
168%patch101 -p1
169%patch102 -p1
494a100b 170%patch103 -p1
0b555ee8
JB
171%patch1 -p1
172%patch2 -p1
a54ace54 173#%patch3 -p1
0cf45dc5 174%patch4 -p1
0b555ee8 175%patch5 -p1
5a7abf9a 176%patch6 -p1
0b555ee8 177%patch7 -p1
586f52e3 178%patch9 -p1
ea0cda84 179
ee61dafa 180%build
839c36a5 181install -d built
52db7bd4 182%if %{with initrd}
4f8fe04f
AM
183install %{SOURCE2} .config
184%{__make} oldconfig
52db7bd4 185%{__make} \
91a4c8e3 186 %{?with_verbose:V=1} \
95f61a42 187 CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
63de0802 188 LDFLAGS="%{rpmldflags} -static" \
27ca3ce9 189%if %{with dietlibc}
52db7bd4 190 LIBRARIES="-lrpc" \
661e2e64 191 CC="diet %{__cc}"
1735ff25
MM
192%else
193%if %{with glibc}
9922ba41 194 %{CrossOpts} \
1735ff25 195 CC="%{__cc}"
27ca3ce9 196%else
cbbddfaa 197 %if "%{_target_base_arch}" != "%{_host_base_arch}"
9922ba41 198 CROSS="%{_target_cpu}-uclibc-" \
a54ace54 199 %endif
27ca3ce9
AM
200 CC="%{_target_cpu}-uclibc-gcc"
201%endif
1735ff25
MM
202%endif
203
839c36a5 204mv -f busybox built/busybox.initrd
52db7bd4 205%{__make} clean
52db7bd4
MM
206%endif
207
1735ff25
MM
208%if %{with altconfig}
209install %{SOURCE3} .config
13fc95fb
ER
210%else
211install %{SOURCE1} .config
1735ff25
MM
212%endif
213
4a69c6c5 214%if %{with static}
4f8fe04f 215%{__make} oldconfig
6f6b5afa 216%{__make} \
91a4c8e3 217 %{?with_verbose:V=1} \
ef0df9c1 218 CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
63de0802 219 LDFLAGS="%{rpmldflags} -static" \
ef0df9c1
JR
220%if %{with dietlibc}
221 LIBRARIES="-lrpc" \
661e2e64 222 CC="diet %{__cc}"
ef0df9c1
JR
223%else
224%if %{with glibc}
225 %{CrossOpts} \
52db7bd4 226 CC="%{__cc}"
ef0df9c1 227%else
cbbddfaa 228 %if "%{_target_base_arch}" != "%{_host_base_arch}"
ef0df9c1 229 CROSS="%{_target_cpu}-uclibc-" \
a54ace54 230 %endif
ef0df9c1
JR
231 CC="%{_target_cpu}-uclibc-gcc"
232%endif
233%endif
234
839c36a5 235mv -f busybox built/busybox.static
2481202a 236%{__make} clean
34ec6041 237%endif
2481202a 238
63de0802 239%if %{with dynamic}
b5011fd7 240%{__make} oldconfig
b7f899e9 241%{__make} \
91a4c8e3 242 %{?with_verbose:V=1} \
9922ba41 243 %{CrossOpts} \
b7f899e9 244 CFLAGS_EXTRA="%{rpmcflags}" \
63de0802 245 LDFLAGS="%{rpmldflags}" \
f5ad7fd6 246 CC="%{__cc}"
bf1f4257 247%{__make} busybox.links docs/busybox.1
63de0802 248%endif
4e2ab1f5 249
ee61dafa
MM
250%install
251rm -rf $RPM_BUILD_ROOT
b7f899e9 252
63de0802
JB
253%if %{with static}
254install -d $RPM_BUILD_ROOT%{_bindir}
255install built/busybox.static $RPM_BUILD_ROOT%{_bindir}
256%endif
257
a71afd72
JR
258%if %{with initrd}
259install -d $RPM_BUILD_ROOT%{_libdir}/initrd
1857f402 260install built/busybox.initrd $RPM_BUILD_ROOT%{_libdir}/initrd/busybox
a71afd72 261%endif
34ec6041 262
63de0802
JB
263%if %{with dynamic}
264install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
b7f899e9 265install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
bf1f4257 266install docs/busybox.1 $RPM_BUILD_ROOT%{_mandir}/man1
ee61dafa 267
d635bde0 268# install links to busybox binary, when linkfl is defined
4a69c6c5 269%if %{with linkfl}
2678f462 270%{__make} install \
5a7abf9a 271 PREFIX=$RPM_BUILD_ROOT
4a69c6c5
MM
272%else
273install busybox $RPM_BUILD_ROOT%{_bindir}
274%endif
63de0802 275%endif
d635bde0 276
ee61dafa
MM
277%clean
278rm -rf $RPM_BUILD_ROOT
279
63de0802 280%if %{with dynamic}
ee61dafa
MM
281%files
282%defattr(644,root,root,755)
a230e0df 283%doc AUTHORS README .config
d635bde0 284
4a69c6c5 285%if %{with linkfl}
77109ddb 286%attr(755,root,root) /bin/*
d635bde0 287%attr(755,root,root) /sbin/*
288%attr(755,root,root) %{_bindir}/*
289%attr(755,root,root) %{_sbindir}/*
4a69c6c5
MM
290%else
291%attr(755,root,root) %{_bindir}/busybox
d635bde0 292%endif
293
65512310 294%{_libdir}/busybox
77109ddb 295%{_mandir}/man1/busybox.1*
63de0802 296%endif
bb4ca08e 297
4a69c6c5 298%if %{with static}
34ec6041
JB
299%files static
300%defattr(644,root,root,755)
301%attr(755,root,root) %{_bindir}/busybox.static
302%endif
52db7bd4
MM
303
304%if %{with initrd}
305%files initrd
306%defattr(644,root,root,755)
1857f402 307%attr(755,root,root) %{_libdir}/initrd/busybox
52db7bd4 308%endif
This page took 0.231686 seconds and 4 git commands to generate.