]> git.pld-linux.org Git - packages/btparser.git/blame - btparser.spec
- package missing dir
[packages/btparser.git] / btparser.spec
CommitLineData
7dc4c325
JR
1Summary: Parser and analyzer for backtraces produced by GDB
2Name: btparser
3Version: 0.20
f277cb5b 4Release: 2
7dc4c325
JR
5License: GPL v2
6Group: Applications
7Source0: https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.xz
8# Source0-md5: dac50574a3015d6ca6eb588a2efb4686
9URL: http://fedorahosted.org/btparser
10%ifarch %{x8664}
11BuildRequires: binutils-static
12%endif
13BuildRequires: python-devel
14BuildRequires: python-distribute
15BuildRequires: rpm-pythonprov
16Requires: %{name}-libs = %{version}-%{release}
17BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19%description
20Btparser is a backtrace parser and analyzer, which works with
21backtraces produced by the GNU Project Debugger. It can parse a text
22file with a backtrace to a tree of C structures, allowing to analyze
23the threads and frames of the backtrace and work with them.
24
25Btparser also contains some backtrace manipulation and extraction
26routines:
27- it can find a frame in the crash-time backtrace where the program
28 most likely crashed (a chance is that the function described in that
29 frame is buggy)
30- it can produce a duplication hash of the backtrace, which helps to
31 discover that two crash-time backtraces are duplicates, triggered by
32 the same flaw of the code
33- it can "rate" the backtrace quality, which depends on the number of
34 frames with and without the function name known (missing function
35 name is caused by missing debugging symbols)
36
37%package libs
38Summary: Btparser library
39Summary(pl.UTF-8): Biblioteka btparser
40Group: Libraries
41Requires: python-libs
42Requires: python-modules
43
44%description libs
45Btparser libraries
46
47%description libs -l pl.UTF-8
48Biblioteka btparser.
49
50%package devel
51Summary: Header files for %{name} library
52Summary(pl.UTF-8): Pliki nagłówkowe biblioteki %{name}
53Group: Development/Libraries
54Requires: %{name}-libs = %{version}-%{release}
55
56%description devel
57Header files for %{name} library.
58
59%description devel -l pl.UTF-8
60Pliki nagłówkowe biblioteki %{name}.
61
62%package -n python-btparser
63Summary: Python bindings for %{name}
64Group: Development/Libraries
65Requires: %{name}-libs = %{version}-%{release}
66
67%description -n python-btparser
68Python bindings for %{name}.
69
70%prep
71%setup -q
72
73%build
74%ifarch %{x8664}
75%configure \
76 --enable-fingerprints
77%else
78%configure
79%endif
80%{__make}
81
82%install
83rm -rf $RPM_BUILD_ROOT
84
85%{__make} install \
86 DESTDIR=$RPM_BUILD_ROOT
87
88%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la $RPM_BUILD_ROOT%{py_sitedir}/btparser/*.la
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93%post libs -p /sbin/ldconfig
94%postun libs -p /sbin/ldconfig
95
96%files
97%defattr(644,root,root,755)
98%doc ChangeLog NEWS README RELEASE TODO
99%attr(755,root,root) %{_bindir}/btparser
100%{_mandir}/man1/btparser.1*
101
102%files libs
103%defattr(644,root,root,755)
104%attr(755,root,root) %{_libdir}/libbtparser.so.*.*
105%attr(755,root,root) %ghost %{_libdir}/libbtparser.so.2
106
107%files devel
108%defattr(644,root,root,755)
109%{_pkgconfigdir}/btparser.pc
110%{_includedir}/btparser
111%{_libdir}/libbtparser.so
112
113%files -n python-btparser
f277cb5b 114%dir %{py_sitedir}/btparser
7dc4c325
JR
115%{py_sitedir}/btparser/*.py*
116%attr(755,root,root) %{py_sitedir}/btparser/*.so
This page took 0.066445 seconds and 4 git commands to generate.