]> git.pld-linux.org Git - packages/bctoolbox.git/blame - bctoolbox.spec
- turn off ENABLE_STRICT (because of mbedtls vs gcc 11 -Werror=stringop-overflow)
[packages/bctoolbox.git] / bctoolbox.spec
CommitLineData
581c6399
JB
1#
2# Conditional build:
beede8b7 3%bcond_without dtls_srtp # DTLS SRTP support
581c6399
JB
4%bcond_without static_libs # static libraries
5
beede8b7
JB
6%if %{with dtls_srtp}
7%define mbedtls_ver 2.26.0-2
8%else
9%define mbedtls_ver 2
10%endif
82032e80 11Summary: Utility library for software from Belledonne Communications
581c6399 12Summary(pl.UTF-8): Biblioteka narzędziowa dla oprogramowania firmy Belledonne Communications
82032e80 13Name: bctoolbox
beede8b7
JB
14Version: 4.5.15
15Release: 1
232d9ea8 16License: GPL v3+
82032e80 17Group: Libraries
232d9ea8
JB
18#Source0Download: https://gitlab.linphone.org/BC/public/bctoolbox/tags
19Source0: https://gitlab.linphone.org/BC/public/bctoolbox/-/archive/%{version}/%{name}-%{version}.tar.bz2
beede8b7 20# Source0-md5: 479fd5eaa6242d8622f957744794f541
82032e80 21URL: https://linphone.org/
232d9ea8
JB
22# with junit xml support
23BuildRequires: bcunit-devel >= 3.0.2-3.20200822
581c6399 24BuildRequires: cmake >= 2.8.12
232d9ea8 25BuildRequires: libdecaf-devel
581c6399 26BuildRequires: libstdc++-devel >= 6:4.7
beede8b7 27BuildRequires: mbedtls-devel >= %{mbedtls_ver}
581c6399 28BuildRequires: sed >= 4.0
beede8b7 29Requires: mbedtls >= %{mbedtls_ver}
82032e80
AM
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33Utilities library used by Belledonne Communications softwares like
34belle-sip, mediastreamer2 and linphone.
35
581c6399
JB
36%description -l pl.UTF-8
37Biblioteka narzędziowa używana w oprogramowaniu firmy Belledonne
38Communications, takim jak belle-sip, mediastreamer2 czy linphone.
39
82032e80 40%package devel
581c6399
JB
41Summary: Header files for bctoolbox libraries
42Summary(pl.UTF-8): Pliki nagłówkowe bibliotek bctoolbox
82032e80 43Group: Development/Libraries
581c6399 44Requires: %{name} = %{version}-%{release}
232d9ea8 45Requires: libdecaf-devel
beede8b7 46Requires: mbedtls-devel >= %{mbedtls_ver}
82032e80
AM
47
48%description devel
581c6399
JB
49Header files for bctoolbox libraries.
50
51%description devel -l pl.UTF-8
52Pliki nagłówkowe bibliotek bctoolbox.
53
54%package static
55Summary: Static bctoolbox libraries
56Summary(pl.UTF-8): Statyczne biblioteki bctoolbox
57Group: Development/Libraries
58Requires: %{name}-devel = %{version}-%{release}
59
60%description static
61Static bctoolbox libraries.
62
63%description static -l pl.UTF-8
64Statyczne biblioteki bctoolbox.
82032e80
AM
65
66%prep
67%setup -q
68
69%build
70install -d build
71cd build
581c6399 72%cmake .. \
ef607d11
JB
73 %{!?with_static_libs:-DENABLE_STATIC=OFF} \
74 -DENABLE_STRICT=OFF
82032e80
AM
75
76%{__make}
77
78%install
79rm -rf $RPM_BUILD_ROOT
80
81%{__make} -C build install \
82 DESTDIR=$RPM_BUILD_ROOT
83
581c6399 84# disable completeness check incompatible with split packaging
232d9ea8 85%{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d; /^unset(_IMPORT_CHECK_TARGETS)/d' $RPM_BUILD_ROOT%{_datadir}/bctoolbox/cmake/bctoolboxTargets.cmake
581c6399 86
82032e80
AM
87%clean
88rm -rf $RPM_BUILD_ROOT
89
581c6399
JB
90%post -p /sbin/ldconfig
91%postun -p /sbin/ldconfig
82032e80
AM
92
93%files
94%defattr(644,root,root,755)
232d9ea8 95%doc CHANGELOG.md README.md
581c6399
JB
96%attr(755,root,root) %{_libdir}/libbctoolbox.so.1
97%attr(755,root,root) %{_libdir}/libbctoolbox-tester.so.1
82032e80
AM
98
99%files devel
100%defattr(644,root,root,755)
101%attr(755,root,root) %{_libdir}/libbctoolbox.so
102%attr(755,root,root) %{_libdir}/libbctoolbox-tester.so
103%{_includedir}/bctoolbox
104%{_pkgconfigdir}/bctoolbox.pc
105%{_pkgconfigdir}/bctoolbox-tester.pc
581c6399
JB
106%dir %{_datadir}/bctoolbox
107%{_datadir}/bctoolbox/cmake
108
109%if %{with static_libs}
110%files static
111%defattr(644,root,root,755)
112%{_libdir}/libbctoolbox.a
113%{_libdir}/libbctoolbox-tester.a
114%endif
This page took 0.0911650000000001 seconds and 4 git commands to generate.