]> git.pld-linux.org Git - packages/bacula-web.git/blame - bacula-web.spec
- release 2 (by relup.sh)
[packages/bacula-web.git] / bacula-web.spec
CommitLineData
97184a12
ER
1# TODO
2# - lighttpd support
3%define php_min_version 5.3.4
138953e5 4%include /usr/lib/rpm/macros.php
eba56fc5
ER
5Summary: Open source monitoring and reporting tool for Bacula
6Name: bacula-web
5e3bbf5d 7Version: 6.0.0
f5b51469 8Release: 2
eba56fc5
ER
9License: GPL v2
10Group: Applications/WWW
5e3bbf5d
JK
11Source0: http://www.bacula-web.org/download/articles/bacula-web-600.html?file=files/bacula-web.org/downloads/%{name}-%{version}.tgz
12# Source0-md5: 3e99f9626cf4329ce43947f11a9d8f49
eba56fc5 13Source1: apache.conf
138953e5 14Patch0: sys-libs.patch
19277062 15URL: http://www.bacula-web.org/
eba56fc5 16BuildRequires: rpm-php-pearprov >= 4.4.2-11
97184a12 17BuildRequires: rpmbuild(macros) >= 1.654
eba56fc5 18BuildRequires: sed >= 4.0
138953e5
ER
19Requires: Smarty
20Requires: Smarty-plugin-gettext
1f4ccae5 21Requires: php(core) >= %{php_min_version}
f3e8be0b
ER
22Requires: php(gd)
23Requires: php(gettext)
24Requires: php(pdo)
97184a12 25Requires: php(session)
eba56fc5 26Requires: phplot
eba56fc5 27Requires: webserver(php)
97184a12
ER
28# Any of the db drivers needed depending where you hold your Bacula DB
29Suggests: php-pdo-mysql
30Suggests: php-pdo-pgsql
31Suggests: php-pdo-sqlite
405cdc14 32BuildArch: noarch
4041abae
AM
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
af7a763b 35%define _webapps /etc/webapps
eba56fc5 36%define _webapp %{name}
af7a763b
ER
37%define _sysconfdir %{_webapps}/%{_webapp}
38%define _appdir %{_datadir}/%{_webapp}
138953e5 39%define cachedir /var/cache/%{name}
af7a763b 40%define _smartyplugindir %{php_data_dir}/Smarty/plugins
4041abae 41
eba56fc5
ER
42# bad depsolver
43%define _noautopear pear
44# put it together for rpmbuild
45%define _noautoreq %{?_noautophp} %{?_noautopear}
4041abae 46
eba56fc5
ER
47%description
48Bacula-Web is a web based tool written in PHP that provide you a
49summarized view of your bacula's backup infrastructure. It obtain his
50information from your bacula catalog's database.
b3b9ed9e 51
4041abae 52%prep
5e3bbf5d 53%setup -q
138953e5 54%patch0 -p1
4041abae 55
97184a12 56mv application/config .
eba56fc5 57mv config/config.php{.sample,}
97184a12
ER
58%{__rm} application/locale/*/LC_MESSAGES/*.po
59%{__rm} -r application/view/cache
138953e5 60mv core/external .
5e3bbf5d 61mv DOCS/* .
4041abae 62
97184a12
ER
63# you'll need this if you cp -a complete dir in source
64# cleanup backups after patching
65find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
8eb594c5 66
4041abae
AM
67%install
68rm -rf $RPM_BUILD_ROOT
138953e5 69install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir},%{cachedir}}
97184a12 70cp -a *.php application core $RPM_BUILD_ROOT%{_appdir}
eba56fc5 71cp -a config/* $RPM_BUILD_ROOT%{_sysconfdir}
138953e5 72
eba56fc5 73cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
2f6c9c51 74cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
4041abae 75
eba56fc5
ER
76%clean
77rm -rf $RPM_BUILD_ROOT
4041abae 78
138953e5
ER
79%post
80# cleanup cache from previous rpm
81echo %{cachedir}/* | xargs rm -f
82
83%preun
84if [ "$1" = 0 ]; then
85 echo %{cachedir}/* | xargs rm -f
86fi
87
eba56fc5 88%triggerin -- apache1 < 1.3.37-3, apache1-base
af7a763b 89%webapp_register apache %{_webapp}
4041abae 90
eba56fc5 91%triggerun -- apache1 < 1.3.37-3, apache1-base
af7a763b
ER
92%webapp_unregister apache %{_webapp}
93
2f6c9c51 94%triggerin -- apache < 2.2.0, apache-base
af7a763b
ER
95%webapp_register httpd %{_webapp}
96
2f6c9c51 97%triggerun -- apache < 2.2.0, apache-base
af7a763b 98%webapp_unregister httpd %{_webapp}
4041abae 99
eba56fc5 100%files
4041abae 101%defattr(644,root,root,755)
97184a12 102%doc INSTALL README Changelog
af7a763b
ER
103%dir %attr(750,root,http) %{_sysconfdir}
104%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
105%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
eba56fc5 106%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
eba56fc5
ER
107
108%dir %{_appdir}
109%{_appdir}/backupjob-report.php
110%{_appdir}/client-report.php
111%{_appdir}/index.php
97184a12 112%{_appdir}/joblogs.php
eba56fc5
ER
113%{_appdir}/jobs.php
114%{_appdir}/pools.php
115%{_appdir}/test.php
eba56fc5
ER
116
117%dir %{_appdir}/core
5e3bbf5d
JK
118%{_appdir}/core/bweb.class.php
119%{_appdir}/core/const.inc.php
97184a12 120%{_appdir}/core/global.inc.php
eba56fc5 121%{_appdir}/core/app
eba56fc5
ER
122%{_appdir}/core/db
123%{_appdir}/core/graph
124%{_appdir}/core/i18n
125%{_appdir}/core/utils
126
97184a12
ER
127%dir %{_appdir}/application
128%{_appdir}/application/libs
129%{_appdir}/application/models
130%{_appdir}/application/view
131
132%dir %{_appdir}/application/locale
133%lang(de) %{_appdir}/application/locale/de_DE
134%lang(en) %{_appdir}/application/locale/en_EN
135%lang(es) %{_appdir}/application/locale/es_ES
136%lang(fr) %{_appdir}/application/locale/fr_FR
137%lang(it) %{_appdir}/application/locale/it_IT
5e3bbf5d 138%lang(nl) %{_appdir}/application/locale/nl_NL
97184a12
ER
139%lang(pt_BR) %{_appdir}/application/locale/pt_BR
140%lang(sv) %{_appdir}/application/locale/sv_SV
eba56fc5 141
138953e5 142%dir %attr(775,root,http) %{cachedir}
This page took 0.086926 seconds and 4 git commands to generate.