]> git.pld-linux.org Git - packages/atf.git/blame - atf.spec
- release 2 (by relup.sh)
[packages/atf.git] / atf.spec
CommitLineData
8dc0dc0f
AG
1Summary: Automated Testing Framework
2Name: atf
3Version: 0.20
050563ff 4Release: 2
8dc0dc0f
AG
5License: BSD
6Group: Development/Libraries
7Source0: https://github.com/jmmv/atf/releases/download/%{name}-%{version}/atf-%{version}.tar.gz
8# Source0-md5: dd27cf5c6299013dd84053ee1df37759
9URL: https://github.com/jmmv/atf/
10BuildRequires: autoconf
11BuildRequires: automake
12BuildRequires: libtool
13BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15%description
16The Automated Testing Framework (ATF) is a collection of libraries to
17implement test programs in a variety of languages. At the moment, ATF
18offers C, C++ and POSIX shell bindings with which to implement tests.
19These bindings all offer a similar set of functionality and any test
20program written with them exposes a consistent user interface.
21
22ATF-based test programs rely on a separate runtime engine to execute
23them. The runtime engine is in charge of isolating the test programs
24from the rest of the system to ensure that their results are
25deterministic and that they cannot affect the running system. The
26runtime engine is also responsible for gathering the results of all
27tests and composing reports. The current runtime of choice is Kyua.
28
29%package tests
30Summary: Automated Testing Framework - Test suite
31Group: Development/Libraries
32Requires: %{name} = %{version}-%{release}
33Requires: libatf-c++-devel = %{version}-%{release}
34Requires: libatf-c-devel = %{version}-%{release}
35Requires: libatf-sh-devel = %{version}-%{release}
36
37%description tests
38This package installs the run-time tests for all the components of
39ATF, which include tests for the C, C++ and POSIX shell libraries and
40the run-time tools. Please see the README.Fedora file in the
41documentation directory for further details on how to run the
42installed tests.
43
44%package -n libatf-c
45Summary: Automated Testing Framework - C bindings
46Summary(pl.UTF-8): Automated Testing Framework - dowiązania dla języka C
47Group: Development/Libraries
48
49%description -n libatf-c
50This package provides the run-time libraries to run tests that use the
51ATF C bindings.
52
53%package -n libatf-c-devel
54Summary: Header files for ATF C bindings
55Group: Development/Libraries
56Requires: libatf-c = %{version}-%{release}
57
58%description -n libatf-c-devel
59Header files for ATF C bindings.
60
61%package -n libatf-c-static
62Summary: Static ATF C library
63Group: Development/Libraries
64Requires: libatf-c-devel = %{version}-%{release}
65
66%description -n libatf-c-static
67Static ATF C library.
68
69%package -n libatf-c++
70Summary: Automated Testing Framework - C++ bindings
71Summary(pl.UTF-8): Automated Testing Framework - dowiązania dla języka C++
72Group: Development/Libraries
73
74%description -n libatf-c++
75This package provides the run-time libraries to run tests that use the
76ATF C++ bindings.
77
78%package -n libatf-c++-devel
79Summary: Header files for ATF C++ bindings
80Group: Development/Libraries
81Requires: libatf-c++ = %{version}-%{release}
82
83%description -n libatf-c++-devel
84Header files for ATF C++ bindings.
85
86%package -n libatf-c++-static
87Summary: Static ATF C++ library
88Group: Development/Libraries
89Requires: libatf-c++-devel = %{version}-%{release}
90
91%description -n libatf-c++-static
92Static ATF C++ library.
93
94%package -n libatf-sh
95Summary: Automated Testing Framework - PSOIX shell bindings
96Group: Development/Libraries
97
98%description -n libatf-sh
99This package provides the run-time libraries to run tests that use the
100ATF POSIX shell bindings.
101
102%package -n libatf-sh-devel
103Summary: Header files for ATF POSIX shell bindings
104Group: Development/Libraries
105Requires: libatf-sh = %{version}-%{release}
106
107%description -n libatf-sh-devel
108Header files for ATF POSIX shell bindings.
109
110%prep
111%setup -q
112
113%build
114%{__libtoolize}
115%{__aclocal}
116%{__autoconf}
117%{__autoheader}
118%{__automake}
119%configure
120%{__make}
121
122%install
123rm -rf $RPM_BUILD_ROOT
124%{__make} install \
125 DESTDIR=$RPM_BUILD_ROOT \
126 doc_DATA= \
127 testsdir=%{_libexecdir}/atf/tests \
128 pkgtestsdir=%{_libexecdir}/atf/tests
129
130%clean
131rm -rf $RPM_BUILD_ROOT
132
133%post -p /sbin/ldconfig
134%postun -p /sbin/ldconfig
135
136#%files
137#%defattr(644,root,root,755)
138
139%files tests
140%defattr(644,root,root,755)
141%dir %{_libexecdir}/atf
142%{_libexecdir}/atf/tests
143
144%files -n libatf-c
145%defattr(644,root,root,755)
146%attr(755,root,root) %{_libdir}/libatf-c.so.0
147%attr(755,root,root) %{_libdir}/libatf-c.so.0.0.0
148%{_mandir}/man1/atf-test-program.1*
149%{_mandir}/man4/atf-test-case.4*
150
151%files -n libatf-c-devel
152%defattr(644,root,root,755)
153%attr(755,root,root) %{_libdir}/libatf-c.so
154%{_libdir}/libatf-c.la
155%{_includedir}/atf-c
156%{_includedir}/atf-c.h
157%{_aclocaldir}/atf-c.m4
158%{_aclocaldir}/atf-common.m4
159%{_pkgconfigdir}/atf-c.pc
160%{_mandir}/man3/atf-c-api.3*
161
162%files -n libatf-c-static
163%defattr(644,root,root,755)
164%{_libdir}/libatf-c.a
165
166%files -n libatf-c++
167%defattr(644,root,root,755)
168%attr(755,root,root) %{_libdir}/libatf-c++.so.1
169%attr(755,root,root) %{_libdir}/libatf-c++.so.1.0.0
170
171%files -n libatf-c++-devel
172%defattr(644,root,root,755)
173%attr(755,root,root) %{_libdir}/libatf-c++.so
174%{_libdir}/libatf-c++.la
175%{_includedir}/atf-c++
176%{_includedir}/atf-c++.hpp
177%{_aclocaldir}/atf-c++.m4
178%{_pkgconfigdir}/atf-c++.pc
179%{_mandir}/man3/atf-c++-api.3*
180
181%files -n libatf-c++-static
182%defattr(644,root,root,755)
183%{_libdir}/libatf-c++.a
184
185%files -n libatf-sh
186%defattr(644,root,root,755)
187%attr(755,root,root) %{_bindir}/atf-sh
188%attr(755,root,root) %{_libexecdir}/atf-check
189%{_mandir}/man1/atf-check.1*
190%{_mandir}/man1/atf-sh.1*
191%{_datadir}/atf
192
193%files -n libatf-sh-devel
194%defattr(644,root,root,755)
195%{_aclocaldir}/atf-sh.m4
196%{_pkgconfigdir}/atf-sh.pc
197%{_mandir}/man3/atf-sh-api.3*
This page took 0.139539 seconds and 4 git commands to generate.