]> git.pld-linux.org Git - packages/apache1-mod_pointer.git/blame - apache1-mod_pointer.spec
- tabs in preamble
[packages/apache1-mod_pointer.git] / apache1-mod_pointer.spec
CommitLineData
32cdfe24
ER
1# TODO
2# - apache config
3# - package split by backend
4%define mod_name pointer
5%define apxs %{_sbindir}/apxs1
6Summary: Apache module for making domain redirects
76bd52ea 7Summary(pl.UTF-8): Moduł Apache'a do tworzenia przekierowań domen
32cdfe24
ER
8Name: apache1-mod_%{mod_name}
9Version: 0.8
fc3cd936 10Release: 0.6
32cdfe24
ER
11License: Apache
12Group: Networking/Daemons
13Source0: http://stderr.net/mod_pointer/dist/mod_pointer-%{version}.tar.gz
14# Source0-md5: 2f6529c49f1d10ecd06d3f6bc8503a5f
fc3cd936 15Patch0: apache1-mod_pointer-mysql.patch
32cdfe24 16URL: http://stderr.net/mod_pointer/
a6b26ec5 17BuildRequires: apache1-devel >= 1.3.34-8.5
32cdfe24
ER
18BuildRequires: gdbm-devel
19BuildRequires: mysql-devel
20BuildRequires: postgresql-devel
21BuildRequires: rpmbuild(macros) >= 1.268
22Requires: apache1 >= 1.3.33-2
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
26%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)
27
28%description
29mod_pointer is an Apache module for making domain redirects easy - the
30known service of many hosting providers that lets a domain point to
31your webpage on another server.
32
33The configuration part of the mappings are handled in either a MySQL
97fde319 34or PostgreSQL database or a NDBM or SDBM db file, so it's easy to
32cdfe24
ER
35build a webbased interface for letting users change it on their own.
36
1408ef23
JR
37%description -l pl.UTF-8
38mod_pointer to moduł Apache'a do łatwego tworzenia przekierowań domen
39- znanej usługi wielu providerów pozwalającej domenie wskazywać na
40stronę na innym serwerze.
97fde319 41
1408ef23
JR
42Część konfiguracyjna odwzorowań jest obsługiwana poprzez bazę danych
43MySQL lub PostgreSQL albo plik bazy danych NDBM lub SDBM, więc łatwo
44stworzyć oparty na WWW interfejs umożliwiający użytkownikom
45samodzielną zmianę przekierowań.
97fde319 46
32cdfe24
ER
47%prep
48%setup -q -n mod_%{mod_name}-%{version}
fc3cd936 49%patch0 -p1
32cdfe24
ER
50
51%build
52%{__make} all \
53 WITH_APXS=%{apxs}
54
55%install
56rm -rf $RPM_BUILD_ROOT
57install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
58
59%{__make} install \
60 APXS="%{apxs} -S DESTDIR=$RPM_BUILD_ROOT"
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65%post
66%service -q apache restart
67
68%postun
69if [ "$1" = "0" ]; then
70 %service -q apache restart
71fi
72
73%files
74%defattr(644,root,root,755)
fc3cd936 75%doc README CHANGES SUPPORT TODO frameset.html *.sql *.readme pointer.conf
32cdfe24
ER
76#%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
77%attr(755,root,root) %{_pkglibdir}/*
This page took 0.096925 seconds and 4 git commands to generate.