]> git.pld-linux.org Git - packages/apache-mod_auth_cas.git/blame - apache-mod_auth_cas.spec
- init
[packages/apache-mod_auth_cas.git] / apache-mod_auth_cas.spec
CommitLineData
0fb1b0c7 1# Replace MODNAME with real module name (example for mod_example)
2# Replace VERSION with version since what confdir support was
3# introduced for the module. only needed for older .specs, not needed
4# for new packages.
5#
6%define mod_name auth_cas
7%define apxs %{_sbindir}/apxs
8Summary: Apache module: CAS
9Summary(pl.UTF-8): ModuĊ‚ Apache'a: CAS
10Name: apache-mod_%{mod_name}
11Version: 1.0.8
12Release: 0.1
13License: GPL v3+
14Group: Networking/Daemons/HTTP
15# svn export https://www.ja-sig.org/svn/cas-clients/mod_auth_cas/tags/mod_auth_cas-1.0.8
16Source0: mod_%{mod_name}-%{version}.tar.bz2
17# Source0-md5: 2bd4117f7a8b25ade77f53c59c66944a
18Source1: %{name}.conf
19URL: https://www.ja-sig.org/svn/cas-clients/mod_auth_cas/
20BuildRequires: %{apxs}
21BuildRequires: apache-devel >= 2.2
22BuildRequires: rpmbuild(macros) >= 1.268
23Requires: apache(modules-api) = %apache_modules_api
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
27%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
28
29%description
30
31%description -l pl.UTF-8
32
33%prep
34%setup -q -n mod_%{mod_name}-%{version}
35
36%build
37%{apxs} -c src/mod_%{mod_name}.c
38
39%install
40rm -rf $RPM_BUILD_ROOT
41install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
42
43install src/.libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
44
45# module configuration
46# - should contain LoadModule line
47# - and directives must be between IfModule (so user could disable the module easily)
48install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_%{mod_name}.conf
49
50%clean
51rm -rf $RPM_BUILD_ROOT
52
53%post
54%service -q httpd restart
55
56%postun
57if [ "$1" = "0" ]; then
58 %service -q httpd restart
59fi
60
61%files
62%defattr(644,root,root,755)
63%doc README
64%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
65%attr(755,root,root) %{_pkglibdir}/*
This page took 0.068195 seconds and 4 git commands to generate.