]> git.pld-linux.org Git - packages/SPQR.git/blame - SPQR.spec
- new
[packages/SPQR.git] / SPQR.spec
CommitLineData
f492f268
JB
1Summary: SuiteSparseQR: multithreaded multifrontal sparse QR factorization
2Summary(pl.UTF-8): SuiteSparseQR - wielowątkowy, wielofrontalny rozkład QR dla macierzy rzadkich
3Name: SPQR
4Version: 1.2.3
5Release: 1
6License: GPL v2+
7Group: Libraries
8Source0: http://www.cise.ufl.edu/research/sparse/SPQR/%{name}-%{version}.tar.gz
9# Source0-md5: 65e12826a2a3d11a774c517990eabdd7
10Patch0: %{name}-ufconfig.patch
11Patch1: %{name}-shared.patch
12URL: http://www.cise.ufl.edu/research/sparse/SPQR/
13BuildRequires: CHOLMOD-devel >= 1.7.4
14BuildRequires: UFconfig >= 3.7.0
15BuildRequires: libstdc++-devel
16BuildRequires: libtool >= 2:1.5
17BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19%description
20SuiteSparseQR is an implementation of the multifrontal sparse QR
21factorization method. Parallelism is exploited both in the BLAS and
22across different frontal matrices using Intel's Threading Building
23Blocks, a shared-memory programming model for modern multicore
24architectures. It can obtain a substantial fraction of the theoretical
25peak performance of a multicore computer. The package is written in
26C++ with user interfaces for MATLAB, C, and C++.
27
28%description -l pl.UTF-8
29SuiteSparseQR to implementacja wielofrontalnej metody rozkładu QR dla
30macierzy rzadkich. Równoległość jest wykorzystywna zarówno w BLAS, jak
31i poprzez różne macierze frontalne przy użyciu Threading Building
32Blocks Intela - model programowania ze współdzieloną pamięcią dla
33architektur wielordzeniowych. Dzięki temu możliwe jest osiągnięcie
34znaczącej części teoretycznej maksymalnej wydajności na komputerze
35wielordzeniowym. Pakiet jest napisany w C++ z interfejsami dla
36MATLAB-a, C i C++.
37
38%package devel
39Summary: Header files for SPQR library
40Summary(pl.UTF-8): Pliki nagłówkowe biblioteki SPQR
41Group: Development/Libraries
42Requires: %{name} = %{version}-%{release}
43Requires: CHOLMOD-devel >= 1.7.4
44Requires: UFconfig >= 3.7.0
45Requires: libstdc++-devel
46
47%description devel
48Header files for SPQR library.
49
50%description devel -l pl.UTF-8
51Pliki nagłówkowe biblioteki SPQR.
52
53%package static
54Summary: Static SPQR library
55Summary(pl.UTF-8): Statyczna biblioteka SPQR
56Group: Development/Libraries
57Requires: %{name}-devel = %{version}-%{release}
58
59%description static
60Static SPQR library.
61
62%description static -l pl.UTF-8
63Statyczna biblioteka SPQR.
64
65%prep
66%setup -q -n %{name}
67%patch0 -p1
68%patch1 -p1
69
70%build
71%{__make} \
72 CC="%{__cc}" \
73 CXX="%{__cxx}" \
74 CFLAGS="%{rpmcflags}" \
75 CXXFLAGS="%{rpmcxxflags}" \
76 LDFLAGS="%{rpmldflags}" \
77 libdir=%{_libdir}
78
79%install
80rm -rf $RPM_BUILD_ROOT
81install -d $RPM_BUILD_ROOT%{_includedir}/spqr
82
83%{__make} -C Lib install \
84 DESTDIR=$RPM_BUILD_ROOT \
85 libdir=%{_libdir}
86
87install Include/*.{h,hpp} $RPM_BUILD_ROOT%{_includedir}/spqr
88
89%clean
90rm -rf $RPM_BUILD_ROOT
91
92%post -p /sbin/ldconfig
93%postun -p /sbin/ldconfig
94
95%files
96%defattr(644,root,root,755)
97%doc README.txt Doc/ChangeLog
98%attr(755,root,root) %{_libdir}/libspqr.so.*.*.*
99%attr(755,root,root) %ghost %{_libdir}/libspqr.so.0
100
101%files devel
102%defattr(644,root,root,755)
103%doc Doc/{algo_spqr,spqr,spqr_user_guide}.pdf
104%attr(755,root,root) %{_libdir}/libspqr.so
105%{_libdir}/libspqr.la
106%{_includedir}/spqr
107
108%files static
109%defattr(644,root,root,755)
110%{_libdir}/libspqr.a
This page took 0.05475 seconds and 4 git commands to generate.