]> git.pld-linux.org Git - packages/PackageKit.git/blame - PackageKit.spec
Updated to 1.2.1
[packages/PackageKit.git] / PackageKit.spec
CommitLineData
d05d9108
MB
1# TODO:
2# - BASH command-not-found functionality disabled for now as it needs patched bash
3# (details in bash from Fedora Rawhide)
d05d9108
MB
4#
5# Conditional build:
53810c7c
JB
6%bcond_without doc # build without docs
7%bcond_without introspection # gobject introspection, time to time broken
aa278a7b
JB
8%bcond_without static_libs # static library
9%bcond_without python # Python binding (used by entropy and portage backends)
10%bcond_without vala # Vala binding
11# backends
d06070b1 12%bcond_with alpm # ALPM (Arch Linux package manager) backend
04e18045 13%bcond_with apt # APT (Debian/Ubuntu) backend using C++ API
49ea0764 14%bcond_with dnf # DNF (Fedora/RHEL) backend
04e18045 15%bcond_with entropy # Entropy (Sabayon) backend (Python)
aa278a7b 16%bcond_with nix # Nix (NixOS) backend [broken as of 1.2.0]
04e18045
JB
17%bcond_without poldek # Poldek (PLD) backend
18%bcond_with portage # portage (Gentoo) backend (Python)
49ea0764 19%bcond_with slack # Slack (Slackware) backend
aa278a7b 20%bcond_with zypp # ZYPP (openSUSE/SLE) backend [broken as of 1.2.0]
0e84469f 21
aa278a7b
JB
22%if %{without python}
23%undefine with_entropy
24%undefine with_portage
04e18045 25%endif
0e84469f 26
85d27e4f
JB
27Summary: System daemon that is a D-Bus abstraction layer for package management
28Summary(pl.UTF-8): Demon systemowy będący warstwą abstrakcji D-Bus do zarządzania pakietami
a2d83637 29Name: PackageKit
8271f320 30Version: 1.2.1
783c79a3 31Release: 1
a2d83637 32License: GPL v2+
85d27e4f 33Group: Applications/System
90405068 34Source0: https://www.freedesktop.org/software/PackageKit/releases/%{name}-%{version}.tar.xz
8271f320 35# Source0-md5: a0a1f7c45d25901cf4ff4318405610c3
02b3d2d3
JB
36Patch0: %{name}-poldek.patch
37Patch1: %{name}-bashcomp.patch
aa278a7b 38Patch2: %{name}-meson.patch
bcd7526e 39Patch3: consolekit-fallback.patch
90405068 40URL: https://www.freedesktop.org/software/PackageKit/
49ea0764 41%{?with_apt:BuildRequires: AppStream-devel >= 0.11}
a2d83637 42BuildRequires: NetworkManager-devel >= 0.6.5
49ea0764
JB
43# pkgconfig(libalpm) >= 12.0.0
44%{?with_alpm:BuildRequires: alpm-devel >= 5.2}
45%{?with_dnf:BuildRequires: appstream-glib-devel}
46%{?with_apt:BuildRequires: apt-devel >= 1.7}
577193a4 47BuildRequires: connman-devel
49ea0764 48%{?with_slack:BuildRequires: curl-devel}
6808f644 49BuildRequires: dbus-devel >= 1.2.0
f5f5e3ff 50BuildRequires: dbus-glib-devel >= 0.76
bdd8c0ca 51BuildRequires: docbook-dtd412-xml
52BuildRequires: docbook-dtd42-xml
dac2b5e1 53BuildRequires: fontconfig-devel
a0f1aeda 54BuildRequires: gettext-tools
49ea0764 55BuildRequires: glib2-devel >= 1:2.54.0
53810c7c 56%{?with_introspection:BuildRequires: gobject-introspection-devel >= 0.9.9}
7cd3cbcf
MB
57BuildRequires: gstreamer-devel >= 1.0.0
58BuildRequires: gstreamer-plugins-base-devel >= 1.0.0
dac2b5e1 59BuildRequires: gtk+3-devel >= 3.0.0
577193a4 60%{?with_doc:BuildRequires: gtk-doc >= 1.11}
78293e06 61BuildRequires: libarchive-devel
aa278a7b 62%{?with_dnf:BuildRequires: libdnf-devel >= 0.43.1}
49ea0764
JB
63%if %{with apt} || %{with nix}
64BuildRequires: libstdc++-devel >= 6:4.7
65%endif
66%{?with_slack:BuildRequires: libstdc++-devel >= 6:5}
dac2b5e1 67BuildRequires: libxslt-progs
3b18414e 68%{?with_zypp:BuildRequires: libzypp-devel >= 15}
aa278a7b
JB
69BuildRequires: meson >= 0.47.0
70BuildRequires: ninja >= 1.5
49ea0764
JB
71# nix-expr nix-main nix-store
72%{?with_nix:BuildRequires: nix-devel >= 1.12}
dac2b5e1 73BuildRequires: pango-devel
a2d83637 74BuildRequires: pkgconfig
49ea0764
JB
75# when released; just to detect which reboot modes to use (library not linked)
76#BuildRequires: plymouth-devel >= 0.9.5
7cd3cbcf 77%{?with_poldek:BuildRequires: poldek-devel >= 0.30-1.rc6.4}
49ea0764
JB
78BuildRequires: polkit-devel >= 0.114
79# or 1:3.2
02b3d2d3 80%{?with_python:BuildRequires: python-devel >= 1:2.7}
827cd5e7 81BuildRequires: readline-devel
49ea0764 82%{?with_dnf:BuildRequires: rpm-devel >= 4.?}
a2d83637 83BuildRequires: rpm-pythonprov
aa278a7b
JB
84BuildRequires: rpmbuild(macros) >= 1.736
85BuildRequires: sed >= 4.0
577193a4 86BuildRequires: sqlite3-devel >= 3
49ea0764 87BuildRequires: systemd-devel >= 1:213
e216f3d9 88BuildRequires: tar >= 1:1.22
9ed4ca79 89BuildRequires: udev-glib-devel
8ad97aee 90%{?with_vala:BuildRequires: vala >= 2:0.16}
e216f3d9 91BuildRequires: xz
fcd0bc5c 92Requires(post,postun): shared-mime-info
0d5f415c 93Requires: %{name}-backend
a2d83637 94Requires: %{name}-libs = %{version}-%{release}
8d48627e 95Requires: crondaemon
49ea0764 96Requires: polkit >= 0.114
48178e4e 97Suggests: ConsoleKit-x11
aa278a7b
JB
98Obsoletes: PackageKit-backend-pisi
99Obsoletes: PackageKit-backend-ports
02b3d2d3 100Obsoletes: PackageKit-backend-smart
aa278a7b 101Obsoletes: PackageKit-backend-urpmi
02b3d2d3 102Obsoletes: PackageKit-backend-yum
7cd3cbcf 103Obsoletes: PackageKit-docs < 0.8.4
d113818a 104Obsoletes: pm-utils-packagekit
a2d83637
MB
105BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
106
107%description
108PackageKit is a D-Bus abstraction layer that allows the session user
109to manage packages in a secure way using a cross-distro,
110cross-architecture API.
111
85d27e4f
JB
112%description -l pl.UTF-8
113PackageKit to warstwa abstrakcji D-Bus pozwalająca użytkownikowi
114sesyjnemu w bezpieczny sposob zarządzać pakietami przy użyciu API
115zgodnego z wieloma dystrybucjami i architekturami.
116
a2d83637 117%package libs
d05d9108
MB
118Summary: packagekit-glib library
119Summary(pl.UTF-8): Biblioteka packagekit-glib
a2d83637 120Group: Libraries
49ea0764
JB
121Requires: glib2 >= 1:2.54.0
122Obsoletes: browser-plugin-packagekit < 1.1.0
a2d83637
MB
123
124%description libs
d05d9108 125packagekit-glib library.
a2d83637
MB
126
127%description libs -l pl.UTF-8
d05d9108 128Biblioteka packagekit-glib.
a2d83637
MB
129
130%package devel
d05d9108
MB
131Summary: Header files for packagekit-glib library
132Summary(pl.UTF-8): Pliki nagłówkowe biblioteki packagekit-glib
a2d83637
MB
133Group: Development/Libraries
134Requires: %{name}-libs = %{version}-%{release}
9ed4ca79 135Requires: dbus-devel >= 1.2.0
49ea0764 136Requires: glib2-devel >= 1:2.54.0
9ed4ca79 137Requires: sqlite3-devel
a2d83637
MB
138
139%description devel
d05d9108 140Header files for packagekit-glib library.
a2d83637
MB
141
142%description devel -l pl.UTF-8
d05d9108 143Pliki nagłówkowe biblioteki packagekit-glib.
a2d83637
MB
144
145%package static
d05d9108
MB
146Summary: Static packagekit-glib library
147Summary(pl.UTF-8): Statyczna biblioteka packagekit-glib
a2d83637
MB
148Group: Development/Libraries
149Requires: %{name}-devel = %{version}-%{release}
150
151%description static
d05d9108 152Static packagekit-glib library.
a2d83637
MB
153
154%description static -l pl.UTF-8
d05d9108
MB
155Statyczna biblioteka packagekit-glib.
156
8ad97aee
JB
157%package -n vala-packagekit
158Summary: Vala API for PackageKit library
159Summary(pl.UTF-8): API języka Vala do biblioteki PackageKitu
160Group: Development/Libraries
161Requires: %{name}-devel = %{version}-%{release}
162Requires: vala >= 2:0.16
49ea0764 163%if "%{_rpmversion}" >= "4.6"
0e84469f
ER
164BuildArch: noarch
165%endif
8ad97aee
JB
166
167%description -n vala-packagekit
168Vala API for PackageKit library.
169
170%description -n vala-packagekit -l pl.UTF-8
171API języka Vala do biblioteki PackageKitu.
172
16acf8d5
JB
173%package apidocs
174Summary: PackageKit library API documentation
175Summary(pl.UTF-8): Dokumentacja API biblioteki PackageKit
176Group: Documentation
177Requires: gtk-doc-common
49ea0764 178%if "%{_rpmversion}" >= "4.6"
2aa4ef3d
ER
179BuildArch: noarch
180%endif
16acf8d5
JB
181
182%description apidocs
183PackageKit library API documentation.
184
185%description apidocs -l pl.UTF-8
186Dokumentacja API biblioteki PackageKit.
187
d06070b1
JB
188%package backend-alpm
189Summary: PackageKit ALPM backend
190Summary(pl.UTF-8): Backend PackageKit oparty na bibliotece ALPM
191Group: Libraries
192Requires: %{name} = %{version}-%{release}
193Provides: %{name}-backend = %{version}-%{release}
d06070b1
JB
194
195%description backend-alpm
196A backend for PackageKit to enable Arch Linux packages via ALPM
197library.
198
199%description backend-alpm -l pl.UTF-8
200Backend PackageKit dodający obsługę pakietów Arch Linuksa poprzez
201bibliotekę ALPM.
202
04e18045
JB
203%package backend-aptcc
204Summary: PackageKit APTcc backend
205Summary(pl.UTF-8): Backend PackageKit APTcc
206Group: Libraries
207Requires: %{name} = %{version}-%{release}
49ea0764 208Requires: AppStream >= 0.11
04e18045
JB
209Provides: %{name}-backend = %{version}-%{release}
210
211%description backend-aptcc
212A backend for PackageKit to enable APT support via C++ API.
213
214%description backend-aptcc -l pl.UTF-8
215Backend PackageKit dodający obsługę zarządcy pakietów APT poprzez API
216C++.
217
49ea0764
JB
218%package backend-dnf
219Summary: PackageKit dnf backend
220Summary(pl.UTF-8): Backend PackageKit oparty na bibliotece dnfhif
221Group: Libraries
222Requires: %{name} = %{version}-%{release}
223Provides: %{name}-backend = %{version}-%{release}
224Obsoletes: PackageKit-backend-hawkey
225Obsoletes: PackageKit-backend-hif
226
227%description backend-dnf
228A backend for PackageKit to enable RPM packages support via dnf
229library (used in Fedora).
230
231%description backend-dnf -l pl.UTF-8
232Backend PackageKit dodający obsługę pakietów RPM poprzez bibliotekę
233dnf (używaną w dystrybucji Fedora).
234
04e18045
JB
235%package backend-entropy
236Summary: PackageKit Entropy backend
237Summary(pl.UTF-8): Backend PackageKit Entropy
238Group: Libraries
239Requires: %{name} = %{version}-%{release}
240Requires: python-packagekit = %{version}-%{release}
241#Requires: python-entropy
242Provides: %{name}-backend = %{version}-%{release}
243
244%description backend-entropy
245A backend for PackageKit to enable Sabayon packages support through
246Entropy package manager.
247
248%description backend-entropy -l pl.UTF-8
249Backend PackageKit dodający obsługę pakietów dystrybucji Sabayon przy
250użyciu zarządcy pakietów Entropy.
251
49ea0764
JB
252%package backend-nix
253Summary: PackageKit Nix backend
254Summary(pl.UTF-8): Backend PackageKit oparty na zarządcy pakietów Nix
04e18045
JB
255Group: Libraries
256Requires: %{name} = %{version}-%{release}
49ea0764 257Requires: nix >= 1.12
04e18045
JB
258Provides: %{name}-backend = %{version}-%{release}
259
49ea0764
JB
260%description backend-nix
261A backend for PackageKit to enable Nix packages support (used in
262NixOS).
04e18045 263
49ea0764
JB
264%description backend-nix -l pl.UTF-8
265Backend PackageKit dodający obsługę pakietów Nix (używanych w NixOS).
04e18045 266
0d5f415c
ER
267%package backend-poldek
268Summary: PackageKit Poldek backend
16acf8d5 269Summary(pl.UTF-8): Backend PackageKit oparty na Poldku
0d5f415c
ER
270Group: Libraries
271Requires: %{name} = %{version}-%{release}
7cd3cbcf 272Requires: poldek >= 0.30-1.rc6.4
16acf8d5 273Provides: %{name}-backend = %{version}-%{release}
0d5f415c
ER
274
275%description backend-poldek
04e18045
JB
276A backend for PackageKit to enable RPM packages support through Poldek
277- native PLD package manager.
0d5f415c 278
16acf8d5 279%description backend-poldek -l pl.UTF-8
04e18045
JB
280Backend PackageKit dodający obsługę pakietów RPM poprzez Poldka -
281natywnego zarządcę pakietów dystrybucji PLD.
282
283%package backend-portage
284Summary: PackageKit Portage backend
285Summary(pl.UTF-8): Backend PackageKit Portage
286Group: Libraries
287Requires: %{name} = %{version}-%{release}
288Requires: python-packagekit = %{version}-%{release}
289#Requires: python-portage
290Provides: %{name}-backend = %{version}-%{release}
291
292%description backend-portage
293A backend for PackageKit to enable Gentoo Portage support.
294
295%description backend-portage -l pl.UTF-8
296Backend PackageKit dodający obsługę systemu Portage dystrybucji
297Gentoo.
298
49ea0764
JB
299%package backend-slack
300Summary: PackageKit Slack backend
301Summary(pl.UTF-8): Backend PackageKit Slack
302Group: Libraries
303Requires: %{name} = %{version}-%{release}
304Provides: %{name}-backend = %{version}-%{release}
305Obsoletes: PackageKit-backend-katja
306
307%description backend-slack
308Slack backend for PackageKit to enable Slackware repositories support.
309
310%description backend-slack -l pl.UTF-8
311Backend PackageKit Slack dodający obsługę repozytoriów Slackware.
312
04e18045
JB
313%package backend-zypp
314Summary: PackageKit Zypp backend
315Summary(pl.UTF-8): Backend PackageKit Zypp
316Group: Libraries
317Requires: %{name} = %{version}-%{release}
3b18414e 318Requires: libzypp >= 15
04e18045
JB
319Provides: %{name}-backend = %{version}-%{release}
320
321%description backend-zypp
322A backend for PackageKit to enable RPM packages support through Zypp
323library (originated in openSUSE/SLE).
324
325%description backend-zypp -l pl.UTF-8
326Backend PackageKit dodający obsługę pakietów RPM poprzez bibliotekę
327Zypp (pochodzącą z dystrybucji openSUSE/SLE).
16acf8d5 328
d05d9108
MB
329%package gstreamer-plugin
330Summary: GStreamer codecs installer
331Summary(pl.UTF-8): Instalator kodeków GStreamera
332Group: Applications
333Requires: %{name} = %{version}-%{release}
aa278a7b 334Requires: %{name}-gtk3-module = %{version}-%{release}
d05d9108
MB
335
336%description gstreamer-plugin
337The PackageKit GStreamer plugin allows any GStreamer application to
338install codecs from configured repositories using PackageKit.
339
340%description gstreamer-plugin -l pl.UTF-8
341Wtyczka GStreamer pozwala każdej aplikacji używającej GStreamera
342zainstalować kodeki ze skonfigurowanych źródeł PackageKit.
343
dac2b5e1
AF
344%package gtk3-module
345Summary: GTK+ 3.x module to detect and install missing fonts
346Summary(pl.UTF-8): Moduł GTK+ 3.x do wykrywania i instalowania brakujących czcionek
347Group: X11/Libraries
aa278a7b 348Obsoletes: PackageKit-gtk-module < 1.2.0
dac2b5e1
AF
349
350%description gtk3-module
351The PackageKit GTK+ 3.x module allows any pango application to install
352missing fonts from configured repositories using PackageKit.
353
354%description gtk3-module -l pl.UTF-8
355Moduł GTK+ 3.x pozwala każdej aplikacji używającej pango zainstalować
356brakującą czcionkę ze skonfigurowanych źródeł PackageKit.
357
a2d83637 358%package -n bash-completion-packagekit
16acf8d5
JB
359Summary: Bash completion for PackageKit console commands
360Summary(pl.UTF-8): Bashowe uzupełnianie parametrów dla poleceń konsolowych PackageKit
a2d83637 361Group: Applications/Shells
577193a4
JB
362Requires: %{name} = %{version}-%{release}
363Requires: bash-completion >= 2
49ea0764 364%if "%{_rpmversion}" >= "4.6"
ead2d2f6
ER
365BuildArch: noarch
366%endif
a2d83637
MB
367
368%description -n bash-completion-packagekit
16acf8d5 369This package provides bash-completion for PackageKit console commands.
a2d83637
MB
370
371%description -n bash-completion-packagekit -l pl.UTF-8
16acf8d5
JB
372Pakiet ten dostarcza bashowe uzupełnianie parametrów dla poleceń
373konsolowych PackageKit.
a2d83637 374
a2d83637
MB
375%package -n python-packagekit
376Summary: PackageKit Python bindings
377Summary(pl.UTF-8): Wiązania PackageKit dla Pythona
378Group: Development/Languages/Python
379Requires: python-dbus
380Requires: python-pygobject
381
382%description -n python-packagekit
383PackageKit Python bindings.
384
86086d14 385%description -n python-packagekit -l pl.UTF-8
a2d83637
MB
386Wiązania PackageKit dla Pythona.
387
388%prep
389%setup -q
d113818a 390%patch0 -p1
02b3d2d3 391%patch1 -p1
aa278a7b 392%patch2 -p1
bcd7526e 393%patch3 -p1
a2d83637 394
aa278a7b
JB
395%if %{with static_libs}
396%{__sed} -i -e '/^packagekit_glib2_library =/ s/shared_library/library/' lib/packagekit-glib2/meson.build
d5617342 397%endif
aa278a7b
JB
398
399%build
04e18045 400%{?with_zypp:CPPFLAGS="%{rpmcppflags} -D_RPM_5 -I/usr/include/rpm"}
aa278a7b
JB
401%meson build \
402 -Dbash_command_not_found=false \
403 -Dbash_completion_dir=%{bash_compdir} \
404 %{!?with_introspection:-Dgobject_introspection=false} \
405 %{?with_doc:-Dgtk_doc=true} \
406 -Dpackaging_backend=dummy%{?with_alpm:,alpm}%{?with_apt:,aptcc}%{?with_dnf:,dnf}%{?with_entropy:,entropy}%{?with_poldek:,poldek}%{?with_portage:,portage}%{?with_slack:,slack}%{?with_zypp:,zypp}%{?with_nix:,nix} \
407 %{!?with_python:-Dpython_backend=false} \
408 -Dpythonpackagedir=%{py_sitescriptdir} \
409 -Dsystemdsystemunitdir=%{systemdunitdir}
410
411# TODO:
412# -Ddnf_vendor=
413# -Dpackagekit_user=
414
415%ninja_build -C build
a2d83637
MB
416
417%install
418rm -rf $RPM_BUILD_ROOT
aa278a7b 419install -d $RPM_BUILD_ROOT/var/cache/PackageKit/downloads
a2d83637 420
aa278a7b
JB
421%ninja_install -C build
422
423%{__rm} $RPM_BUILD_ROOT%{_libdir}/packagekit-backend/libpk_backend_test_*.so
a2d83637 424
5059111f
JB
425%if %{without apt} && %{without entropy} && %{without portage}
426# common dir not created if no users built with PackageKit
427install -d $RPM_BUILD_ROOT%{_datadir}/PackageKit/helpers
428%endif
429
d05d9108 430# use pk-gstreamer-install as codec installer
aa278a7b 431ln -s pk-gstreamer-install $RPM_BUILD_ROOT%{_libexecdir}/gst-install-plugins-helper
d05d9108 432
aa278a7b
JB
433install -d $RPM_BUILD_ROOT%{systemdunitdir}/system-update.target.wants
434ln -sf ../packagekit-offline-update.service \
435 $RPM_BUILD_ROOT%{systemdunitdir}/system-update.target.wants/packagekit-offline-update.service
436
437%if %{with python}
438%py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
439%py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
dac2b5e1 440
a2d83637 441%py_postclean
aa278a7b 442%endif
a2d83637 443
6808f644
MB
444%find_lang %{name}
445
a2d83637
MB
446%clean
447rm -rf $RPM_BUILD_ROOT
448
fcd0bc5c
MB
449%post
450%update_mime_database
451
452%postun
453%update_mime_database
454
85d27e4f 455%post libs -p /sbin/ldconfig
a2d83637
MB
456%postun libs -p /sbin/ldconfig
457
6808f644 458%files -f %{name}.lang
a2d83637 459%defattr(644,root,root,755)
02b3d2d3 460%doc AUTHORS HACKING MAINTAINERS NEWS README
a2d83637
MB
461%attr(755,root,root) %{_bindir}/pkcon
462%attr(755,root,root) %{_bindir}/pkmon
50832223 463%attr(750,root,root) /etc/cron.daily/packagekit-background.cron
02b3d2d3
JB
464%attr(755,root,root) %{_libexecdir}/packagekit-direct
465%attr(755,root,root) %{_libexecdir}/packagekitd
466%attr(755,root,root) %{_libexecdir}/pk-offline-update
a2d83637 467%dir %{_libdir}/packagekit-backend
aa278a7b 468%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_dummy.so
a2d83637
MB
469%dir %{_sysconfdir}/PackageKit
470%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/PackageKit.conf
d05d9108 471%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Vendor.conf
5baab3aa
ER
472%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/packagekit-background
473/etc/dbus-1/system.d/org.freedesktop.PackageKit.conf
d05d9108 474%dir %{_datadir}/PackageKit
6e66a3a4 475%dir %{_datadir}/PackageKit/helpers
d05d9108 476%attr(755,root,root) %{_datadir}/PackageKit/pk-upgrade-distro.sh
f058dba9 477%{_datadir}/polkit-1/actions/org.freedesktop.packagekit.policy
577193a4 478%{_datadir}/polkit-1/rules.d/org.freedesktop.packagekit.rules
a2d83637 479%{_datadir}/dbus-1/system-services/org.freedesktop.PackageKit.service
a2d83637 480%{_mandir}/man1/pkcon.1*
78293e06 481%{_mandir}/man1/pkmon.1*
53810c7c 482%{systemdunitdir}/packagekit.service
7cd3cbcf 483%{systemdunitdir}/packagekit-offline-update.service
02b3d2d3 484%{systemdunitdir}/system-update.target.wants/packagekit-offline-update.service
78293e06
MB
485%dir /var/cache/PackageKit
486%dir /var/cache/PackageKit/downloads
a2d83637 487%dir /var/lib/PackageKit
d05d9108 488%ghost /var/lib/PackageKit/transactions.db
a2d83637
MB
489
490%files libs
491%defattr(644,root,root,755)
74872af2 492%attr(755,root,root) %{_libdir}/libpackagekit-glib2.so.*.*.*
02b3d2d3 493%attr(755,root,root) %ghost %{_libdir}/libpackagekit-glib2.so.18
dac2b5e1 494%{_libdir}/girepository-1.0/PackageKitGlib-1.0.typelib
2ab9cd42
JB
495# NOTE: dbus interface xmls are commonly used:
496# - at runtime by packagekitd
497# - for development of applications using PK dbus interface
498%{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.Transaction.xml
499%{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.xml
08c67dac 500
a2d83637
MB
501%files devel
502%defattr(644,root,root,755)
74872af2 503%attr(755,root,root) %{_libdir}/libpackagekit-glib2.so
74872af2 504%{_pkgconfigdir}/packagekit-glib2.pc
d05d9108 505%dir %{_includedir}/PackageKit
74872af2 506%{_includedir}/PackageKit/packagekit-glib2
dac2b5e1 507%{_datadir}/gir-1.0/PackageKitGlib-1.0.gir
08c67dac 508
a2d83637
MB
509%files static
510%defattr(644,root,root,755)
74872af2 511%{_libdir}/libpackagekit-glib2.a
d05d9108 512
8ad97aee
JB
513%if %{with vala}
514%files -n vala-packagekit
515%defattr(644,root,root,755)
aa278a7b 516%{_datadir}/vala/vapi/packagekit-glib2.deps
8ad97aee
JB
517%{_datadir}/vala/vapi/packagekit-glib2.vapi
518%endif
519
16acf8d5
JB
520%files apidocs
521%defattr(644,root,root,755)
522%{_gtkdocdir}/PackageKit
523
d06070b1
JB
524%if %{with alpm}
525%files backend-alpm
0d5f415c 526%defattr(644,root,root,755)
d06070b1
JB
527%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_alpm.so
528%dir %{_sysconfdir}/PackageKit/alpm.d
529%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/groups.list
530%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/pacman.conf
531%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/repos.list
0d5f415c
ER
532%endif
533
04e18045
JB
534%if %{with apt}
535%files backend-aptcc
536%defattr(644,root,root,755)
537%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_aptcc.so
538%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apt/apt.conf.d/20packagekit
539%dir %{_datadir}/PackageKit/helpers/aptcc
540%attr(755,root,root) %{_datadir}/PackageKit/helpers/aptcc/get-distro-upgrade.py
541%attr(755,root,root) %{_datadir}/PackageKit/helpers/aptcc/pkconffile
542%{_datadir}/PackageKit/helpers/aptcc/pkconffile.nodiff
543%endif
544
49ea0764
JB
545%if %{with dnf}
546%files backend-dnf
547%defattr(644,root,root,755)
548%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_dnf.so
549%endif
550
04e18045
JB
551%if %{with entropy}
552%files backend-entropy
553%defattr(644,root,root,755)
554%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_entropy.so
555%dir %{_datadir}/PackageKit/helpers/entropy
556%attr(755,root,root) %{_datadir}/PackageKit/helpers/entropy/entropyBackend.py
557%endif
558
49ea0764
JB
559%if %{with nix}
560%files backend-nix
ee375c30 561%defattr(644,root,root,755)
49ea0764 562%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_nix.so
04e18045
JB
563%endif
564
d06070b1
JB
565%if %{with poldek}
566%files backend-poldek
567%defattr(644,root,root,755)
568%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_poldek.so
569%endif
570
04e18045
JB
571%if %{with portage}
572%files backend-portage
573%defattr(644,root,root,755)
574%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_portage.so
575%dir %{_datadir}/PackageKit/helpers/portage
576%attr(755,root,root) %{_datadir}/PackageKit/helpers/portage/portageBackend.py
577%endif
578
49ea0764
JB
579%if %{with slack}
580%files backend-slack
581%defattr(644,root,root,755)
582%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_slack.so
583%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Slackware.conf
584%dir /var/cache/PackageKit/metadata
585%ghost /var/cache/PackageKit/metadata/metadata.db
586%endif
587
04e18045
JB
588%if %{with zypp}
589%files backend-zypp
590%defattr(644,root,root,755)
591%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_zypp.so
592%endif
593
d05d9108
MB
594%files gstreamer-plugin
595%defattr(644,root,root,755)
596%doc contrib/gstreamer-plugin/README
aa278a7b 597%attr(755,root,root) %{_libexecdir}/gst-install-plugins-helper
02b3d2d3 598%attr(755,root,root) %{_libexecdir}/pk-gstreamer-install
d05d9108 599
dac2b5e1
AF
600%files gtk3-module
601%defattr(644,root,root,755)
aa278a7b 602%doc contrib/gtk-module/{GLASS.txt,README}
dac2b5e1 603%attr(755,root,root) %{_libdir}/gtk-3.0/modules/libpk-gtk-module.so
7cd3cbcf 604%{_libdir}/gnome-settings-daemon-3.0/gtk-modules/pk-gtk-module.desktop
dac2b5e1 605
a2d83637
MB
606%files -n bash-completion-packagekit
607%defattr(644,root,root,755)
577193a4 608%{bash_compdir}/pkcon
a2d83637 609
02b3d2d3 610%if %{with python}
a2d83637
MB
611%files -n python-packagekit
612%defattr(644,root,root,755)
613%dir %{py_sitescriptdir}/packagekit
614%{py_sitescriptdir}/packagekit/*.py[co]
02b3d2d3 615%endif
This page took 0.190293 seconds and 4 git commands to generate.