]> git.pld-linux.org Git - packages/Lunchbox.git/blame - Lunchbox.spec
- up to 1.13.0
[packages/Lunchbox.git] / Lunchbox.spec
CommitLineData
7c02bafe
JB
1#
2# Conditional build:
3%bcond_without apidocs # do not build and package API docs
4%bcond_with mpi # MPI support
5%bcond_with skv # SKV (Scalable Key-Value Store) support
3da0d941 6
7c02bafe
JB
7Summary: Lunchbox - C++ library for multi-threading programming
8Summary(pl.UTF-8): Lunchbox - biblioteka C++ do programowania wielowątkowego
9Name: Lunchbox
c6de7caf
JR
10Version: 1.13.0
11Release: 1
7c02bafe
JB
12License: LGPL v2.1
13Group: Libraries
14Source0: https://github.com/Eyescale/Lunchbox/archive/%{version}/%{name}-%{version}.tar.gz
c6de7caf 15# Source0-md5: f782452db284a2e4e4fec687f95dfd30
382ae9ec 16Patch2: cxx.patch
7c02bafe 17URL: http://pogl.wordpress.com/category/lunchbox/
c6de7caf 18BuildRequires: Eyescale-CMake >= 2016.04
7c02bafe
JB
19BuildRequires: avahi-devel
20BuildRequires: boost-devel >= 1.41.0
21BuildRequires: cmake >= 2.8
22%{?with_apidocs:BuildRequires: doxygen}
23BuildRequires: gcc-c++ >= 6:4.2
24BuildRequires: hwloc-devel >= 1.3
25BuildRequires: leveldb-devel
26BuildRequires: libgomp-devel
27BuildRequires: libjpeg-turbo-devel >= 1.2.1
28BuildRequires: libstdc++-devel
29%{?with_mpi:BuildRequires: mpi-devel}
30BuildRequires: pkgconfig
31%{?with_skv:BuildRequires: skv-devel}
32Requires: hwloc-libs >= 1.3
33Requires: libjpeg-turbo >= 1.2.1
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%description
37Lunchbox is a C++ library for multi-threaded programming. Lunchbox was
38formerly known as eq::base or co::base, the foundation for the
39Equalizer parallel rendering framework and the Collage network
40library. It is intended for all application developers creating
41high-performance multi-threaded programs.
42
43%description -l pl.UTF-8
44Lunchbox to biblioteka C++ do programowania wielowątkowego. Wcześniej
45była znana jako eq::base lub co::base - podstawa szkieletu do
46renderowania wielowątkowego Equalizer lub biblioteki sieciowej
47Collage. Biblioteka jest przeznaczona dla wszystkich programistów
48tworzących wysoko wydajne, wielowątkowe aplikacje.
49
50%package devel
51Summary: Header files for Lunchbox library
52Summary(pl.UTF-8): Pliki nagłówkowe biblioteki Lunchbox
53Group: Development/Libraries
54Requires: %{name} = %{version}-%{release}
55Requires: boost-devel >= 1.41.0
56Requires: libgomp-devel
57Requires: libstdc++-devel
58
59%description devel
60Header files for Lunchbox library.
61
62%description devel -l pl.UTF-8
63Pliki nagłówkowe biblioteki Lunchbox.
64
65%package apidocs
66Summary: Lunchbox API documentation
67Summary(pl.UTF-8): Dokumentacja API biblioteki Lunchbox
68Group: Documentation
3da0d941
ER
69%if "%{_rpmversion}" >= "5"
70BuildArch: noarch
71%endif
7c02bafe
JB
72
73%description apidocs
74API documentation for Lunchbox library.
75
76%description apidocs -l pl.UTF-8
77Dokumentacja API biblioteki Lunchbox.
78
79%prep
c6de7caf 80%setup -q
7c02bafe 81
c6de7caf 82ln -s %{_datadir}/Eyescale-CMake CMake/common
7c02bafe
JB
83%{__rm} .gitexternals
84
382ae9ec 85%patch2 -p1
c428797b 86
7c02bafe
JB
87%build
88install -d build
89cd build
90%cmake .. \
91 -DBUILDYARD_DISABLED=ON \
92 %{!?with_mpi:-DCMAKE_DISABLE_FIND_PACKAGE_MPI=ON} \
93 %{!?with_skv:-DCMAKE_DISABLE_FIND_PACKAGE_skv=ON}
94%{__make}
95
96%if %{with apidocs}
97doxygen doc/Doxyfile
98%endif
99
100%install
101rm -rf $RPM_BUILD_ROOT
102
103%{__make} -C build install \
104 DESTDIR=$RPM_BUILD_ROOT
105
106%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/Lunchbox/{doc,tests}
107
108%clean
109rm -rf $RPM_BUILD_ROOT
110
111%post -p /sbin/ldconfig
112%postun -p /sbin/ldconfig
113
114%files
115%defattr(644,root,root,755)
c6de7caf 116%doc ACKNOWLEDGEMENTS.txt AUTHORS.txt CHANGES.txt LICENSE.txt README.md doc/Changelog.md
7c02bafe 117%attr(755,root,root) %{_libdir}/libLunchbox.so.*.*.*
c6de7caf 118%attr(755,root,root) %ghost %{_libdir}/libLunchbox.so.6
7c02bafe
JB
119
120%files devel
121%defattr(644,root,root,755)
122%attr(755,root,root) %{_libdir}/libLunchbox.so
123%{_includedir}/lunchbox
7c02bafe
JB
124%dir %{_datadir}/Lunchbox
125%{_datadir}/Lunchbox/CMake
126
127%if %{with apidocs}
128%files apidocs
129%defattr(644,root,root,755)
130%doc build/doc/html/*
131%endif
This page took 1.11984 seconds and 4 git commands to generate.