]> git.pld-linux.org Git - packages/InDependence.git/blame - InDependence.spec
- based on spec found from asplinux
[packages/InDependence.git] / InDependence.spec
CommitLineData
0113a9aa
ER
1Summary: RPM Dependency Tracker
2Name: InDependence
3Version: 1.0
4Release: 1
5Group: Applications/System
6Source0: %{name}_%{version}.tar.gz
7# Source0-md5: df419e1443683305891060985f723902
8Patch0: %{name}_1.0-rpmlib.asp.patch
9License: Artistic License
10URL: http://www.cse.ogi.edu/DISC/projects/independence/
11BuildArch: noarch
12BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14%description
15InDependence is a suite of tools (well two :-) designed to help RPM
16packagers and system administrators deal with the dependencies between
17RPM packages. InDependence has two major components:
18
19Dep: This tool is for the RPM packager that identifies external files
20or RPM packages that a program uses.
21
22RPMTC: "RPM Transitive Closure". This tool is for the RPM system
23administrator. "rpmtc foo.rpm" will transitively compute the -
24- *entire* set of RPMs necessary to support the foo.rpm package, i.e.
25 if foo.rpm depends on bar.rpm, and bar.rpm depends on baz.rpm, RPMTC
26 will report both bar and baz.
27
28%prep
29%setup -q -n %{name}_%{version}
30%patch0 -p1
31
32%build
33%{__make}
34
35%install
36rm -rf $RPM_BUILD_ROOT
37install -d ${RPM_BUILD_ROOT}%{_bindir}
38install dep/dep ${RPM_BUILD_ROOT}%{_bindir}/dep
39install dep/swrapper.pl ${RPM_BUILD_ROOT}%{_bindir}/swrapper.pl
40install rpmtc/rpmtc ${RPM_BUILD_ROOT}%{_bindir}/rpmtc
41install rpmtc/rpmdep-pipe ${RPM_BUILD_ROOT}%{_bindir}/rpmdep-pipe
42install -d ${RPM_BUILD_ROOT}%{_mandir}/man1
43install dep/dep.1 ${RPM_BUILD_ROOT}%{_mandir}/man1/dep.1
44install rpmtc/rpmtc.1 ${RPM_BUILD_ROOT}%{_mandir}/man1/rpmtc.1
45
46%clean
47rm -rf $RPM_BUILD_ROOT
48
49%files
50%defattr(644,root,root,755)
51%doc README
52%attr(755,root,root) %{_bindir}/dep
53%attr(755,root,root) %{_bindir}/rpmdep-pipe
54%attr(755,root,root) %{_bindir}/rpmtc
55%attr(755,root,root) %{_bindir}/swrapper.pl
56%{_mandir}/man1/dep.1*
57%{_mandir}/man1/rpmtc.1*
This page took 0.05904 seconds and 4 git commands to generate.