]> git.pld-linux.org Git - packages/Collage.git/blame - Collage.spec
rpm version for noarch subpackage
[packages/Collage.git] / Collage.spec
CommitLineData
262ad267
JB
1#
2# Conditional build:
3%bcond_without apidocs # do not build and package API docs
59a55be8 4
262ad267
JB
5Summary: Cross-platform C++ network library
6Summary(pl.UTF-8): Wieloplatformowa biblioteka sieciowa dla C++
7Name: Collage
44e57821 8Version: 1.7.0
df65f790 9Release: 6
262ad267
JB
10License: LGPL v2.1
11Group: Libraries
44e57821 12#Source0Download: https://github.com/Eyescale/Collage/releases
262ad267 13Source0: https://github.com/Eyescale/Collage/archive/%{version}/%{name}-%{version}.tar.gz
44e57821 14# Source0-md5: f0e57c1a2f6196c11ad8ac6029483e56
ced5b5c1 15Patch0: boost-1.61.patch
61f14322 16Patch1: %{name}-boost.patch
262ad267 17URL: http://libcollage.net/
44e57821
JB
18BuildRequires: Lunchbox-devel >= 1.16.0
19BuildRequires: Eyescale-CMake >= 2017.05
20BuildRequires: Pression-devel >= 2.0.0
21BuildRequires: Servus-devel >= 1.5.1
262ad267 22BuildRequires: boost-devel >= 1.41.0
44e57821 23BuildRequires: cmake >= 3.1
262ad267
JB
24%{?with_apidocs:BuildRequires: doxygen}
25BuildRequires: libibverbs-devel
26BuildRequires: librdmacm-devel
27BuildRequires: libstdc++-devel
28BuildRequires: pkgconfig
54e13fd9 29BuildRequires: rpm-build >= 4.6
93cca369 30BuildRequires: rpmbuild(macros) >= 1.605
262ad267 31BuildRequires: udt-devel
44e57821
JB
32Requires: Lunchbox >= 1.16.0
33Requires: Pression >= 2.0.0
34Requires: Servus >= 1.5.1
262ad267
JB
35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37%description
38Collage is a cross-platform C++ library for building heterogenous,
39distributed applications. Among other things, it is the cluster
40backend for the Equalizer parallel rendering framework. Collage
41provides an abstraction of different network connections, peer-to-peer
42messaging, node discovery, synchronization and high-performance,
43object-oriented, versioned data distribution. Collage is designed for
44low-overhead multi-threaded execution which allows applications to
45easily exploit multi-core architectures.
46
47%description -l pl.UTF-8
48Collage to wieloplatformowa biblioteka C++ do tworzenia
49heterogenicznych, rozproszonych aplikacji. Jest to między innymi
50backend klastrowy dla szkieletu równoległego renderowania Equalizer.
51Zapewnia abstrakcję różnych połączeń sieciowych, przesyłania
52komunikatów między węzłami, wykrywanie węzłów, synchronizację oraz
53wydajne, zorientowane obiektowo i wersjonowane rozproszenie danych.
54Collage został zaprojektowany pod kątem lekkiej wielowątkowości, co
55pozwala aplikacjom łatwo wykorzystywać architektury wielordzeniowe.
56
57%package devel
58Summary: Header files for Collage library
59Summary(pl.UTF-8): Pliki nagłówkowe biblioteki Collage
60Group: Development/Libraries
61Requires: %{name} = %{version}-%{release}
44e57821
JB
62Requires: Lunchbox-devel >= 1.16.0
63Requires: Pression-devel >= 2.0.0
64Requires: Servus-devel >= 1.5.1
65Requires: boost-devel >= 1.41.0
262ad267
JB
66
67%description devel
68Header files for Collage library.
69
70%description devel -l pl.UTF-8
71Pliki nagłówkowe biblioteki Collage.
72
73%package apidocs
74Summary: Collage API documentation
75Summary(pl.UTF-8): Dokumentacja API biblioteki Collage
76Group: Documentation
59a55be8 77BuildArch: noarch
262ad267
JB
78
79%description apidocs
80API documentation for Collage library.
81
82%description apidocs -l pl.UTF-8
83Dokumentacja API biblioteki Collage.
84
85%prep
ced5b5c1
JR
86%setup -q
87%patch0 -p1
61f14322 88%patch1 -p1
262ad267 89
44e57821 90rmdir CMake/common
ced5b5c1 91ln -s %{_datadir}/Eyescale-CMake CMake/common
262ad267
JB
92
93%build
94install -d build
95cd build
96%cmake .. \
0f6053fd
JP
97 -DBUILDYARD_DISABLED=ON \
98 -DCOMMON_DISABLE_WERROR=ON
262ad267
JB
99%{__make}
100
101%if %{with apidocs}
102doxygen doc/Doxyfile
103%endif
104
105%install
106rm -rf $RPM_BUILD_ROOT
107
108%{__make} -C build install \
109 DESTDIR=$RPM_BUILD_ROOT
110
111%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/Collage/{doc,tests}
112
113%clean
114rm -rf $RPM_BUILD_ROOT
115
116%post -p /sbin/ldconfig
117%postun -p /sbin/ldconfig
118
119%files
120%defattr(644,root,root,755)
ced5b5c1 121%doc LICENSE.txt README.md doc/{README.IB,README.udt} doc/Changelog.md
262ad267
JB
122%attr(755,root,root) %{_bindir}/coNetperf
123%attr(755,root,root) %{_bindir}/coNodeperf
124%attr(755,root,root) %{_bindir}/coObjectperf
125%attr(755,root,root) %{_libdir}/libCollage.so.*.*.*
44e57821 126%attr(755,root,root) %ghost %{_libdir}/libCollage.so.7
262ad267
JB
127
128%files devel
129%defattr(644,root,root,755)
130%attr(755,root,root) %{_libdir}/libCollage.so
131%{_includedir}/co
262ad267
JB
132%dir %{_datadir}/Collage
133%{_datadir}/Collage/CMake
134
135%if %{with apidocs}
136%files apidocs
137%defattr(644,root,root,755)
138%doc build/doc/html/*
139%endif
This page took 0.18213 seconds and 4 git commands to generate.