]> git.pld-linux.org Git - packages/AfterStep-APPS.git/blame - AfterStep-APPS.spec
almost raw
[packages/AfterStep-APPS.git] / AfterStep-APPS.spec
CommitLineData
720be1ad
JR
1Summary: Applets you can use with AfterStep and compatible window managers.
2Name: AfterStep-APPS
3Version: 990329
4Release: 2
5Copyright: GPL
6Group: User Interface/Desktops
7BuildRoot: /var/tmp/afterstep-apps-root
8Source0: http://www.tigr.net/afterstep/as-apps/download/as-apps-%{version}.tar
9Patch0: AfterStep-APPS-1.5beta1-glibc.patch
10Patch1: ascp-paths.patch
11Patch2: as-apps-compile.patch
12Patch3: aterm-utmp.patch
13Patch4: xiterm-utmp.patch
14Prereq: /sbin/ldconfig
15Requires: /usr/sbin/utempter
16
17%description
18What's a cool window manager without some cool applets?
19Well... it's still cool, but these applets which can
20be used in the Wharf module for AfterStep or Window
21Maker can add both spice and productivity to your
22preferred window manager, such as a handy clock and
23information about system resources.
24
25If you've installed the AfterStep packages, you
26should also install these packages. Enjoy!
27
28%prep
29%setup -q -c
30rm -f *.asc
31for archive in *.tar.gz ; do
32 tar xzf $archive
33 rm -f $archive
34done
35%patch0 -p1 -b .glibc
36%patch1 -p1 -b .paths
37%patch3 -p0 -b .autmp
38%patch4 -p1 -b .xiutmp
39
40%build
41for package in `ls` ; do
42 cd $package
43 case $package in
44 ascd-* )
45 ./configure << EOF
461
47
481
49
50
51
52EOF
53 patch -p2 -b --suffix .compile < %{PATCH2}
54 xmkmf
55 make Makefiles
56 make MANDIR=/usr/X11R6/man/man1 \
57 BINDIR=/usr/X11R6/bin \
58 SHLIBDIR=/usr/X11R6/lib \
59 ;;
60
61 asmount* | asDrinks* | asbutton* | asdm* | aspbm* | aspostit* | ascdc-* | astuner* | ASFiles* | as[R-W]* | asfaces* | asmon* | astrash* | asxmcd* )
62 # we don't compile these
63 ;;
64
65 aterm*)
66 CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=/usr/X11R6 \
67 --enable-utmp
68 make
69 ;;
70
71 xiterm*)
72 # cough cough, hack hack -- ewt
73 CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=/usr/X11R6 \
74 --enable-xpm-background --enable-utmp --enable-wtmp \
75 --enable-menubar --enable-next-scroll
76 xmkmf
77 make Makefiles
78 cd src
79 sed -e "s/EXTRA_LIBRARIES =/EXTRA_LIBRARIES = -lutempter/" \
80 Makefile > Makefile.foo
81 sed -e "s/-lsocket //" Makefile.foo > Makefile
82 make
83 ;;
84 asclock*)
85 CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=/usr/X11R6 << EOF
86classic
87
88EOF
89 make
90 ;;
91 *)
92 #just about every other thing supports autoconf
93 CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=/usr/X11R6 --datadir=/usr/share
94 make
95 ;;
96 esac
97 cd ..
98done
99
100%install
101
102rm -rf $RPM_BUILD_ROOT
103mkdir -p $RPM_BUILD_ROOT/usr/X11R6/bin
104mkdir -p $RPM_BUILD_ROOT/usr/X11R6/man/man1
105
106for package in `ls` ; do
107 cd $package
108 case $package in
109 ascd-* | xiterm*)
110 make install install.man \
111 AFTER_BIN_DIR=$RPM_BUILD_ROOT/usr/X11R6/bin \
112 AFTER_MAN_DIR=$RPM_BUILD_ROOT/usr/X11R6/man/man1 \
113 MANDIR=/usr/X11R6/man/man1 \
114 BINDIR=/usr/X11R6/bin \
115 SHLIBDIR=/usr/X11R6/lib \
116 DESTDIR=$RPM_BUILD_ROOT
117 ;;
118
119 asmount* | asDrinks* | asbutton* | asdm* | aspbm* | aspostit* | ascdc-* | astuner* | ASFiles* | as[R-W]* | asfaces* | asmon* | astrash* | asxmcd* )
120 # we don't install this
121 ;;
122
123 ascp-* )
124 make install \
125 ASCP_BIN_DIR=$RPM_BUILD_ROOT/usr/X11R6/bin \
126 ASCP_MAN_DIR=$RPM_BUILD_ROOT/usr/X11R6/man/man1 \
127 prefx=$RPM_BUILD_ROOT \
128 DESTDIR=$RPM_BUILD_ROOT
129 ;;
130
131
132 asppp* | aterm* )
133 make install \
134 AFTER_BIN_DIR=$RPM_BUILD_ROOT/usr/X11R6/bin \
135 AFTER_MAN_DIR=$RPM_BUILD_ROOT/usr/X11R6/man/man1 \
136 DESTDIR=$RPM_BUILD_ROOT
137 ;;
138 *)
139 make install install.man \
140 AFTER_BIN_DIR=$RPM_BUILD_ROOT/usr/X11R6/bin \
141 AFTER_MAN_DIR=$RPM_BUILD_ROOT/usr/X11R6/man/man1 \
142 DESTDIR=$RPM_BUILD_ROOT
143 ;;
144 esac
145 cd ..
146done
147rm -f $RPM_BUILD_ROOT/usr/X11R6/{bin,man/man1}/{sessreg,xpmroot,qplot}*
148strip $RPM_BUILD_ROOT/usr/X11R6/bin/*
149
150%clean
151rm -rf $RPM_BUILD_ROOT
152
153%post -p /sbin/ldconfig
154
155%postun -p /sbin/ldconfig
156
157%files
158/usr/X11R6/bin/*
159/usr/share/afterstep/*
160/usr/X11R6/man/man1/*
This page took 0.072239 seconds and 4 git commands to generate.