]> git.pld-linux.org Git - packages/beignet.git/blame - beignet.spec
a couple of patches from Debian
[packages/beignet.git] / beignet.spec
CommitLineData
039979b7
JK
1#
2# TODO:
3# - make it build with our LLVM
4#
5
6# Conditional build:
7%bcond_with host_pci_id # build specifically for the build host
8
9# by default build kernel for Intel Ivybridge
10%define gen_pci_id 0x0162
11
22ed1ab0 12Summary: Open source implementation of the OpenCL specification for Intel GPUs
9dfe627a 13Summary(pl.UTF-8): Mająca otwarte źródła implementacja specyfikacji OpenGL dla GPU formy Intel
22ed1ab0 14Name: beignet
039979b7
JK
15Version: 1.3.1
16Release: 0.1
9dfe627a 17License: LGPL v2+
22ed1ab0 18Group: Libraries
039979b7
JK
19Source0: https://01.org/sites/default/files/beignet-%{version}-source.tar.gz
20# Source0-md5: 850886a71a34672ca26a42046d0bb442
b4439341
JK
21Patch0: cflags.patch
22Patch1: static_llvm.patch
22ed1ab0
JK
23URL: http://www.freedesktop.org/wiki/Software/Beignet/
24BuildRequires: Mesa-libgbm-devel
039979b7 25BuildRequires: Mesa-libEGL-devel
978e36e0 26BuildRequires: OpenGL-devel
22ed1ab0 27BuildRequires: clang-devel
9dfe627a 28BuildRequires: cmake >= 2.6.0
22ed1ab0 29BuildRequires: libdrm-devel
039979b7 30BuildRequires: libedit-devel
9dfe627a 31BuildRequires: libstdc++-devel
039979b7
JK
32BuildRequires: llvm >= 3.6
33BuildRequires: llvm-devel >= 3.6
34BuildRequires: ncurses-devel
22ed1ab0 35BuildRequires: ocl-icd-devel
9dfe627a
JB
36BuildRequires: pkgconfig
37BuildRequires: python
38BuildRequires: sed >= 4.0
22ed1ab0
JK
39BuildRequires: xorg-lib-libXext-devel
40BuildRequires: xorg-lib-libXfixes-devel
039979b7 41BuildRequires: zlib-devel
22ed1ab0
JK
42Provides: ocl-icd(beignet)
43Provides: ocl-icd-driver
44BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46%description
47Beignet is an open source implementation of the OpenCL specification -
48a generic compute oriented API. This code base contains the code to
49run OpenCL programs on Intel GPUs which basically defines and
50implements the OpenCL host functions required to initialize the
51device, create the command queues, the kernels and the programs and
52run them on the GPU.
53
9dfe627a
JB
54%description -l pl.UTF-8
55Beignet to mająca otwarte źródła implementacja specyfikacji OpenCL -
56ogólnego API przeznaczonego do obliczeń. Ten pakiet zawiera kod do
57uruchamiania programów OpenCL na procesorach graficznych (GPU) firmy
58Intel; kod ten zasadniczo definiuje i implementuje funkcje hosta
59OpenCL wymagane do zainicjowania urządzenia, tworzenia kolejek
60poleceń, jądra i programów oraz uruchamia je na GPU.
61
22ed1ab0 62%prep
039979b7 63%setup -qn Beignet-%{version}-Source
22ed1ab0 64
b4439341
JK
65%patch0 -p1
66%patch1 -p1
67
9dfe627a 68
22ed1ab0
JK
69%build
70install -d build
71cd build
72%cmake \
73 -DLIB_INSTALL_DIR=%{_libdir} \
978e36e0
JK
74 -DCMAKE_CXX_FLAGS_PLD="%{rpmcxxflags} -DNDEBUG -DGBE_DEBUG=0" \
75 -DCMAKE_C_FLAGS_PLD="%{rpmcxxflags} -DNDEBUG -DGBE_DEBUG=0" \
039979b7 76 -DGEN_PCI_ID=%{gen_pci_id} \
22ed1ab0
JK
77 ../
78%{__make}
79
80%install
81rm -rf $RPM_BUILD_ROOT
82
83%{__make} -C build install \
84 DESTDIR=$RPM_BUILD_ROOT
85
9dfe627a 86%{__rm} -r $RPM_BUILD_ROOT%{_includedir}
22ed1ab0
JK
87
88%clean
89rm -rf $RPM_BUILD_ROOT
90
91%files
92%defattr(644,root,root,755)
93%doc docs/*
94%dir %{_libdir}/%{name}
95%{_libdir}/%{name}/beignet.bc
96%attr(755,root,root) %{_libdir}/%{name}/libcl.so
978e36e0
JK
97%attr(755,root,root) %{_libdir}/%{name}/libgbe.so
98%attr(755,root,root) %{_libdir}/%{name}/libgbeinterp.so
b4439341
JK
99%{_libdir}/%{name}/beignet.pch
100%{_libdir}/%{name}/beignet_20.bc
101%{_libdir}/%{name}/beignet_20.pch
102%{_libdir}/%{name}/include
22ed1ab0 103/etc/OpenCL/vendors/intel-beignet.icd
This page took 0.055268 seconds and 4 git commands to generate.