]> git.pld-linux.org Git - packages/apache1-mod_pointer.git/blame - apache1-mod_pointer.spec
- add more %doc
[packages/apache1-mod_pointer.git] / apache1-mod_pointer.spec
CommitLineData
32cdfe24
ER
1# TODO
2# - apache config
3# - package split by backend
4%define mod_name pointer
5%define apxs %{_sbindir}/apxs1
6Summary: Apache module for making domain redirects
7Name: apache1-mod_%{mod_name}
8Version: 0.8
fc3cd936 9Release: 0.6
32cdfe24
ER
10License: Apache
11Group: Networking/Daemons
12Source0: http://stderr.net/mod_pointer/dist/mod_pointer-%{version}.tar.gz
13# Source0-md5: 2f6529c49f1d10ecd06d3f6bc8503a5f
fc3cd936 14Patch0: apache1-mod_pointer-mysql.patch
32cdfe24
ER
15URL: http://stderr.net/mod_pointer/
16BuildRequires: apache1-devel >= 1.3.33-2
17BuildRequires: gdbm-devel
18BuildRequires: mysql-devel
19BuildRequires: postgresql-devel
20BuildRequires: rpmbuild(macros) >= 1.268
21Requires: apache1 >= 1.3.33-2
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
25%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)
26
27%description
28mod_pointer is an Apache module for making domain redirects easy - the
29known service of many hosting providers that lets a domain point to
30your webpage on another server.
31
32The configuration part of the mappings are handled in either a MySQL
33or Postgresql database or a NDBM or SDBM db file, so it's easy to
34build a webbased interface for letting users change it on their own.
35
36%prep
37%setup -q -n mod_%{mod_name}-%{version}
fc3cd936 38%patch0 -p1
32cdfe24
ER
39
40%build
41%{__make} all \
42 WITH_APXS=%{apxs}
43
44%install
45rm -rf $RPM_BUILD_ROOT
46install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
47
48%{__make} install \
49 APXS="%{apxs} -S DESTDIR=$RPM_BUILD_ROOT"
50
51%clean
52rm -rf $RPM_BUILD_ROOT
53
54%post
55%service -q apache restart
56
57%postun
58if [ "$1" = "0" ]; then
59 %service -q apache restart
60fi
61
62%files
63%defattr(644,root,root,755)
fc3cd936 64%doc README CHANGES SUPPORT TODO frameset.html *.sql *.readme pointer.conf
32cdfe24
ER
65#%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
66%attr(755,root,root) %{_pkglibdir}/*
This page took 0.09436 seconds and 4 git commands to generate.