]> git.pld-linux.org Git - packages/apache-mod_spdy.git/blame - apache-mod_spdy.spec
add asf origin info
[packages/apache-mod_spdy.git] / apache-mod_spdy.spec
CommitLineData
c6d40ac0
ER
1# NOTE:
2# - apache 2.4 patch https://code.google.com/p/mod-spdy/issues/detail?id=64
3# and a fork (due lack of response in upstream): https://github.com/eousphoros/mod-spdy
de7f1b17
ER
4# - donated to asf http://googledevelopers.blogspot.com/2014/06/modspdy-is-now-apache-project.html
5# whose repo is at https://svn.apache.org/repos/asf/httpd/mod_spdy/trunk/
ce046aa5
ER
6#
7# Conditional build:
8%bcond_with werror # build with "-Werror" enabled
9
7e12550d
ER
10%define mod_name spdy
11%define apxs %{_sbindir}/apxs
7139bb6c 12Summary: Apache module to enable SPDY support
7e12550d
ER
13Name: apache-mod_%{mod_name}
14Version: 0.9.3.3
1b8cc06f 15Release: 1
7e12550d
ER
16License: Apache v2.0
17Group: Daemons
18Source0: mod-spdy-%{version}.tar.xz
19# Source0-md5: 35770e4855b2953440be5a56d9da3fa4
20Source1: get-source.sh
21Source2: gclient.conf
22Patch0: gyp.patch
23Patch1: log-constants.patch
1b8cc06f 24Patch2: apache2.4.patch
7139bb6c 25Patch3: system-zlib.patch
7e12550d
ER
26URL: http://code.google.com/p/mod-spdy/
27BuildRequires: %{apxs}
28BuildRequires: apache-devel >= 2.2
29BuildRequires: tar >= 1:1.22
30BuildRequires: xz
31Requires: apache(modules-api) = %apache_modules_api
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
35%define _pkgrootdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)
36%define _sysconfdir %{_pkgrootdir}/conf.d
37
38%description
39mod_spdy is an Apache module that allows an Apache server to support
40the SPDY protocol for serving HTTP resources.
41
42%prep
43%setup -q -n mod-spdy-%{version}
44%patch0 -p1
45%patch1 -p1
1b8cc06f 46%patch2 -p1
7139bb6c 47%patch3 -p1
7e12550d
ER
48
49%build
50CC="%{__cc}" \
51CXX="%{__cxx}" \
52%{__python} build/gyp_chromium \
53 --format=make \
54 --depth=. \
55 build/all.gyp \
ce046aa5 56 %{!?with_werror:-Dwerror=} \
7e12550d
ER
57 -Duse_openssl=1 \
58 -Duse_system_apache_dev=1 \
59 -Duse_system_libjpeg=1 \
60 -Duse_system_libpng=1 \
61 -Duse_system_opencv=1 \
62 -Duse_system_zlib=1 \
63 -Dsystem_include_path_apr=%{_includedir}/apr \
64 -Dsystem_include_path_aprutil=%{_includedir}/apr-util \
65 -Dsystem_include_path_httpd=%{_includedir}/apache \
66 %{nil}
67
68%{__make} mod_spdy \
69 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
70 %{?with_verbose:V=1} \
71 CC="%{__cc}" \
72 CXX="%{__cxx}" \
73 CC.host="%{__cc}" \
74 CXX.host="%{__cxx}" \
75 LINK.host="%{__cxx}" \
76 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
77 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
78 %{nil}
79
80%install
81rm -rf $RPM_BUILD_ROOT
82install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
83
84out=out/%{!?debug:Release}%{?debug:Debug}
85install -p $out/libmod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}/mod_%{mod_name}.so
86
87cat > $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_%{mod_name}.conf <<EOF
88LoadModule %{mod_name}_module modules/mod_%{mod_name}.so
89EOF
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%post
95%service -q httpd restart
96
97%postun
98if [ "$1" = "0" ]; then
99 %service -q httpd restart
100fi
101
102%files
103%defattr(644,root,root,755)
104%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
105%attr(755,root,root) %{_pkglibdir}/mod_%{mod_name}.so
This page took 0.083903 seconds and 4 git commands to generate.