]> git.pld-linux.org Git - packages/apache-mod_pagespeed.git/blame - apache-mod_pagespeed.spec
up to 1.8.31.5
[packages/apache-mod_pagespeed.git] / apache-mod_pagespeed.spec
CommitLineData
757b3ba5
ER
1#
2# Conditional build:
42a31ab3 3%bcond_without verbose # verbose build (V=1)
757b3ba5 4
b6a5d8d0 5# NOTE
e540e830 6# - relase notes: https://developers.google.com/speed/pagespeed/module/release_notes
757b3ba5 7# - http://code.google.com/p/modpagespeed/wiki/HowToBuild
eb743e9a 8# - http://wiki.mediatemple.net/w/(dv)_HOWTO:_Install_mod_pagespeed
b6a5d8d0 9# TODO
757b3ba5 10# - add unit tests running
b6a5d8d0
ER
11# - possible sysdeps (uses release tags)
12# "serf_src": "http://serf.googlecode.com/svn/tags/0.3.1",
b6a5d8d0
ER
13# "gflags_root": "http://google-gflags.googlecode.com/svn/tags/gflags-1.3/src",
14# "google_sparsehash_root": "http://google-sparsehash.googlecode.com/svn/tags/sparsehash-1.8.1/src",
b74b29a5 15# protobuf_lite
24f1647c 16
08710a2f 17%define mod_name pagespeed
cad452c8 18%define apxs %{_sbindir}/apxs
08710a2f
ER
19Summary: Apache module for rewriting web pages to reduce latency and bandwidth
20Name: apache-mod_%{mod_name}
ffebf8bc
ER
21# beta: 1.9.32.2-beta
22# stable: 1.8.31.5
23Version: 1.8.31.5
24Release: 0.6
08710a2f
ER
25License: Apache v2.0
26Group: Networking/Daemons/HTTP
4623c72a 27Source0: modpagespeed-%{version}.tar.xz
ffebf8bc 28# Source0-md5: ce0f27b177fba51f6b9f08fed8134709
b74b29a5 29Source1: get-source.sh
5a3e561c 30Source2: gclient.conf
42a31ab3 31Patch0: system-libs.patch
1a9213c5 32Patch2: bug-632.patch
cad452c8 33Patch4: no-dev-stdout.patch
59548b66 34URL: https://developers.google.com/speed/pagespeed/module
08710a2f
ER
35BuildRequires: %{apxs}
36BuildRequires: apache-devel >= 2.2
ffebf8bc 37BuildRequires: bash
42a31ab3 38BuildRequires: glib2-devel
3f27b998 39BuildRequires: gperf
42a31ab3 40BuildRequires: libselinux-devel
b74b29a5 41BuildRequires: libstdc++-devel >= 5:4.1
4623c72a 42BuildRequires: opencv-devel >= 2.3.1
42a31ab3 43BuildRequires: openssl-devel
3f27b998 44BuildRequires: pkgconfig
757b3ba5 45BuildRequires: python-devel >= 1:2.6
4623c72a
ER
46# This version of gyp is new enough that it knows to use make for Linux 3.x
47# and FreeBSD, but old enough that 'type': 'settings' works and
48# LINKER_SUPPORTS_ICF hasn't been removed yet.
3fbdacfc 49BuildRequires: python-gyp >= 0.1-0.svn1602.1
08710a2f 50BuildRequires: rpmbuild(macros) >= 1.268
4623c72a 51BuildRequires: tar >= 1:1.22
2ddcd200 52BuildRequires: util-linux
4623c72a 53BuildRequires: xz
42a31ab3 54BuildRequires: zlib-devel
08710a2f 55Requires: apache(modules-api) = %apache_modules_api
e5171f2e 56Requires: apache-mod_authz_host
3f27b998 57Requires: apache-mod_headers
b6a5d8d0 58Suggests: apache-mod_deflate
08710a2f
ER
59BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
06daee42
ER
62%define _pkgrootdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)
63%define _sysconfdir %{_pkgrootdir}/conf.d
64%define htdocsdir %(%{apxs} -q htdocsdir 2>/dev/null)
65%define cachedir %(%{apxs} -q proxycachedir 2>/dev/null)/mod_%{mod_name}
08710a2f
ER
66
67%description
68mod_pagespeed automates the application of those rules in an Apache
69server. HTML, CSS, JavaScript, and images are changed dynamically
70during the web serving process, so that the best practices recommended
71by Page Speed can be used without having to change the way the web
72site is maintained.
73
74%prep
5bdfa704
ER
75%setup -q -n modpagespeed-%{version}
76%patch0 -p2
ce5a7d18 77%patch2 -p1
9c41f6b1 78%patch4 -p1
08710a2f
ER
79
80%build
eb743e9a 81# re-gen makefiles
e62ba6cb
ER
82CC="%{__cc}" \
83CXX="%{__cxx}" \
5bdfa704
ER
84%{__python} build/gyp_chromium \
85 --format=make \
86 --depth=. \
87 build/all.gyp \
42a31ab3
ER
88 -Duse_openssl=1 \
89 -Duse_system_apache_dev=1 \
90 -Duse_system_libjpeg=1 \
91 -Duse_system_libpng=1 \
92 -Duse_system_opencv=1 \
93 -Duse_system_zlib=1 \
b2f50394
ER
94 -Dsystem_include_path_apr=%{_includedir}/apr \
95 -Dsystem_include_path_aprutil=%{_includedir}/apr-util \
96 -Dsystem_include_path_httpd=%{_includedir}/apache \
42a31ab3
ER
97 %{nil}
98
1a9213c5 99%{__make} mod_pagespeed js_minify css_minify_main \
08710a2f
ER
100 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
101 %{?with_verbose:V=1} \
102 CC="%{__cc}" \
103 CXX="%{__cxx}" \
104 CC.host="%{__cc}" \
105 CXX.host="%{__cxx}" \
106 LINK.host="%{__cxx}" \
107 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
108 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
5bdfa704 109 %{nil}
08710a2f
ER
110
111%install
112rm -rf $RPM_BUILD_ROOT
1a9213c5
ER
113install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir},%{_bindir},%{cachedir}}
114
5bdfa704 115%{__make} -j1 -C install staging_except_module \
06daee42 116 APACHE_ROOT=%{_pkgrootdir} \
3f27b998 117 APACHE_MODULES=modules \
06daee42 118 APACHE_DOC_ROOT=%{htdocsdir} \
5bdfa704
ER
119 MOD_PAGESPEED_CACHE=%{cachedir} \
120 MOD_PAGESPEED_STATS_LOG=/var/log/httpd/mod_pagespeed_stats.log \
06daee42
ER
121 STAGING_DIR=staging
122
1a9213c5
ER
123out=out/%{!?debug:Release}%{?debug:Debug}
124install -p $out/libmod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}/mod_%{mod_name}.so
125install -p $out/js_minify $RPM_BUILD_ROOT%{_bindir}/pagespeed_js_minify
126install -p $out/css_minify_main $RPM_BUILD_ROOT%{_bindir}/pagespeed_css_minify
127
5bdfa704 128cd install/staging
06daee42
ER
129cat > $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_%{mod_name}.conf <<EOF
130LoadModule %{mod_name}_module modules/mod_%{mod_name}.so
131
132$(cat pagespeed.conf)
133EOF
08710a2f 134
1a9213c5
ER
135cp -p pagespeed_libraries.conf $RPM_BUILD_ROOT%{_sysconfdir}/91_mod_%{mod_name}_libraries.conf
136
3f27b998
ER
137install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
138cp -a mod_pagespeed_example/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
139
08710a2f
ER
140%clean
141rm -rf $RPM_BUILD_ROOT
142
143%post
144%service -q httpd restart
145
146%postun
147if [ "$1" = "0" ]; then
148 %service -q httpd restart
149fi
150
151%files
152%defattr(644,root,root,755)
08710a2f 153%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
1a9213c5
ER
154%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}_libraries.conf
155%attr(755,root,root) %{_bindir}/pagespeed_css_minify
156%attr(755,root,root) %{_bindir}/pagespeed_js_minify
b6a5d8d0 157%attr(755,root,root) %{_pkglibdir}/mod_%{mod_name}.so
3f27b998 158%{_examplesdir}/%{name}-%{version}
5bdfa704 159%dir %attr(770,root,http) %{cachedir}
This page took 0.150964 seconds and 4 git commands to generate.