]> git.pld-linux.org Git - packages/apache-mod_auth_pam.git/blame - apache-mod_auth_pam.spec
- added symbol_fixa patch which allow (de)register module using apxs.
[packages/apache-mod_auth_pam.git] / apache-mod_auth_pam.spec
CommitLineData
1511467c 1%define mod_name auth_pam
2Summary: This is the PAM authentication module for Apache
3Name: apache-mod_%{mod_name}
4Version: 1.0a
5Release: 1
6License: GPL
7Group: Networking/Daemons
8Group(de): Netzwerkwesen/Server
9Group(pl): Sieciowe/Serwery
10Source0: http://pam.sourceforge.net/mod_auth_pam/dist/mod_%{mod_name}.tar.gz
c1197a23 11Patch0: %{name}-symbol_fix.patch
1511467c 12BuildRequires: /usr/sbin/apxs
13BuildRequires: apache(EAPI)-devel
14Prereq: /usr/sbin/apxs
15Requires: apache(EAPI)
16URL: http://pam.sourceforge.net/mod_auth_pam/
17BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19%define _pkglibdir %(/usr/sbin/apxs -q LIBEXECDIR)
20
21%description
22This is an authentication module for Apache that allows you to
73f51453 23authenticate HTTP clients using PAM (pluggable authentication module).
1511467c 24
25%prep
26%setup -q -n mod_%{mod_name}-%{version}
c1197a23 27%patch -p1
1511467c 28
29%build
73f51453 30/usr/sbin/apxs -c mod_%{mod_name}.c -o mod_%{mod_name}.so -lpam -ldl
1511467c 31
32%install
33rm -rf $RPM_BUILD_ROOT
34install -d $RPM_BUILD_ROOT%{_pkglibdir}
35
36install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
37
38%post
39/usr/sbin/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
40if [ -f /var/lock/subsys/httpd ]; then
41 /etc/rc.d/init.d/httpd restart 1>&2
42fi
43
44%preun
45if [ "$1" = "0" ]; then
46 /usr/sbin/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
47 if [ -f /var/lock/subsys/httpd ]; then
48 /etc/rc.d/init.d/httpd restart 1>&2
49 fi
50fi
51
52%clean
53rm -rf $RPM_BUILD_ROOT
54
55%files
56%defattr(644,root,root,755)
57%attr(755,root,root) %{_pkglibdir}/*
This page took 0.039621 seconds and 4 git commands to generate.