]> git.pld-linux.org Git - packages/balsa.git/blobdiff - balsa.spec
- use iconv() in libc
[packages/balsa.git] / balsa.spec
index 2b8166b8ac7d028cfc245eb0fef513fc4cefd2d6..23a5e719b1bb75c0d13450a1ad6e71e73a16c4a9 100644 (file)
@@ -1,38 +1,39 @@
 #
 # Conditional build:
-# --without ldap
+%bcond_without ldap            # build without LDAP support
+%bcond_without gpgme           # build without GPG support (experimental)
+%bcond_without esmtp           # build without ESMTP support
+%bcond_without gtkhtml         # build without HTML support
 
-%define                snap    20030522
+%define                snap    20030630
 
 Summary:       balsa - GNOME e-Mail program
 Summary(pl):   Klient poczty dla GNOME z silnikiem mutt-a
 Summary(es):   Balsa es un lector de e-mail. Usa el toolkit GTK
 Summary(pt_BR):        Balsa é um leitor de e-mail. Usa o toolkit GTK
 Name:          balsa
-Version:       2.0.11
-Release:       1.%{snap}
-#Release:      1
+Version:       2.0.17
+Release:       1
 License:       GPL
 Group:         X11/Applications
-#Source0:      http://balsa.gnome.org/%{name}-%{version}.tar.bz2
-Source0:       %{name}-%{version}-%{snap}.tar.bz2
-# Source0-md5: 75d91e8c0b3fa10bc8b0d63eb7d29c2c
-Patch0:                %{name}-libtool_hack.patch
+Source0:       http://balsa.gnome.org/%{name}-%{version}.tar.bz2
+# Source0-md5: 851db68728ed9adea615eb2f249fa1ee
+#Source0:      %{name}-%{version}-%{snap}.tar.bz2
+#Patch0:               %{name}-libtool_hack.patch
 Patch1:                %{name}-desktop.patch
-Patch2:                %{name}-message-tree-patch-2003-05-22.gz
-Patch3:                %{name}-gcc33.patch
 URL:           http://balsa.gnome.org/
 BuildRequires: autoconf
 BuildRequires: automake
-BuildRequires: libesmtp-devel
+%{?with_esmtp:BuildRequires:   libesmtp-devel}
 BuildRequires: libgnomeprintui-devel >= 1.106.0
-BuildRequires: gpgme-devel >= 0.3.14 
+%{?with_gpgme:BuildRequires:   gpgme-devel >= 0.3.14}
 BuildRequires: gtk+2-devel >= 2.2.0
-BuildRequires:  libgtkhtml-devel
-BuildRequires:  libgnome-devel
-BuildRequires:  libgnomeui-devel
-%{!?_without_ldap:BuildRequires:       openldap-devel}
-BuildRequires:  aspell-devel >= 0.50
+%{?with_gtkhtml:BuildRequires: libgtkhtml-devel}
+BuildRequires: libltdl-devel
+BuildRequires: libgnome-devel
+BuildRequires: libgnomeui-devel >= 2.3.3.1-2
+%{?with_ldap:BuildRequires:    openldap-devel}
+BuildRequires: aspell-devel >= 0.50
 BuildRequires: xft-devel
 Requires:      gpgme >= 0.3.14
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -60,48 +61,35 @@ Suporta caixas de correio locais, POP3 a IMAP.
 
 %prep
 %setup -q
-%patch0 -p1
+#%patch0 -p1
 %patch1 -p1
-%patch2 -p1
-%patch3        -p1
 
 %build
-#%glib-gettextize --copy --force
-#%intltoolize --copy --force
-#%%{__libtoolize}
-#%%{__aclocal}
-#%%{__autoheader}
-#%%{__automake}
-#%%{__autoconf}
-
-#%cd libmutt
-#%%{__libtoolize}
-#%%{__aclocal}
-#%%{__autoheader}
-#%%{__automake}
-#%%{__autoconf}
-#%cd ..
-./autogen.sh
+#./autogen.sh
+cp -f /usr/share/automake/config.* .
 %configure \
        --with-ssl \
-       --with-gpgme \
-       %{!?_without_ldap:--enable-ldap} \
-       %{?_without_ldap:--disable-ldap}
+       %{!?with_esmtp:--without-esmtp} \
+       %{?with_gtkhtml:--enable-gtkhtml} \
+       %{!?with_gtkhtml:--disable-gtkhtml}\
+       %{!?with_gpgme:--without-gpgme} \
+       %{?with_ldap:--with-ldap} \
+       %{!?with_ldap:--without-ldap}
 
-%{__make} CFLAGS="%{rpmcflags} -fno-strict-aliasing"
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT 
+       DESTDIR=$RPM_BUILD_ROOT
 
 %find_lang %{name} --with-gnome --all-name
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post -p /usr/bin/scrollkeeper-update 
+%post -p /usr/bin/scrollkeeper-update
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
This page took 0.099051 seconds and 4 git commands to generate.