]> git.pld-linux.org Git - packages/apache1-mod_throttle.git/blobdiff - apache1-mod_throttle.spec
- Spanish summary/description fixes
[packages/apache1-mod_throttle.git] / apache1-mod_throttle.spec
index 51ba1cb9956b72cf331fcd110dfa4d7c40f27b26..cd07f96309bc3b79d82569ca2341e8c2f9337691 100644 (file)
@@ -1,4 +1,5 @@
-%define        apxs    /usr/sbin/apxs
+%define                mod_name        throttle
+%define        apxs            /usr/sbin/apxs1
 Summary:       Bandwidth & Request Throttling for Apache
 Summary(cs):   Omezení sí»ového provozu pro Apache
 Summary(de):   Ein Modul, das die Bandbreiten- und Anforderungseinschränkung für Apache implementiert
@@ -9,22 +10,23 @@ Summary(ja): Apache 
 Summary(pl):   T³umienie przepustowo¶ci i zapytañ dla Apache'a
 Summary(pt_BR):        Descompressão "On-the-fly" de arquivos HTML para o Apache
 Summary(sv):   En modul som implementerar bandvidd- och begäranbegränsningar i Apache
-Name:          apache-mod_throttle
+Name:          apache1-mod_%{mod_name}
 Version:       3.1.2
-Release:       5
-License:       Anthony Howe
+Release:       1
+License:       BSD-like
 Group:         Networking/Daemons
 Source0:       http://www.snert.com/Software/mod_throttle/mod_throttle312.tgz
-Patch0:                apache-mod_throttle-PLD-v6stuff.patch
+# Source0-md5: 6edc45c3ea8a0855d4b0b14cf0f76404
+Patch0:                apache1-mod_throttle-PLD-v6stuff.patch
 URL:           http://www.snert.com/Software/mod_throttle/
-BuildRequires: apache-devel
 BuildRequires: %{apxs}
-Prereq:                %{_sbindir}/apxs
-Requires:      apache >= 1.3.1
+BuildRequires: apache1-devel >= 1.3.1
+Requires(post,preun):  %{apxs}
+Requires:      apache1 >= 1.3.1
+Obsoletes:     apache-mod_%{mod_name} <= %{version}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define         _libexecdir     %{_libdir}/apache
-%define         _htmldocdir     /home/httpd/manual/mod
+%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR)
 
 %description
 This Apache module is intended to reduce the load on your server &
@@ -48,7 +50,7 @@ authentifizierte Benutzer eingestellt werden.
 %description -l es
 Mod_throttle puede usarse para limitar la cantidad de datos que su
 servidor web va a servir. Estos límites se pueden configurar para
-hosts virtuales individuales, directorios, lug<res o usuarios
+hosts virtuales individuales, directorios, lugares o usuarios
 autenticados.
 
 %description -l fr
@@ -69,7 +71,7 @@ Mod_throttle 
 Ç§¾Ú¥æ¡¼¥¶¡¼ÍѤˤĤ¤¤ÆÀßÄê¤Ç¤­¤Þ¤¹¡£
 
 %description -l pl
-Ten modu³ Apache ma s³u¿yæ do zmniejsszania obci±¿enia serwera i ruchu
+Ten modu³ Apache ma s³u¿yæ do zmniejszania obci±¿enia serwera i ruchu
 generowanego przez popularne hosty wirtualne, katalogi, pliki lub
 u¿ytkowników zgodnie z obs³ugiwanymi polisami, które decyduj± kiedy
 opó¼niæ lub odrzuciæ zapytanie. mod_throttle mo¿e tak¿e ¶ledziæ i
@@ -85,44 +87,40 @@ webbserver skickar. Dessa gr
 värdar, kataloger, platser eller autenticerade användare.
 
 %prep
-%setup -q -n mod_throttle-%{version}
+%setup -q -n mod_%{mod_name}-%{version}
 %patch0 -p1
 
 %build
-%{apxs} -DSUEXEC_BIN="\"\\\"%{_sbindir}/suexec\\\"\"" -o mod_throttle.so -c mod_throttle.c
-# to don't bother about ssi counter inside
-mv -f index.shtml index.html
+%{apxs} -o mod_%{mod_name}.so -c mod_%{mod_name}.c
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_libexecdir},%{_htmldocdir}}
+install -d $RPM_BUILD_ROOT%{_pkglibdir}
 
-install mod_throttle.so $RPM_BUILD_ROOT%{_libexecdir}
-install *.html $RPM_BUILD_ROOT%{_htmldocdir}
+install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
 
-gzip -9nf *.txt
+sed -e 's/<!--#/<!--/g' index.shtml > mod_%{mod_name}.html
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
-%{apxs} -e -a -n throttle %{_libexecdir}/mod_throttle.so 1>&2
-if [ -f /var/lock/subsys/httpd ]; then
-       /etc/rc.d/init.d/httpd restart 1>&2
+%{apxs} -e -a -n throttle %{_pkglibdir}/mod_%{mod_name}.so 1>&2
+if [ -f /var/lock/subsys/apache ]; then
+       /etc/rc.d/init.d/apache restart 1>&2
 else
-       echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
+       echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
 %preun
 if [ "$1" = "0" ]; then
-       %{apxs} -e -A -n throttle %{_libexecdir}/mod_throttle.so 1>&2
-       if [ -f /var/lock/subsys/httpd ]; then
-               /etc/rc.d/init.d/httpd restart 1>&2
+       %{apxs} -e -A -n throttle %{_pkglibdir}/mod_%{mod_name}.so 1>&2
+       if [ -f /var/lock/subsys/apache ]; then
+               /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
 %files
 %defattr(644,root,root,755)
-%doc *.gz
-%doc %{_htmldocdir}/index.html
-%attr(755,root,root) %{_libexecdir}/*
+%doc *.txt *.html
+%attr(755,root,root) %{_pkglibdir}/*
This page took 0.048045 seconds and 4 git commands to generate.