]> git.pld-linux.org Git - packages/apache1-mod_throttle.git/blobdiff - apache1-mod_throttle.spec
- obsoletes with constant version
[packages/apache1-mod_throttle.git] / apache1-mod_throttle.spec
index 0e7420387f93a72bf1b4f5753808c280478dffb5..09ae5431d7aef2399428c524898daf2f64367be4 100644 (file)
@@ -1,4 +1,7 @@
-%define        apxs    /usr/sbin/apxs
+%bcond_without ipv6            # disable IPv6 support
+
+%define                mod_name        throttle
+%define        apxs            /usr/sbin/apxs1
 Summary:       Bandwidth & Request Throttling for Apache
 Summary(cs):   Omezení sí»ového provozu pro Apache
 Summary(de):   Ein Modul, das die Bandbreiten- und Anforderungseinschränkung für Apache implementiert
@@ -7,23 +10,28 @@ Summary(fr): Module qui met en oeuvre la bande passante et l'
 Summary(it):   Modulo che implementa la larghezza di banda e la richiesta di throttling per Apache
 Summary(ja):   Apache ÍÑÂÓ°èÉý¤ª¤è¤ÓÍ׵᥹¥í¥Ã¥È¥ë¤ò¼ÂÁõ¤¹¤ë¥â¥¸¥å¡¼¥ë
 Summary(pl):   T³umienie przepustowo¶ci i zapytañ dla Apache'a
-Summary(pt_BR): Descompressão "On-the-fly" de arquivos HTML para o Apache
+Summary(pt_BR):        Descompressão "On-the-fly" de arquivos HTML para o Apache
 Summary(sv):   En modul som implementerar bandvidd- och begäranbegränsningar i Apache
-Name:          apache-mod_throttle
+Name:          apache1-mod_%{mod_name}
 Version:       3.1.2
 Release:       3
-License:       Anthony Howe
+License:       BSD-like
 Group:         Networking/Daemons
 Source0:       http://www.snert.com/Software/mod_throttle/mod_throttle312.tgz
+# Source0-md5: 6edc45c3ea8a0855d4b0b14cf0f76404
+Patch0:                apache1-mod_throttle-PLD-v6stuff.patch
 URL:           http://www.snert.com/Software/mod_throttle/
-BuildRequires: apache-devel
 BuildRequires: %{apxs}
-Prereq:                %{_sbindir}/apxs
-Requires:      apache >= 1.3.1
+#{?with_ipv6:BuildRequires:    apache1(ipv6)-devel}
+BuildRequires: apache1-devel >= 1.3.33-2
+Requires(triggerpostun):       %{apxs}
+Requires:      apache1 >= 1.3.33-2
+Obsoletes:     apache-mod_%{mod_name} <= 3.1.2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define         _libexecdir     %{_libdir}/apache
-%define         _htmldocdir     /home/httpd/manual/mod
+%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
+%define                _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
+%define                _pkglogdir      %(%{apxs} -q PREFIX 2>/dev/null)/logs
 
 %description
 This Apache module is intended to reduce the load on your server &
@@ -47,7 +55,7 @@ authentifizierte Benutzer eingestellt werden.
 %description -l es
 Mod_throttle puede usarse para limitar la cantidad de datos que su
 servidor web va a servir. Estos límites se pueden configurar para
-hosts virtuales individuales, directorios, lug<res o usuarios
+hosts virtuales individuales, directorios, lugares o usuarios
 autenticados.
 
 %description -l fr
@@ -68,7 +76,7 @@ Mod_throttle 
 Ç§¾Ú¥æ¡¼¥¶¡¼ÍѤˤĤ¤¤ÆÀßÄê¤Ç¤­¤Þ¤¹¡£
 
 %description -l pl
-Ten modu³ Apache ma s³u¿yæ do zmniejsszania obci±¿enia serwera i ruchu
+Ten modu³ Apache ma s³u¿yæ do zmniejszania obci±¿enia serwera i ruchu
 generowanego przez popularne hosty wirtualne, katalogi, pliki lub
 u¿ytkowników zgodnie z obs³ugiwanymi polisami, które decyduj± kiedy
 opó¼niæ lub odrzuciæ zapytanie. mod_throttle mo¿e tak¿e ¶ledziæ i
@@ -84,43 +92,51 @@ webbserver skickar. Dessa gr
 värdar, kataloger, platser eller autenticerade användare.
 
 %prep
-%setup -q -n mod_throttle-%{version}
+%setup -q -n mod_%{mod_name}-%{version}
+%{?with_ipv6:%patch0 -p1}
 
 %build
-%{apxs} -DSUEXEC_BIN="\"\\\"%{_sbindir}/suexec\\\"\"" -o mod_throttle.so -c *.c
-# to don't bother about ssi counter inside
-mv -f index.shtml index.html
+%{apxs} -o mod_%{mod_name}.so -c mod_%{mod_name}.c
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_libexecdir},%{_htmldocdir}}
+install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d,%{_pkglogdir}}
+
+install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
+
+echo 'LoadModule %{mod_name}_module    modules/mod_%{mod_name}.so' > \
+       $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
 
-install mod_throttle.so $RPM_BUILD_ROOT%{_libexecdir}
-install *.html $RPM_BUILD_ROOT%{_htmldocdir}
+sed -e 's/<!--#/<!--/g' index.shtml > mod_%{mod_name}.html
 
-gzip -9nf *.txt
+> $RPM_BUILD_ROOT%{_pkglogdir}/mod_throttle.runtime
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
-%{_sbindir}/apxs -e -a -n throttle %{_libexecdir}/mod_throttle.so 1>&2
-if [ -f /var/lock/subsys/httpd ]; then
-       /etc/rc.d/init.d/httpd restart 1>&2
+if [ -f /var/lock/subsys/apache ]; then
+       /etc/rc.d/init.d/apache restart 1>&2
 else
-       echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
+       echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
 fi
 
-%preun
+%postun
 if [ "$1" = "0" ]; then
-       %{_sbindir}/apxs -e -A -n throttle %{_libexecdir}/mod_throttle.so 1>&2
-       if [ -f /var/lock/subsys/httpd ]; then
-               /etc/rc.d/init.d/httpd restart 1>&2
+       if [ -f /var/lock/subsys/apache ]; then
+               /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
+%triggerpostun -- apache1-mod_%{mod_name} < 3.1.2-1.1
+# check that they're not using old apache.conf
+if grep -q '^Include conf\.d' /etc/apache/apache.conf; then
+       %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
+fi
+
 %files
 %defattr(644,root,root,755)
-%doc *.gz
-%doc %{_htmldocdir}/index.html
-%attr(755,root,root) %{_libexecdir}/*
+%doc *.txt *.html
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
+%attr(755,root,root) %{_pkglibdir}/*
+%attr(660,root,http) %ghost %{_pkglogdir}/*
This page took 0.03246 seconds and 4 git commands to generate.