]> git.pld-linux.org Git - packages/apache1-mod_perl.git/blobdiff - apache1-mod_perl.spec
- fixed _noautoreqdep
[packages/apache1-mod_perl.git] / apache1-mod_perl.spec
index d2f5cb786812d2be4a58ec22a3ce4972d8ceb0bc..b8b500a6746fd5b45ca553acd7849de388d0447b 100644 (file)
@@ -1,7 +1,7 @@
 # TODO:
 # - add devel subpackage
 %include       /usr/lib/rpm/macros.perl
-%define        apxs    /usr/sbin/apxs
+%define        apxs    /usr/sbin/apxs1
 Summary:       A Perl interpreter for the Apache Web server
 Summary(cs):   Vestavìný interpret Perlu pro WWW server Apache
 Summary(da):   En indbygget Perl-fortolker for webtjeneren Apache
@@ -12,7 +12,7 @@ Summary(id):  Interpreter Perl untuk web server Apache
 Summary(is):   Perl túlkur fyrir Apache vefþjóninn
 Summary(it):   Interprete Perl integrato per il server Web Apache
 Summary(ja):   Apache Web ¥µ¡¼¥Ð¡¼ÍѤÎÁȹþ¤ß Perl ¥¤¥ó¥¿¡¼¥×¥ê¥¿
-Summary(no):   En Perl-fortolker for webtjeneren Apache
+Summary(nb):   En Perl-fortolker for webtjeneren Apache
 Summary(pl):   Interpreter perla dla serwera WWW Apache
 Summary(pt):   Um interpretador de Perl embebido para o servidor Web Apache
 Summary(ru):   ÷ÓÔÒÏÅÎÎÙÊ ÉÎÔÅÒÐÒÅÔÁÔÏÒ Perl ÄÌÑ WWW-ÓÅÒ×ÅÒÁ Apache
@@ -22,34 +22,41 @@ Summary(sv):        En inbyggd Perl-interpretator f
 Summary(uk):   íÏÄÕÌØ ×ÂÕÄÏ×Õ×ÁÎÎÑ ¦ÎÔÅÒÐÒÅÔÁÔÏÒÁ Perl × ÓÅÒ×ÅÒ Apache
 Summary(zh_CN):        ÓÃÓÚ Apache web ·þÎñ³ÌÐòµÄ Perl ½âÊͳÌÐò¡£
 Name:          apache1-mod_perl
-Version:       1.27
-Release:       3
+Version:       1.29
+Release:       2
 License:       GPL
 Group:         Networking/Daemons
 Source0:       http://perl.apache.org/dist/mod_perl-%{version}.tar.gz
+# Source0-md5: 1491931790509b9af06fc037d02b0e7a
 Patch0:                apache-perl-rh.patch
 # from ftp://ftp.kddlabs.co.jp/Linux/packages/Kondara/pub/Jirai/
 Patch1:                mod_perl-v6.patch
+Patch2:                %{name}-optimize.patch
 URL:           http://perl.apache.org/
-BuildRequires: apache(EAPI)-devel
-BuildRequires: perl >= 5.8.0
+BuildRequires: %{apxs}
+BuildRequires: apache1(EAPI)-devel >= 1.3.29-4
 BuildRequires: perl-B-Graph
 BuildRequires: perl-BSD-Resource
 BuildRequires: perl-Devel-Symdump
 BuildRequires: perl-HTML-Parser
 BuildRequires: perl-MIME-Base64
 BuildRequires: perl-URI
+BuildRequires: perl-devel >= 5.8.0
 BuildRequires: perl-libwww
 BuildRequires: rpm-perlprov >= 4.1-13
-BuildRequires: %{apxs}
-PreReq:                apache(EAPI)
+PreReq:                apache1(EAPI)
 Requires(post,preun):  %{apxs}
+%requires_eq   apache1
+%requires_eq   perl-base
 Provides:      perl(mod_perl_hooks)
 Provides:      mod_perl
 Obsoletes:     mod_perl
 Obsoletes:     mod_perl-common
+Obsoletes:     perl-Apache-Test
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _noautoreqdep   'perl(Apache::.*)' 'perl(mod_perl)'
+
 %description
 Mod_perl incorporates a Perl interpreter into the Apache web server,
 so that the Apache web server can directly execute Perl code. Mod_perl
@@ -184,57 +191,60 @@ Apache web 
 %setup  -q -n mod_perl-%{version}
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
-perl Makefile.PL \
+%{__perl} Makefile.PL \
        USE_APXS=1 \
        WITH_APXS=%{apxs} \
        EVERYTHING=1 \
        PERL_STACKED_HANDLERS=1 \
+       OPTIMIZE="%{rpmcflags}" \
        INSTALLDIRS=vendor
 
-(cd apaci; ln -s ../src/modules .; chmod +x find_source)
-%{__make}
+ln -s ../src/modules apaci/modules
+chmod +x apaci/find_source
 
-cd faq
-%{__make}
+%{__make} \
+       OPTIMIZE="%{rpmcflags}"
+%{__make} -C faq
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_libdir}/apache,/home/httpd/manual/mod}
+install -d $RPM_BUILD_ROOT{%{_libdir}/apache1,/home/apache/manual/mod}
 
-%{__make} pure_install DESTDIR=$RPM_BUILD_ROOT
+%{__make} pure_install \
+       DESTDIR=$RPM_BUILD_ROOT
 
-install apaci/libperl.so $RPM_BUILD_ROOT%{_libdir}/apache
+install apaci/libperl.so $RPM_BUILD_ROOT%{_libdir}/apache1
 install htdocs/manual/mod/mod_perl.html \
-       $RPM_BUILD_ROOT/home/httpd/manual/mod
+       $RPM_BUILD_ROOT/home/apache/manual/mod
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
 %{apxs} -e -a -n perl %{_libexecdir}/libperl.so 1>&2
-if [ -f /var/lock/subsys/httpd ]; then
-       /etc/rc.d/init.d/httpd restart 1>&2
+if [ -f /var/lock/subsys/apache ]; then
+       /etc/rc.d/init.d/apache restart 1>&2
 else
-       echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
+       echo "Run \"/etc/rc.d/init.d/apache start\" to start apache http daemon."
 fi
 
 %preun
 if [ "$1" = "0" ]; then
        %{apxs} -e -A -n perl %{_libexecdir}/libperl.so 1>&2
-       if [ -f /var/lock/subsys/httpd ]; then
-               /etc/rc.d/init.d/httpd restart 1>&2
+       if [ -f /var/lock/subsys/apache ]; then
+               /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
-
 %files
 %defattr(644,root,root,755)
 %doc README INSTALL CREDITS faq/*.html faq/*.txt apache-modlist.html eg
-%doc /home/httpd/manual/mod/*html
+%doc /home/apache/manual/mod/*html
 
-%attr(755,root,root) %{_libdir}/apache/*.so
+%attr(755,root,root) %{_libdir}/apache1/*.so
 
 %{perl_vendorarch}/*.pm
 %{perl_vendorarch}/*.PL
This page took 0.053986 seconds and 4 git commands to generate.