]> git.pld-linux.org Git - packages/apache1-mod_gzip.git/blobdiff - apache1-mod_gzip.spec
- added macros in /etc/logrotate.d
[packages/apache1-mod_gzip.git] / apache1-mod_gzip.spec
index 57218765efd86d6bbdb79a68ba50fa417f76fcd0..3716201116f64e5907e18d88b900b1fc8253fb48 100644 (file)
@@ -1,25 +1,30 @@
 %define                mod_name        gzip
-%define        apxs            /usr/sbin/apxs
+%define        apxs            /usr/sbin/apxs1
 Summary:       Apache module: On-the-fly compression of HTML documents
 Summary(pl):   Modu³ do apache: kompresuje dokumenty HTML w locie
-Name:          apache-mod_%{mod_name}
+Name:          apache1-mod_%{mod_name}
 Version:       1.3.26.1a
 Release:       1
 License:       Apache
 Group:         Networking/Daemons
 Source0:       http://dl.sourceforge.net/mod-gzip/mod_gzip-%{version}.tgz
+# Source0-md5: 080ccc5d789ed5efa0c0a7625e4fa02d
+Source1:       %{name}.logrotate
+Patch0:                %{name}-name_clash.patch
+Patch1:                %{name}-security.patch
 URL:           http://sourceforge.net/projects/mod-gzip/
 BuildRequires: %{apxs}
-BuildRequires: apache(EAPI)-devel
+BuildRequires: apache1-devel
 BuildRequires: zlib-devel
 Requires(post,preun):  %{apxs}
 Requires(post,preun):  grep
 Requires(preun):       fileutils
-Requires:      apache(EAPI)
+Requires:      apache1
+Obsoletes:     apache-mod_%{mod_name} <= %{version}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _pkglibdir      %(%{apxs} -q LIBEXECDIR)
-%define         _sysconfdir     /etc/httpd
+%define                _sysconfdir     %(%{apxs} -q SYSCONFDIR)
 
 %description
 Apache module: On-the-fly compression of HTML documents. Browser will
@@ -31,38 +36,42 @@ spos
 
 %prep
 %setup -q -n mod_%{mod_name}-%{version}
+%patch0 -p1
+%patch1 -p1
 
 %build
 %{apxs} -Wc,-Wall,-pipe -c mod_%{mod_name}.c mod_%{mod_name}_debug.c mod_%{mod_name}_compress.c -o mod_%{mod_name}.so
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
+install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir},/etc/logrotate.d}
 
 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
-install docs/mod_gzip.conf.sample $RPM_BUILD_ROOT%{_sysconfdir}/mod_gzip.conf
+sed -e 's#logs/mod_gzip.log#/var/log/httpd/mod_gzip.log#g' docs/mod_gzip.conf.sample > $RPM_BUILD_ROOT%{_sysconfdir}/mod_gzip.conf
+
+install %{SOURCE1} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
-if [ -f /etc/httpd/httpd.conf ] && ! grep -q "^Include.*mod_gzip.conf" /etc/httpd/httpd.conf; then
-        echo "Include /etc/httpd/mod_gzip.conf" >> /etc/httpd/httpd.conf
+if [ -f /etc/apache/apache.conf ] && ! grep -q "^Include.*mod_%{mod_name}.conf" /etc/apache/apache.conf; then
+        echo "Include /etc/apache/mod_%{mod_name}.conf" >> /etc/apache/apache.conf
 fi
-if [ -f /var/lock/subsys/httpd ]; then
-       /etc/rc.d/init.d/httpd restart 1>&2
+if [ -f /var/lock/subsys/apache ]; then
+       /etc/rc.d/init.d/apache restart 1>&2
 fi
 
 %preun
 if [ "$1" = "0" ]; then
        %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
        umask 027
-       grep -v "^Include.*mod_gzip.conf" /etc/httpd/httpd.conf > \
-                /etc/httpd/httpd.conf.tmp
-        mv -f /etc/httpd/httpd.conf.tmp /etc/httpd/httpd.conf
-       if [ -f /var/lock/subsys/httpd ]; then
-               /etc/rc.d/init.d/httpd restart 1>&2
+       grep -v "^Include.*mod_%{mod_name}.conf" /etc/apache/apache.conf > \
+                /etc/apache/apache.conf.tmp
+        mv -f /etc/apache/apache.conf.tmp /etc/apache/apache.conf
+       if [ -f /var/lock/subsys/apache ]; then
+               /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
@@ -72,3 +81,4 @@ fi
 %lang(de) %doc docs/manual/deutsch
 %attr(755,root,root) %{_pkglibdir}/*
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mod_gzip.conf
+%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/*
This page took 0.063019 seconds and 4 git commands to generate.