]> git.pld-linux.org Git - packages/apache-mod_perl.git/blobdiff - apache-mod_perl.spec
- release 4: added -pm_to_blib.patch and BR: MakeMaker >= 6.22
[packages/apache-mod_perl.git] / apache-mod_perl.spec
index aa81717f42657f0818f1e1ce5d53e9a1caa710b1..4f3d44b447231cddfedb4974141926e5f8a5ecba 100644 (file)
@@ -14,7 +14,7 @@ Summary(is):  Perl t
 Summary(it):   Interprete Perl integrato per il server Web Apache
 Summary(ja):   Apache Web ¥µ¡¼¥Ð¡¼ÍѤÎÁȹþ¤ß Perl ¥¤¥ó¥¿¡¼¥×¥ê¥¿
 Summary(nb):   En Perl-fortolker for webtjeneren Apache
-Summary(pl):   Interpreter perla dla serwera WWW Apache
+Summary(pl):   Interpreter Perla dla serwera WWW Apache
 Summary(pt):   Um interpretador de Perl embebido para o servidor Web Apache
 Summary(ru):   ÷ÓÔÒÏÅÎÎÙÊ ÉÎÔÅÒÐÒÅÔÁÔÏÒ Perl ÄÌÑ WWW-ÓÅÒ×ÅÒÁ Apache
 Summary(sk):   Interpreter jazyka Perl pre webový server Apache
@@ -23,22 +23,25 @@ Summary(sv):        En inbyggd Perl-interpretator f
 Summary(uk):   íÏÄÕÌØ ×ÂÕÄÏ×Õ×ÁÎÎÑ ¦ÎÔÅÒÐÒÅÔÁÔÏÒÁ Perl × ÓÅÒ×ÅÒ Apache
 Summary(zh_CN):        ÓÃÓÚ Apache web ·þÎñ³ÌÐòµÄ Perl ½âÊͳÌÐò¡£
 Name:          apache-mod_perl
-Version:       1.99_13
-Release:       3
+Version:       1.99_17
+Release:       4
 Epoch:         1
 License:       Apache
 Group:         Networking/Daemons
 #Source0:      modperl-%{version}_%{snap}.tar.bz2
 Source0:       http://perl.apache.org/dist/mod_perl-%{version}.tar.gz
-# Source0-md5: e8945611cae2fe797ae4bb198c0285b6
+# Source0-md5: ffb9d5c825b93d91e6c3a8885f7d5296
 Source1:       %{name}.conf
 Patch0:                %{name}-Makefile_PL.patch
+Patch1:                %{name}-pm_to_blib.patch
 URL:           http://perl.apache.org/
 BuildRequires: apache-devel >= 2.0.0
-BuildRequires: apr-util-devel
+BuildRequires: apr-util-devel >= 1:1.0.0
 BuildRequires: expat-devel
 BuildRequires: gdbm-devel
 BuildRequires: openldap-devel
+# forced by pm_to_blib.patch
+BuildRequires: perl-ExtUtils-MakeMaker >= 6.22
 # These modules aren't needed?
 #BuildRequires:        perl-B-Graph
 #BuildRequires:        perl-BSD-Resource
@@ -50,21 +53,23 @@ BuildRequires:      openldap-devel
 #BuildRequires:        perl-libwww
 BuildRequires: rpm-perlprov >= 3.0.3-16
 %requires_eq   apache
+Requires:      perl(DynaLoader) = %(%{__perl} -MDynaLoader -e 'print DynaLoader->VERSION')
 Requires(post,preun):  %{apxs}
 # What's this for?
 Provides:      perl(mod_perl_hooks)
 Provides:      mod_perl
 Provides:      perl-Apache-Test
 # bugs in rpm perl dependency finder?
-Provides:       perl(Apache::FunctionTable)
-Provides:       perl(Apache::StructureTable)
-# to be resolved:
-BuildConflicts:        apache1-mod_perl
+Provides:      perl(Apache::FunctionTable)
+Provides:      perl(Apache::StructureTable)
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Obsoletes:     mod_perl
 Obsoletes:     mod_perl-common
 
-%define                _noautoreqdep   'perl(Apache::.*)' 'perl(mod_perl)'
+# TODO: separate -devel with ExtUtils::Embed and friends?
+%define                _noautoreq      'perl(Apache::.*)' 'perl(mod_perl)' 'perl(ModPerl::.*)' 'perl(ExtUtils::Embed)'
+%define                _sysconfdir     %(%{apxs} -q SYSCONFDIR)
+%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR)
 
 %description
 Mod_perl incorporates a Perl interpreter into the Apache web server,
@@ -141,7 +146,7 @@ CGI 
 
 %description -l pl
 Mod_perl jest modu³em, który wyposa¿a serwer Apache w interpreter
-perla, umo¿liwiaj±c w ten sposób bezpo¶rednie wykonywanie kodu perla
+Perla, umo¿liwiaj±c w ten sposób bezpo¶rednie wykonywanie kodu Perla
 przez serwer bez potrzeby anga¿owania zewnêtrznego interpretera, co
 przyspiesza procesy zwi±zane z uruchamianiem skryptów CGI.
 
@@ -197,28 +202,31 @@ Apache web 
 ½Å±¾»Øת¹ý³Ì¸üΪ¿ìËÙ¡£
 
 %prep
-%setup  -q -n mod_perl-%{version}
-%patch0 -b .orig -p1
+%setup -q -n mod_perl-%{version}
+%patch0 -p1 -b .orig
+%patch1 -p1 -b .orig
 
 %build
 %{__perl} Makefile.PL \
        MP_APXS=%{apxs} \
+       MP_APR_CONFIG=%{_bindir}/apr-1-config \
        INSTALLDIRS=vendor \
-       MP_CCOPTS="%{rpmcflags} -I/usr/include/apache `apu-config --includes`" 
+       MP_CCOPTS="-I/usr/include/apache `apu-1-config --includes`" 
 
 %{__make} \
+       OPTIMIZE="%{rpmcflags}" \
+       MODPERL_OPTIMIZE="%{rpmcflags}" \
        CC="%{__cc}" \
        MP_APXS=%{apxs}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_libdir}/apache,/etc/httpd/httpd.conf}
-install -d $RPM_BUILD_ROOT/etc/httpd/httpd.conf/
+install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 find $RPM_BUILD_ROOT -name \*.orig -exec rm -f '{}' \;
-install %{SOURCE1} $RPM_BUILD_ROOT/etc/httpd/httpd.conf/75_mod_perl.conf
+install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/75_mod_perl.conf
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -227,7 +235,7 @@ rm -rf $RPM_BUILD_ROOT
 if [ -f /var/lock/subsys/httpd ]; then
        /etc/rc.d/init.d/httpd restart 1>&2
 else
-       echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
+       echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache HTTP daemon."
 fi
 
 %preun
@@ -241,8 +249,8 @@ fi
 %files
 %defattr(644,root,root,755)
 %doc Changes INSTALL README STATUS
-%attr(755,root,root) %{_libdir}/apache/*.so
-%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/httpd/httpd.conf/*.conf
+%attr(755,root,root) %{_pkglibdir}/*.so
+%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd.conf/*.conf
 
 %{perl_vendorarch}/*.pm
 %{perl_vendorarch}/APR
@@ -260,7 +268,7 @@ fi
 %attr(755,root,root) %{perl_vendorarch}/auto/*/*/*.so
 
 %{perl_vendorarch}/auto/Apache/typemap
-# to -devel?  directory ownership problem...
+# to -devel? directory ownership problem...
 %{_includedir}/apache/*.h
 
-%{_mandir}/man?/[^B]*
+%{_mandir}/man?/[!B]*
This page took 0.027591 seconds and 4 git commands to generate.