]> git.pld-linux.org Git - packages/apache-mod_pagespeed.git/blobdiff - apache-mod_pagespeed.spec
up to 1.8.31.5
[packages/apache-mod_pagespeed.git] / apache-mod_pagespeed.spec
index d5fb25b65a3af37fa70c2e25c1e539986f3c8ca9..e087ebd9ddd76986c42570241ce7f19a38c6715e 100644 (file)
@@ -3,6 +3,7 @@
 %bcond_without verbose         # verbose build (V=1)
 
 # NOTE
+# - relase notes: https://developers.google.com/speed/pagespeed/module/release_notes
 # - http://code.google.com/p/modpagespeed/wiki/HowToBuild
 # - http://wiki.mediatemple.net/w/(dv)_HOWTO:_Install_mod_pagespeed
 # TODO
 #  "google_sparsehash_root": "http://google-sparsehash.googlecode.com/svn/tags/sparsehash-1.8.1/src",
 #  protobuf_lite
 
-%if "%{pld_release}" == "ac"
-# add suffix, but allow ccache, etc in ~/.rpmmacros
-%{expand:%%define      __cc    %(echo '%__cc' | sed -e 's,-gcc,-gcc4,')}
-%{expand:%%define      __cxx   %(echo '%__cxx' | sed -e 's,-g++,-g++4,')}
-%{expand:%%define      __cpp   %(echo '%__cpp' | sed -e 's,-gcc,-gcc4,')}
-%endif
-
 %define                mod_name        pagespeed
-%define        apxs            %{_sbindir}/apxs
+%define                apxs            %{_sbindir}/apxs
 Summary:       Apache module for rewriting web pages to reduce latency and bandwidth
 Name:          apache-mod_%{mod_name}
-Version:       0.10.22.7
-Release:       2
+# beta: 1.9.32.2-beta
+# stable: 1.8.31.5
+Version:       1.8.31.5
+Release:       0.6
 License:       Apache v2.0
 Group:         Networking/Daemons/HTTP
 Source0:       modpagespeed-%{version}.tar.xz
-# Source0-md5: 1c67625812d18899ce6a47da069c6043
+# Source0-md5: ce0f27b177fba51f6b9f08fed8134709
 Source1:       get-source.sh
+Source2:       gclient.conf
 Patch0:                system-libs.patch
-Patch1:                gcc-headers.patch
-URL:           https://developers.google.com/speed/pagespeed/
+Patch2:                bug-632.patch
+Patch4:                no-dev-stdout.patch
+URL:           https://developers.google.com/speed/pagespeed/module
 BuildRequires: %{apxs}
 BuildRequires: apache-devel >= 2.2
+BuildRequires: bash
 BuildRequires: glib2-devel
 BuildRequires: gperf
-BuildRequires: libjpeg-devel
 BuildRequires: libselinux-devel
 BuildRequires: libstdc++-devel >= 5:4.1
 BuildRequires: opencv-devel >= 2.3.1
@@ -48,16 +46,12 @@ BuildRequires:      python-devel >= 1:2.6
 # This version of gyp is new enough that it knows to use make for Linux 3.x
 # and FreeBSD, but old enough that 'type': 'settings' works and
 # LINKER_SUPPORTS_ICF hasn't been removed yet.
-BuildRequires: python-gyp >= 1-1175
+BuildRequires: python-gyp >= 0.1-0.svn1602.1
 BuildRequires: rpmbuild(macros) >= 1.268
 BuildRequires: tar >= 1:1.22
 BuildRequires: util-linux
 BuildRequires: xz
 BuildRequires: zlib-devel
-# gcc4 might be installed, but not current __cc
-%if "%(echo %{cc_version} | cut -d. -f1,2)" < "4.0"
-BuildRequires: __cc >= 4.0
-%endif
 Requires:      apache(modules-api) = %apache_modules_api
 Requires:      apache-mod_authz_host
 Requires:      apache-mod_headers
@@ -78,16 +72,19 @@ by Page Speed can be used without having to change the way the web
 site is maintained.
 
 %prep
-%setup -q -n modpagespeed
-%patch0 -p1
-%patch1 -p1
+%setup -q -n modpagespeed-%{version}
+%patch0 -p2
+%patch2 -p1
+%patch4 -p1
 
 %build
 # re-gen makefiles
-cd src
 CC="%{__cc}" \
 CXX="%{__cxx}" \
-%{__python} build/gyp_chromium --format=make build/all.gyp \
+%{__python} build/gyp_chromium \
+       --format=make \
+       --depth=. \
+       build/all.gyp \
        -Duse_openssl=1 \
        -Duse_system_apache_dev=1 \
        -Duse_system_libjpeg=1 \
@@ -99,13 +96,7 @@ CXX="%{__cxx}" \
        -Dsystem_include_path_httpd=%{_includedir}/apache \
        %{nil}
 
-cd ..
-
-# makefile wrapper so we could just invoke "make" from shell
-cat > Makefile <<'EOF'
-# target names from build/all.gyp
-default:
-       $(MAKE) -C src mod_pagespeed \
+%{__make} mod_pagespeed js_minify css_minify_main \
        BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
        %{?with_verbose:V=1} \
        CC="%{__cc}" \
@@ -115,29 +106,34 @@ default:
        LINK.host="%{__cxx}" \
        CFLAGS="%{rpmcflags} %{rpmcppflags}" \
        CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
-       $(MAKEFLAGS) \
-EOF
-%{__make}
+       %{nil}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir},%{cachedir}/{cache,files}}
-%{__make} -j1 -C src/install staging_except_module \
-       HOSTNAME=localhost \
+install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir},%{_bindir},%{cachedir}}
+
+%{__make} -j1 -C install staging_except_module \
        APACHE_ROOT=%{_pkgrootdir} \
        APACHE_MODULES=modules \
        APACHE_DOC_ROOT=%{htdocsdir} \
-       MOD_PAGESPEED_FILE_ROOT=%{cachedir} \
+       MOD_PAGESPEED_CACHE=%{cachedir} \
+       MOD_PAGESPEED_STATS_LOG=/var/log/httpd/mod_pagespeed_stats.log \
        STAGING_DIR=staging
 
-install -p src/out/Release/libmod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}/mod_%{mod_name}.so
-cd src/install/staging
+out=out/%{!?debug:Release}%{?debug:Debug}
+install -p $out/libmod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}/mod_%{mod_name}.so
+install -p $out/js_minify $RPM_BUILD_ROOT%{_bindir}/pagespeed_js_minify
+install -p $out/css_minify_main $RPM_BUILD_ROOT%{_bindir}/pagespeed_css_minify
+
+cd install/staging
 cat > $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_%{mod_name}.conf <<EOF
 LoadModule %{mod_name}_module  modules/mod_%{mod_name}.so
 
 $(cat pagespeed.conf)
 EOF
 
+cp -p pagespeed_libraries.conf $RPM_BUILD_ROOT%{_sysconfdir}/91_mod_%{mod_name}_libraries.conf
+
 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 cp -a mod_pagespeed_example/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
@@ -155,9 +151,9 @@ fi
 %files
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}_libraries.conf
+%attr(755,root,root) %{_bindir}/pagespeed_css_minify
+%attr(755,root,root) %{_bindir}/pagespeed_js_minify
 %attr(755,root,root) %{_pkglibdir}/mod_%{mod_name}.so
 %{_examplesdir}/%{name}-%{version}
-
-%dir %attr(710,root,http) %{cachedir}
-%dir %attr(770,root,http) %{cachedir}/cache
-%dir %attr(770,root,http) %{cachedir}/files
+%dir %attr(770,root,http) %{cachedir}
This page took 0.074517 seconds and 4 git commands to generate.