]> git.pld-linux.org Git - packages/ant.git/blobdiff - ant.spec
- updated some jar names in ant config
[packages/ant.git] / ant.spec
index 5c9e1cd8ed3a02534460b3b73263f42dc91526c7..b7d7794b27e5749e9188bb4aa1948b43ec68ae4f 100644 (file)
--- a/ant.spec
+++ b/ant.spec
@@ -1,4 +1,5 @@
 # TODO
+# - review config files in /etc/ant.d. Something seems to be broken there.
 # - prepare all BR and test the full build
 #   TODO:
 #   - stylebook: http://svn.apache.org/viewcvs.cgi/xml/stylebook/
 %bcond_without jsch            # disable building jsch optional task(s)
 %bcond_without junit           # disable building junit optional task(s)
 %bcond_without netrexx         # disable building netrexx optional taks(s)
-#
+
+%if "%{pld_release}" == "ti"
+%bcond_without java_sun        # build with gcj
+%else
+%bcond_with    java_sun        # build with java-sun
+%endif
+
 %if %{without nonfree}
 %undefine      with_jai
 %endif
 %undefine      with_jsch
 %undefine      with_netrexx
 %endif
-#
-%define                _rel    4
+
+%include       /usr/lib/rpm/macros.java
+
+%define                _rel    5
 Summary:       Ant build tool for Java
 Summary(fr.UTF-8):     Outil de compilation pour java
 Summary(it.UTF-8):     Tool per la compilazione di programmi java
@@ -62,30 +71,34 @@ Patch0:             %{name}-antRun.patch
 # next release of ant.
 Patch1:                %{name}-gcjtask.patch
 URL:           http://ant.apache.org/
+%{!?with_bootstrap:BuildRequires:      ant}
 %{?with_antlr:BuildRequires:   antlr}
 %{?with_apache_bsf:BuildRequires:      beanshell}
 %{?with_apache_bsf:BuildRequires:      bsf}
 %{?with_javamail:BuildRequires:        jaf}
 %{?with_jai:BuildRequires:     jai}
 %{?with_apache_bcel:BuildRequires:     jakarta-bcel}
-%{?with_commons_logging:BuildRequires: jakarta-commons-logging}
-%{?with_commons_net:BuildRequires:     jakarta-commons-net}
-%{?with_apache_oro:BuildRequires:      jakarta-oro}
-%{?with_apache_regexp:BuildRequires:   jakarta-regexp}
-BuildRequires: java-gcj-compat-devel
+%{?with_commons_logging:BuildRequires: java-commons-logging}
+%{?with_commons_net:BuildRequires:     java-commons-net}
+%{!?with_java_sun:BuildRequires:       java-gcj-compat-devel}
+%{?with_apache_oro:BuildRequires:      java-oro}
+%{?with_apache_regexp:BuildRequires:   java-regexp}
 %{?with_apache_resolver:BuildRequires: java-xml-commons-resolver}
+%{?with_java_sun:BuildRequires:        java-sun}
+BuildRequires: jpackage-utils
 %{?with_javamail:BuildRequires:        javamail}
 %{?with_jdepend:BuildRequires: jdepend}
 BuildRequires: jpackage-utils
 %{?with_jsch:BuildRequires:    jsch >= 0.1.21}
 %{?with_junit:BuildRequires:   junit}
 %{?with_apache_bsf:BuildRequires:      jython}
-%{?with_apache_log4j:BuildRequires:    logging-log4j >= 1.2}
+%{?with_apache_log4j:BuildRequires:    java-log4j >= 1.2}
 %{?with_netrexx:BuildRequires: netrexx}
+BuildRequires: rpm >= 4.4.9-56
+BuildRequires: rpm-javaprov
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.300
 BuildRequires: xerces-j
-Requires:      jdk
 Requires:      jpackage-utils
 Obsoletes:     jakarta-ant
 BuildArch:     noarch
@@ -175,7 +188,7 @@ Summary(fr.UTF-8):  Taches apache log4j optionelles pour %{name}
 Summary(pl.UTF-8):     Opcjonalne zadania apache log4j dla anta
 Group:         Development/Languages/Java
 Requires:      %{name} = %{version}-%{release}
-Requires:      logging-log4j >= 1.2
+Requires:      java-log4j >= 1.2
 Provides:      ant-jakarta-log4j = %{version}-%{release}
 Obsoletes:     ant-jakarta-log4j
 Conflicts:     ant-optional-clean
@@ -196,7 +209,7 @@ Summary(fr.UTF-8):  Taches apache oro optionelles pour %{name}
 Summary(pl.UTF-8):     Opcjonalne zadania apache oro dla anta
 Group:         Development/Languages/Java
 Requires:      %{name} = %{version}-%{release}
-Requires:      jakarta-oro
+Requires:      java-oro
 Provides:      ant-jakarta-oro = %{version}-%{release}
 Obsoletes:     ant-jakarta-oro
 Conflicts:     ant-optional-clean
@@ -217,7 +230,7 @@ Summary(fr.UTF-8):  Taches apache regexp optionelles pour %{name}
 Summary(pl.UTF-8):     Opcjonalne zadania apache regexp dla anta
 Group:         Development/Languages/Java
 Requires:      %{name} = %{version}-%{release}
-Requires:      jakarta-regexp
+Requires:      java-regexp
 Obsoletes:     ant-jakarta-regexp
 Conflicts:     ant-optional-clean
 Conflicts:     ant-optional-full
@@ -237,7 +250,7 @@ Summary(fr.UTF-8):  Taches apache resolver optionelles pour %{name}
 Summary(pl.UTF-8):     Opcjonalne zadania apache resolver dla anta
 Group:         Development/Languages/Java
 Requires:      %{name} = %{version}-%{release}
-Requires:      xml-commons-resolver
+Requires:      java-xml-commons-resolver
 Provides:      ant-apache-resolver = %{version}-%{release}
 Conflicts:     ant-optional-clean
 Conflicts:     ant-optional-full
@@ -273,7 +286,7 @@ Summary(fr.UTF-8):  Taches commons net optionelles pour %{name}
 Summary(pl.UTF-8):     Opcjonalne zadania commons net dla anta
 Group:         Development/Languages/Java
 Requires:      %{name} = %{version}-%{release}
-Requires:      jakarta-commons-net
+Requires:      java-commons-net
 Conflicts:     ant-optional-clean
 Conflicts:     ant-optional-full
 
@@ -480,10 +493,10 @@ Summary:  Additional scripts for %{name}
 Summary(fr.UTF-8):     Scripts additionels pour %{name}
 Summary(pl.UTF-8):     Dodatkowe skrypty dla anta
 Group:         Development/Languages/Java
-AutoReqProv:   no
 Requires:      %{name} = %{version}-%{release}
 Requires:      /usr/bin/perl
 Requires:      /usr/bin/python
+AutoReqProv:   no
 
 %description scripts
 Additional Perl and Python scripts for %{name}.
@@ -619,17 +632,17 @@ echo "bsf ant/ant-apache-bsf" > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/apache-b
 
 %if %{with apache_resolver}
 install build/lib/%{name}-apache-resolver.jar $RPM_BUILD_ROOT%{_javadir}/%{name}/%{name}-apache-resolver-%{version}.jar
-echo "xml-commons-resolver ant/ant-apache-resolver" > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/apache-resolver
+echo "resolver ant/ant-apache-resolver" > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/apache-resolver
 %endif
 
 %if %{with commons_logging}
 install build/lib/%{name}-commons-logging.jar $RPM_BUILD_ROOT%{_javadir}/%{name}/%{name}-commons-logging-%{version}.jar
-echo "jakarta-commons-logging ant/ant-commons-logging" > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/commons-logging
+echo "commons-logging ant/ant-commons-logging" > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/commons-logging
 %endif
 
 %if %{with commons_net}
 install build/lib/%{name}-commons-net.jar $RPM_BUILD_ROOT%{_javadir}/%{name}/%{name}-commons-net-%{version}.jar
-echo "jakarta-commons-net ant/ant-commons-net" > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/commons-net
+echo "commons-net ant/ant-commons-net" > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.d/commons-net
 %endif
 
 %if %{with jai}
This page took 0.443212 seconds and 4 git commands to generate.