]> git.pld-linux.org Git - packages/WebChess.git/blobdiff - WebChess.spec
- converted to UTF-8
[packages/WebChess.git] / WebChess.spec
index 14b63dd9ec371b0090441a260fb9f0551ce2f7af..7b016788f79ba47f9919e94b0ac832bd9bfd14e3 100644 (file)
@@ -1,20 +1,25 @@
 Summary:       A great persistant online chess game
-Summary(pl):   Wspania³a internetowa gra w szachy
+Summary(pl.UTF-8):   Wspaniała internetowa gra w szachy
 Name:          WebChess
 Version:       0.9.0
-Release:       1
-License:       GNU General Public License (GPL)
-Group:         Webaplications
-######         Unknown group!
-Source0:       http://voxel.dl.sourceforge.net/sourceforge/webchess/%{name}_%{version}.zip
+Release:       2
+License:       GPL
+Group:         Applications/WWW
+Source0:       http://dl.sourceforge.net/webchess/%{name}_%{version}.zip
 # Source0-md5: e1a0dc90959a4e8475854a6e7fb4f0b9
-Requires:      php-mysql
-Requires:      php-pcre
+Source1:       %{name}.conf
+URL:           http://webchess.sourceforge.net/
+BuildRequires: rpmbuild(macros) >= 1.268
+BuildRequires: unzip
+Requires:      php(mysql)
+Requires:      php(pcre)
 Requires:      webserver
+Requires:      webserver(php)
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _webchessdir    /home/services/httpd/html/WebChess
+%define                _webchessdir    %{_datadir}/%{name}
+%define                _sysconfdir     /etc/%{name}
 
 %description
 A great persistant online chess game using PHP/MySQL on the backend
@@ -22,29 +27,61 @@ and HTML/JavaScript on the front-end, which includes move validation,
 CHECK checking, pawn promotion and undo. It also has a login system
 which allows multiple simultaneous games.
 
-%description -l pl
-Wspania³a internetowa gra w szachy, oparta na PHP/MySQL i
-HTML/JavaScript. Posiada wiele ciekawych funkcji oraz system
-logowania, który zapewnia gre zespo³ow±
+%description -l pl.UTF-8
+Wspaniała internetowa gra w szachy, używająca PHP/MySQL po stronie
+backendu i HTML/JavaScript po stronie interfejsu użytkownika. Zawiera
+kontrolę ruchów, sprawdzanie szachu, promocję pionów oraz cofanie. Ma
+także system logowania, który pozwala na wiele jednoczesnych gier.
 
 %prep
-%setup -q -c %{name}-%{version}
+%setup -q -c
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_webchessdir}
+install -d $RPM_BUILD_ROOT%{_webchessdir} \
+       $RPM_BUILD_ROOT{%{_sysconfdir},/etc/httpd}
 
-cp -af images javascript *.php *.css chess.inc   $RPM_BUILD_ROOT%{_webchessdir}
+cp -af images javascript *.php *.css chess.inc $RPM_BUILD_ROOT%{_webchessdir}
+rm -f $RPM_BUILD_ROOT%{_webchessdir}/config.php
+
+install config.php $RPM_BUILD_ROOT%{_sysconfdir}
+ln -sf %{_sysconfdir}/config.php $RPM_BUILD_ROOT%{_webchessdir}/config.php
+
+install %{SOURCE1} $RPM_BUILD_ROOT/etc/httpd/%{name}.conf
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post
+if [ -f /etc/httpd/httpd.conf ] && ! grep -q "^Include.*%{name}.conf" /etc/httpd/httpd.conf; then
+       echo "Include /etc/httpd/%{name}.conf" >> /etc/httpd/httpd.conf
+elif [ -d /etc/httpd/httpd.conf ]; then
+       ln -sf /etc/httpd/%{name}.conf /etc/httpd/httpd.conf/99_%{name}.conf
+fi
+%service -q httpd reload
+
+%preun
+if [ "$1" = "0" ]; then
+       umask 027
+       if [ -d /etc/httpd/httpd.conf ]; then
+               rm -f /etc/httpd/httpd.conf/99_%{name}.conf
+       else
+               grep -v "^Include.*%{name}.conf" /etc/httpd/httpd.conf > \
+                       /etc/httpd/httpd.conf.tmp
+               mv -f /etc/httpd/httpd.conf.tmp /etc/httpd/httpd.conf
+               %service -q httpd reload
+       fi
+fi
+
 %files
 %defattr(644,root,root,755)
+%dir %{_sysconfdir}
+%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
+%config(noreplace) %verify(not md5 mtime size) /etc/httpd/%{name}.conf
 %doc docs/*
 %dir %{_webchessdir}
-%{_webchessdir}/images/
-%{_webchessdir}/javascript/
+%{_webchessdir}/images
+%{_webchessdir}/javascript
 %{_webchessdir}/chess.inc
 %{_webchessdir}/*.php
 %{_webchessdir}/*.css
This page took 0.031627 seconds and 4 git commands to generate.