]> git.pld-linux.org Git - packages/SPE.git/blobdiff - SPE.spec
- up to 0.8.1.d by Robert Tomasik
[packages/SPE.git] / SPE.spec
index 0090094e9568f1b1ae35adb21db1b2a533e4bfe6..075c1c38b868ca476d298f4e43bd427776775d97 100644 (file)
--- a/SPE.spec
+++ b/SPE.spec
@@ -1,24 +1,27 @@
 # TODO:
 # - fix %%files (doc to %%doc, no .py, remove unused files)
-
-%define        _wx     2.5.2.8
-%define        _bl     2.35
-
+%define        _wx     2.6.1.0
+#
 Summary:       SPE - Stani's Python Editor
 Summary(pl):   SPE - pythonowy edytor Staniego
 Name:          SPE
-Version:       0.7.2.a
-Release:       0.1
+Version:       0.8.1.d
+Release:       1
 License:       LGPL 2.1+ (except sm library <free to use> and sm_idle <PSF>)
 Group:         Applications/Text
-Source0:       http://projects.blender.org/frs/download.php/244/%{name}-%{version}-linux-mac.tgz
-# Source0-md5: f3c19dcbab4d1e77b4ef34f7916d8235
+Source0:       http://download.berlios.de/python/%{name}-%{version}-wx%{_wx}.tar.gz
+# Source0-md5: ea3f3bdf50d4dd26d21f9fc6fab70523
+Source1:       %{name}.desktop
+Source2:       %{name}.png
 URL:           http://spe.pycs.net/
-BuildRequires: rpm-pythonprov
-BuildRequires: findutils
+BuildRequires: python
 BuildRequires: python-devel
+BuildRequires: python-modules
+Requires:      pydoc
 %pyrequires_eq python-modules
 Requires:      python-wxPython >= %{_wx}
+# below is needed - SPE doesn't start without "hacked" release of wxPython (reporting version issue)
+Requires:      python-wxPython >= 2.6.1.0-3
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -43,19 +46,24 @@ mo
 rozszerzalne przy pomocy boa.
 
 %prep
-%setup -q -n %{name}-0.7.0.a-wx%{_wx}.-bl%{_bl}
+%setup -q -n %{name}-%{version}-wx%{_wx}
 
 %build
 python setup.py build
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
 
 python setup.py install \
        --optimize=2 \
        --root=$RPM_BUILD_ROOT
 
-find $RPM_BUILD_ROOT -name '*.py' -exec rm "{}" ";"
+install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
+install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
+
+# SPE doesn't work without *.py files so don't remove them
+#%%py_postclean
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -65,3 +73,5 @@ rm -rf $RPM_BUILD_ROOT
 %doc README.txt
 %attr(755,root,root) %{_bindir}/*
 %{py_sitescriptdir}/*
+%{_desktopdir}/*
+%{_pixmapsdir}/*
This page took 0.051989 seconds and 4 git commands to generate.