]> git.pld-linux.org Git - packages/LPRng.git/blobdiff - LPRng.spec
- rediff patches, rel 5
[packages/LPRng.git] / LPRng.spec
index 8b2a926f94789c67e802ba87fb92ee0aeb7ebfe9..5fdd05d0c8022fbaa0e85d58a2c7096dd70c452e 100644 (file)
@@ -1,3 +1,8 @@
+# NOTE: a bit newer fork is hosted at lprng.sourceforge.net (latest release 3.8.C from 2012)
+#
+# Conditional build:
+%bcond_with    kerberos5       # build with kerberos5 support
+#
 Summary:       A next-generation printing system for UNIX
 Summary(pl.UTF-8):     System drukowania nowej generacji
 Summary(pt_BR.UTF-8):  Gerenciador de impressão para UNIX e NT
@@ -5,17 +10,15 @@ Summary(ru.UTF-8):   Спулер печати LPRng
 Summary(uk.UTF-8):     Спулер друку LPRng
 Summary(zh_CN.UTF-8):  LPRng--打印程序
 Name:          LPRng
-Version:       3.8.28
-Release:       3
-License:       GPL or Artistic
+Version:       3.8.35
+Release:       5
+License:       GPL v2 with OpenSSL exception or Artistic
 Group:         Applications/System
-Source0:       ftp://ftp.lprng.com/pub/LPRng/LPRng/%{name}-%{version}.tgz
-# Source0-md5: 1b3a0abd291b260eab6087ac0e61ed84
-Source1:       %{name}.init
-Source2:       %{name}.conf
-Source3:       %{name}.printcap
-Source4:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-pl-man-pages.tar.bz2
-# Source4-md5: 4771b1c3598677a8201a9e203235dff3
+Source0:       http://www.lprng.com/DISTRIB/LPRng/%{name}-%{version}.tgz
+# Source0-md5: aaf76e4a94300352514d23bdfa66f0e7
+Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-pl-man-pages.tar.bz2
+# Source1-md5: 4771b1c3598677a8201a9e203235dff3
+Source2:       %{name}.init
 Patch0:                %{name}-ac_fixes.patch
 Patch1:                %{name}-lpd-perms.patch
 Patch2:                %{name}-ngettext.patch
@@ -24,21 +27,29 @@ Patch4:             %{name}-pl.po.patch
 Patch5:                %{name}-types.patch
 Patch6:                %{name}-shell.patch
 Patch7:                %{name}-as-needed.patch
+Patch8:                %{name}-lpd.conf.patch
+Patch9:                %{name}-format.patch
+Patch10:       %{name}-openssl1.1.patch
 URL:           http://www.lprng.com/
 BuildRequires: autoconf
 BuildRequires: automake
-BuildRequires: gettext-devel
+BuildRequires: gettext-tools
+%{?with_kerberos5:BuildRequires:       heimdal-devel}
 BuildRequires: libtool
+BuildRequires: libwrap-devel
 BuildRequires: openssl-devel >= 0.9.7d
 BuildRequires: rpmbuild(macros) >= 1.315
 Requires(post):        /sbin/ldconfig
 Requires(post,preun):  /sbin/chkconfig
 Requires:      rc-scripts >= 0.2.0
-Obsoletes:     cups
-Obsoletes:     cups-clients
-Obsoletes:     lpr
+Provides:      printingclient
+Provides:      printingdaemon
+Obsoletes:     printingclient
+Obsoletes:     printingdaemon
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                lpfiltersdir    %{_libexecdir}/lpfilters
+
 %description
 The LPRng software is an enhanced, extended, and portable
 implementation of the Berkeley LPR print spooler functionality. While
@@ -165,55 +176,51 @@ Support та аутентикацію PGP. LPRng прийнято за стан
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
+%patch8 -p1
+%patch9 -p1
+%patch10 -p1
 
-rm -rf autom4te.cache
-mv  PrintingCookbook/{HTML,PrintingCookbook}
+%{__mv} PrintingCookbook/{HTML,PrintingCookbook}
+%{__rm} po/stamp-po
 
 %build
-%{__gettextize}
-%{__libtoolize}
-%{__aclocal}
 %{__autoconf}
-cp -f /usr/share/automake/{config.*,missing} .
 # now it wants to use /etc/lpd/lpd.{conf,perms} - stick to old values?
 %configure \
        OPENSSL=/usr/bin/openssl \
-       PSHOWALL="-ax" \
+       PSHOWALL="ax" \
        --disable-setuid \
        --enable-shared \
        --with-userid=lp \
        --with-groupid=lp \
-       --with-filterdir=%{_libdir}/lpfilters \
+       --with-filterdir=%{lpfiltersdir} \
        --with-lockfile=%{_var}/spool/lpd/lpd \
        --with-lpd_conf_path=%{_sysconfdir}/lpd.conf \
        --with-lpd_perms_path=%{_sysconfdir}/lpd.perms \
        --with-done_jobs=0 \
-       --disable-werror
+       --disable-static \
+       --disable-werror \
+       %{?with_kerberos5:--enable-kerberos} \
+       %{!?with_kerberos5:--disable-kerberos} \
+       --enable-tcpwrappers \
+       --enable-ssl
 
 %{__make} -j1
-%{__make} -C man
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_var}/spool/lpd/lp} \
        $RPM_BUILD_ROOT%{_sysconfdir}/lpd/ssl.{ca,crl,server}
 
-%{__make} install \
+%{__make} -j1 install \
        DESTDIR=$RPM_BUILD_ROOT \
        POSTINSTALL="NO"
-%{__make} install -C man \
-       DESTDIR=$RPM_BUILD_ROOT
 
-install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/lpd
-# yes, overwrite distribution lpd.conf
-install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lpd.conf
-echo "default_printer = lp" >> $RPM_BUILD_ROOT%{_sysconfdir}/lpd.conf
-install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/printcap
-install lpd.perms $RPM_BUILD_ROOT%{_sysconfdir}
+install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/lpd
 
-bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
+bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
 
-rm -f $RPM_BUILD_ROOT%{_libdir}/liblpr.{la,a}
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/liblpr.{so,la}
 
 %find_lang %{name}
 
@@ -236,7 +243,8 @@ fi
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc CHANGES CONTRIBUTORS COPYRIGHT README README.SSL* TODO
-%doc DOCS/LPRng-Reference-Multipart PrintingCookbook/PrintingCookbook
+%doc DOCS/LPRng-Reference.{html,pdf} DOCS/*.jpg DOCS/*.png
+%doc PrintingCookbook/PrintingCookbook PrintingCookbook/PDF/*.pdf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lpd.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lpd.perms
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/printcap
@@ -246,12 +254,43 @@ fi
 %attr(750,root,lp) %dir %{_sysconfdir}/lpd/ssl.crl
 %attr(750,root,lp) %dir %{_sysconfdir}/lpd/ssl.server
 %attr(754,root,root) /etc/rc.d/init.d/lpd
-%attr(755,root,root) %{_bindir}/*
-%attr(755,root,root) %{_sbindir}/*
-%attr(755,root,root) %{_libdir}/lib*.so.*.*
-%dir %{_libdir}/lpfilters
-%attr(755,root,root) %{_libdir}/lpfilters/*
+%attr(755,root,root) %{_bindir}/cancel
+%attr(755,root,root) %{_bindir}/lp
+%attr(755,root,root) %{_bindir}/lpq
+%attr(755,root,root) %{_bindir}/lpr
+%attr(755,root,root) %{_bindir}/lprm
+%attr(755,root,root) %{_bindir}/lpstat
+%attr(755,root,root) %{_sbindir}/checkpc
+%attr(755,root,root) %{_sbindir}/lpc
+%attr(755,root,root) %{_sbindir}/lpd
+%attr(755,root,root) %{_sbindir}/lprng_certs
+%attr(755,root,root) %{_sbindir}/lprng_index_certs
+%attr(755,root,root) %{_libdir}/liblpr.so.*.*
+%attr(755,root,root) %ghost %{_libdir}/liblpr.so.0
+%dir %{lpfiltersdir}
+%attr(755,root,root) %{lpfiltersdir}/lpbanner
+%attr(755,root,root) %{lpfiltersdir}/lpf
+%attr(755,root,root) %{lpfiltersdir}/pclbanner
+%attr(755,root,root) %{lpfiltersdir}/psbanner
 %dir %attr(750,root,lp) %{_var}/spool/lpd
 %dir %attr(770,root,lp) %{_var}/spool/lpd/lp
-%{_mandir}/man[158]/*
+%{_mandir}/man1/cancel.1*
+%{_mandir}/man1/lp.1*
+%{_mandir}/man1/lpbanner.1*
+%{_mandir}/man1/lpf.1*
+%{_mandir}/man1/lpq.1*
+%{_mandir}/man1/lpr.1*
+%{_mandir}/man1/lprm.1*
+%{_mandir}/man1/lprng_certs.1*
+%{_mandir}/man1/lprng_index_certs.1*
+%{_mandir}/man1/lpstat.1*
+%{_mandir}/man1/monitor.1*
+%{_mandir}/man1/pclbanner.1*
+%{_mandir}/man1/psbanner.1*
+%{_mandir}/man5/lpd.conf.5*
+%{_mandir}/man5/lpd.perms.5*
+%{_mandir}/man5/printcap.5*
+%{_mandir}/man8/checkpc.8*
+%{_mandir}/man8/lpc.8*
+%{_mandir}/man8/lpd.8*
 %lang(pl) %{_mandir}/pl/man[158]/*
This page took 0.041213 seconds and 4 git commands to generate.