]> git.pld-linux.org Git - packages/CuraEngine.git/blobdiff - CuraEngine.spec
- release 4 (by relup.sh)
[packages/CuraEngine.git] / CuraEngine.spec
index 1bb2237bdc695e79647c65e8fd36818f0868a2db..681b9f4f98acf6ba679e7ed2a8581315f5415f8c 100644 (file)
@@ -3,17 +3,20 @@
 %bcond_with    tests           # build with tests
 
 Summary:       Engine for processing 3D models into G-code instructions for 3D printers
+Summary(pl.UTF-8):     Silnik do przetwarzania modeli 3D na instrukcje G-code dla drukarek 3D
 Name:          CuraEngine
-Version:       2.5.0
-Release:       2
+Version:       3.5.1
+Release:       4
 Epoch:         1
-License:       AGPLv3
+License:       AGPL v3
 Group:         Applications/Engineering
 Source0:       https://github.com/Ultimaker/CuraEngine/archive/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 8d8de8f56fd5831b3b74e8946a26681e
+# Source0-md5: 54800673b165c69dff2978e7b7a58e70
+Source1:       https://raw.githubusercontent.com/nothings/stb/master/stb_image.h
+# Source1-md5: 2a512ad9f82f104b8120e52babd37cc7
 Patch0:                %{name}-rpath.patch
 Patch1:                %{name}-static-libstdcpp.patch
-Patch2:                %{name}-system-libs.patch
+Patch2:                local-stb.patch
 URL:           https://github.com/Ultimaker/CuraEngine
 BuildRequires: cmake
 BuildRequires: libArcus-devel = %{version}
@@ -25,13 +28,22 @@ BuildRequires:      rapidjson-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-%{name} is a C++ console application for 3D printing G-code
+CuraEngine is a C++ console application for 3D printing G-code
 generation. It has been made as a better and faster alternative to the
 old Skeinforge engine.
 
 This is just a console application for G-code generation. For a full
 graphical application look at cura with is the graphical frontend for
-%{name}.
+CuraEngine.
+
+%description -l pl.UTF-8
+CuraEngine to aplikacja konsolowa C++ do generowania intrukcji G-code
+dla drukarek 3D. Powstała jako lepsza i szybsza alternatywa dla
+starego silnika Skeinforge.
+
+To jest tylko aplikacja konsolowa do generowania kodu. Pełna graficzna
+aplikacja, będąca graficznym interfejsem do CuraEngine, znajduje się w
+pakiecie cura.
 
 %prep
 %setup -q
@@ -39,17 +51,22 @@ graphical application look at cura with is the graphical frontend for
 %patch1 -p1
 %patch2 -p1
 
+mkdir stb
+install %{SOURCE1} stb/
+
 # bundled libraries
-rm -rf libs
-sed -i 's|#include <clipper/clipper.hpp>|#include <polyclipping/clipper.hpp>|' src/utils/*.h src/*.cpp
+%{__rm} -rf libs
+%{__sed} -i 's|#include <clipper/clipper.hpp>|#include <polyclipping/clipper.hpp>|' src/utils/*.h src/*.cpp
 
 # The -DCURA_ENGINE_VERSION does not work, so we sed-change the default value
-sed -i 's/"DEV"/"%{version}"/' src/settings/settings.h
+%{__sed} -i 's/"DEV"/"%{version}"/' src/settings/settings.h
 
 %build
 mkdir build
 cd build
-%{cmake} .. \
+%cmake .. \
+       -DStb_INCLUDE_DIRS:STRING="$(pwd)/.." \
+       -DUSE_SYSTEM_LIBS:BOOL=ON \
        -DBUILD_SHARED_LIBS:BOOL=OFF \
        -DCURA_ENGINE_VERSION:STRING=%{version}
 
This page took 0.089378 seconds and 4 git commands to generate.