]> git.pld-linux.org Git - packages/Atari800.git/blobdiff - Atari800.spec
- more specific BR: svgalib4ggi on ppc
[packages/Atari800.git] / Atari800.spec
index 870f485bfcec7f8a9562e931307e7e7914f38950..5e2d6b3ff926bf03a18d0949748a1e1e0f2f4a96 100644 (file)
@@ -1,17 +1,20 @@
 #
 # Conditional build:
-# _with_license_agreement      - with unzipped ROM files instead of xf25.zip
-# _without_svga                        - without SVGA version
+%bcond_with    license_agreement       # with unzipped ROM files instead of xf25.zip
+%bcond_without svga                    # without SVGA version
 #
+%ifnarch %{ix86} alpha ppc
+%undefine      with_svga
+%endif
 Summary:       Atari 800 Emulator
 Summary(pl):   Emulator Atari 800
 Name:          Atari800
-Version:       1.3.0
-Release:       1
+Version:       1.3.1
+Release:       3
 License:       GPL (Atari800), distributable if unmodified (xf25 with ROMs)
 Group:         Applications/Emulators
 Source0:       http://dl.sourceforge.net/atari800/atari800-%{version}.tar.gz
-# Source0-md5: 2998586f3c69f8a7e50439722e30ffc6
+# Source0-md5: 02c824a4648732a3646d377ee02efd7d
 # NOTE: ROMs probably can be redistributed only in original XF25 archive
 Source1:       http://joy.sophics.cz/www/xf25.zip
 # Source1-md5: 4dc3b6b4313e9596c4d474785a37b94d
@@ -19,13 +22,21 @@ Source2:    %{name}-chooser
 URL:           http://atari800.atari.org/
 BuildRequires: SDL-devel
 BuildRequires: XFree86-devel
-%ifarch %{ix86} alpha ppc
-%{!?_without_svga:BuildRequires:       svgalib-devel}
+%if %{with svga}
+%ifarch ppc
+BuildRequires: svgalib4ggi-devel
+%else
+BuildRequires: svgalib-devel
+%endif
 %endif
+%if %{with license_agreement}
 BuildRequires: unzip
+%endif
 BuildRequires: zlib-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                specflags       -fomit-frame-pointer
+
 %description
 This is Atari 800, 800XL, 130XE and 5200 emulator.
 
@@ -37,28 +48,31 @@ Summary:    Atari 800 Emulator - common files for svgalib and X11 versions
 Summary(pl):   Emulator Atari 800 - pliki wspólne dla wersji svgalib oraz X11
 Group:         Applications/Emulators
 Obsoletes:     Atari800
-%{!?_with_license_agreement:Prereq:    unzip}
+%if %{without license_agreement}
+Requires(post):        unzip
+%endif
 
 %description common
 This is Atari 800, 800XL, 130XE and 5200 emulator.
 
 This package contains common files for both svgalib and X11 versions
 of Atari800.
-
-%{!?_with_license_agreement:Note: because of license problems we had to include whole X-Former}
-%{!?_with_license_agreement:archive (xf25.zip). If you don't want it - rebuild Atari800 by:}
-%{!?_with_license_agreement:rpm --rebuild --with license_agreement ftp://ftp.pld-linux.org/PLD-1.0/SRPMS/SRPMS/%{name}-%{version}-%{release}.src.rpm}
+%if %{without license_agreement}
+Note: because of license problems we had to include whole X-Former
+archive (xf25.zip). If you don't want it - rebuild Atari800 (--with
+license_agreement)
+%endif 
 
 %description common -l pl
 To jest emulator Atari 800, 800XL, 130XE i 5200.
 
 Ten pakiet zawiera pliki wspólne dla wersji dzia³aj±cych pod svgalib
 oraz X11.
-
-%{!?_with_license_agreement:Uwaga: z powodu problemów z licencj± musieli¶my za³±czyæ ca³± paczkê}
-%{!?_with_license_agreement:z emulatorem X-Former (xf25.zip). Je¶li jej nie chcesz w pakiecie -}
-%{!?_with_license_agreement:przebuduj pakiet poleceniem:}
-%{!?_with_license_agreement:rpm --rebuild --with license_agreement ftp://ftp.pld-linux.org/PLD-1.0/SRPMS/SRPMS/%{name}-%{version}-%{release}.src.rpm}
+%if %{without license_agreement}
+Uwaga: z powodu problemów z licencj± musieli¶my za³±czyæ ca³± paczkê
+z emulatorem X-Former (xf25.zip). Je¶li jej nie chcesz w pakiecie -
+przebuduj pakiet z opcja --with license_agreement.
+%endif
 
 %package svga
 Summary:       Atari 800 Emulator - svgalib version
@@ -123,11 +137,11 @@ obs
 %build
 cd src
 
-CFLAGS="%{rpmcflags} %{!?debug:-fomit-frame-pointer}"
-%if %{?_without_svga:0}%{!?_without_svga:1}
-%ifarch %{ix86} alpha ppc
+CFLAGS="%{rpmcflags}"
 
-%configure --target=svgalib \
+%if %{with svga}
+%configure \
+       --target=svgalib \
        --disable-VERY_SLOW \
        --enable-NO_CYCLE_EXACT \
        --enable-CRASH_MENU \
@@ -157,9 +171,9 @@ mv -f atari800 atari800-svga
 
 %{__make} clean
 %endif
-%endif
 
-%configure2_13 --target=sdl \
+%configure \
+       --target=sdl \
        --disable-VERY_SLOW \
        --enable-NO_CYCLE_EXACT \
        --enable-CRASH_MENU \
@@ -186,7 +200,8 @@ mv -f atari800 atari800-SDL
 
 %{__make} clean
 
-%configure2_13 --target=x11-shm \
+%configure \
+       --target=shm \
        --disable-VERY_SLOW \
        --enable-NO_CYCLE_EXACT \
        --enable-CRASH_MENU \
@@ -212,15 +227,15 @@ mv -f atari800 atari800-x11
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/atari800,%{_mandir}/man1}
 
-%ifarch %{ix86} alpha ppc
-%{!?_without_svga:install src/atari800-svga $RPM_BUILD_ROOT%{_bindir}}
+%if %{with svga}
+install src/atari800-svga $RPM_BUILD_ROOT%{_bindir}
 %endif
 install src/atari800-x11 $RPM_BUILD_ROOT%{_bindir}
 install src/atari800-SDL $RPM_BUILD_ROOT%{_bindir}
 install %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/atari800
 install src/atari800.man $RPM_BUILD_ROOT%{_mandir}/man1/atari800.1
 
-%if %{?_with_license_agreement:1}%{!?_with_license_agreement:0}
+%if %{with license_agreement}
 unzip -q -L %{SOURCE1} -d $RPM_BUILD_ROOT%{_datadir}/atari800
 rm -f $RPM_BUILD_ROOT%{_datadir}/atari800/xf25.*
 %else
@@ -230,7 +245,7 @@ install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/atari800
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%if %{?_with_license_agreement:0}%{!?_with_license_agreement:1}
+%if %{without license_agreement}
 %post common
 cd %{_datadir}/atari800
 unzip -q -L xf25.zip
@@ -252,10 +267,8 @@ unzip -q -L xf25.zip
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/atari800-SDL
 
-%ifarch %{ix86} alpha ppc
-%if %{?_without_svga:0}%{!?_without_svga:1}
+%if %{with svga}
 %files svga
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/atari800-svga
 %endif
-%endif
This page took 0.110897 seconds and 4 git commands to generate.