]> git.pld-linux.org Git - packages/bcc.git/blob - bcc.spec
- rel 5; fortify and make fixes from gentoo
[packages/bcc.git] / bcc.spec
1 Summary:        Bruce's C compiler
2 Summary(pl.UTF-8):      Kompilator C Bruce'a
3 Name:           bcc
4 Version:        0.16.17
5 Release:        5
6 License:        GPL
7 Group:          Development/Languages
8 #Source0Download: http://www.cix.co.uk/~mayday/
9 Source0:        http://www.cix.co.uk/~mayday/dev86/Dev86src-%{version}.tar.gz
10 # Source0-md5:  e7bbfdbe61c2fb964994a087e29b0087
11 Patch0:         Dev86src-noroot.patch
12 Patch1:         Dev86src-opt.patch
13 Patch2:         dev86-0.16.17-fortify.patch
14 Patch3:         dev86-pic.patch
15 Patch4:         dev86-0.16.17-make382.patch
16 URL:            http://homepage.ntlworld.com/robert.debath/
17 Requires:       bin86
18 ExclusiveArch:  %{ix86}
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 # don't try to strip Linux-8086 objects
22 # TODO: use _noautostrip
23 %define         no_install_post_strip   1
24
25 %description
26 Bcc is a simple C compiler that produces 8086 assembler, in addition
27 compiler compile time options allow 80386 or 6809 versions. The
28 compiler understands traditional K&R C with just the restriction that
29 bit fields are mapped to one of the other integer types.
30
31 %description -l pl.UTF-8
32 Bcc jest prostym kompilatorem C tworzącym pliki asemblerowe 8086,
33 a dodatkowo pozwala na wybranie wersji 80386 lub 6809. Kompilator
34 rozumie tradycyjne C K&R z takim ograniczeniem, że pola bitowe
35 są odwzorowywane do jednego z innych typów całkowitych.
36
37 %prep
38 %setup -q -n dev86-%{version}
39 %patch0 -p1
40 %patch1 -p1
41 %patch2 -p1
42 %patch3 -p0
43 %patch4 -p0
44
45 mv -f bootblocks/README README.bootblocks
46 mv -f copt/README README.copt
47 mv -f dis88/README README.dis88
48 mv -f elksemu/README README.elksemu
49 mv -f unproto/README README.unproto
50
51 %build
52 CC="%{__cc}" \
53 %{__make} -j1 all other \
54         OPT="%{rpmcppflags} %{rpmcflags}" <<!FooBar!
55 5
56 quit
57 !FooBar!
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} -j1 install-all \
63         DIST=$RPM_BUILD_ROOT
64
65 # FFU (dis88/Makefile is not ready)
66 #       MANDIR=%{_mandir}
67
68 cp -R libc/kinclude $RPM_BUILD_ROOT%{_libdir}/bcc
69
70 ln -sf objdump86 $RPM_BUILD_ROOT%{_bindir}/nm86
71 ln -sf objdump86 $RPM_BUILD_ROOT%{_bindir}/size86
72
73 # these are separated in bin86 package
74 rm -f $RPM_BUILD_ROOT%{_bindir}/{as86,ld86}
75 rm -f $RPM_BUILD_ROOT/usr/man/man1/{as,ld}86.1*
76 # move man pages where they belong
77 install -d $RPM_BUILD_ROOT%{_mandir}
78 mv -f $RPM_BUILD_ROOT/usr/man/* $RPM_BUILD_ROOT%{_mandir}
79
80 %{!?debug:strip -R .comment -R .note $RPM_BUILD_ROOT%{_bindir}/{ar86,bcc,elksemu,objdump86}}
81 %{!?debug:strip -R .comment -R .note $RPM_BUILD_ROOT%{_libdir}/bcc/{bcc*,copt,unproto}}
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %doc Changes Contributors README*
89 %attr(755,root,root) %{_bindir}/ar86
90 %attr(755,root,root) %{_bindir}/bcc
91 %attr(755,root,root) %{_bindir}/dis86
92 %attr(755,root,root) %{_bindir}/elksemu
93 %attr(755,root,root) %{_bindir}/makeboot
94 %attr(755,root,root) %{_bindir}/nm86
95 %attr(755,root,root) %{_bindir}/objdump86
96 %attr(755,root,root) %{_bindir}/size86
97 %dir %{_libdir}/bcc
98 %attr(755,root,root) %{_libdir}/bcc/as86_encap
99 %attr(755,root,root) %{_libdir}/bcc/bcc-cc1
100 %attr(755,root,root) %{_libdir}/bcc/bcc-cpp
101 %attr(755,root,root) %{_libdir}/bcc/copt
102 %attr(755,root,root) %{_libdir}/bcc/unproto
103 %{_libdir}/bcc/i386
104 %{_libdir}/bcc/include
105 %{_libdir}/bcc/kinclude
106 %{_libdir}/bcc/crt*.o
107 %{_libdir}/bcc/lib*.a
108 %{_libdir}/bcc/rules.*
109 %{_mandir}/man1/*
This page took 0.045956 seconds and 3 git commands to generate.