]> git.pld-linux.org Git - packages/balsa.git/blob - balsa.spec
- added BR: sqlite3-devel
[packages/balsa.git] / balsa.spec
1 # TODO:
2 #       - lots files listed twice
3 #       - not packaged /usr/share/locale/ar/LC_MESSAGES/balsa.mo
4 #       - problems with id locale
5 #
6 # Conditional build:
7 %bcond_without  ldap            # build without LDAP support
8 %bcond_with     gpgme           # build with GPG support (experimental)
9 %bcond_without  esmtp           # build without ESMTP support
10 %bcond_without  gtkhtml         # build without HTML support
11 %bcond_with     compface        # build with Compface
12 %bcond_with     gtksourceview   # build with GtkSourceView
13 %bcond_with     gtkspell        # build with GtkSpell
14 %bcond_with     sqlite          # build with SQLite for GPE address books
15 #
16 Summary:        Balsa Mail Client
17 Summary(es.UTF-8):      Balsa es un lector de e-mail
18 Summary(pl.UTF-8):      Balsa - klient poczty
19 Summary(pt_BR.UTF-8):   Balsa é um leitor de e-mail
20 Name:           balsa
21 Version:        2.3.14
22 Release:        0.1
23 License:        GPL
24 Group:          X11/Applications
25 Source0:        http://balsa.gnome.org/%{name}-%{version}.tar.bz2
26 # Source0-md5:  6a86f8bebc21bd279b9fd4d2a21a36c0
27 Patch0:         %{name}-desktop.patch
28 Patch1:         %{name}-includes.patch
29 Patch2:         %{name}-without_id_lang.patch
30 URL:            http://balsa.gnome.org/
31 BuildRequires:  ORBit2-devel >= 1:2.12.4
32 BuildRequires:  aspell-devel >= 2:0.50
33 BuildRequires:  autoconf >= 2.52
34 BuildRequires:  automake
35 %{?with_compface:BuildRequires: compface-devel}
36 BuildRequires:  heimdal-devel
37 %{?with_esmtp:BuildRequires:    libesmtp-devel >= 1.0.4}
38 BuildRequires:  libgnomeprintui-devel >= 1.106.0
39 BuildRequires:  glib2-devel >= 2.6.4-1
40 BuildRequires:  gmime-devel >= 2.1.9
41 %{?with_gpgme:BuildRequires:    gpgme-devel >= 1:0.9.0}
42 BuildRequires:  gtk+2-devel >= 2:2.2.0
43 %{?with_gtksourceview:BuildRequires:    gtksourceview-devel}
44 %{?with_gtkspell:BuildRequires: gtkspell-devel}
45 BuildRequires:  intltool
46 %{?with_gtkhtml:BuildRequires:  libgtkhtml-devel >= 2.0}
47 BuildRequires:  libltdl-devel
48 BuildRequires:  libgnomeprintui-devel >= 2.1.4
49 BuildRequires:  libgnomeui-devel >= 2.3.3.1-2
50 BuildRequires:  libtool
51 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
52 BuildRequires:  openssl-devel >= 0.9.7d
53 BuildRequires:  pcre-devel >= 3.0
54 BuildRequires:  rpmbuild(macros) >= 1.197
55 BuildRequires:  scrollkeeper >= 0.1.4
56 # actually, it requires sqlite >= 2.8
57 %{?with_sqlite:BuildRequires:   sqlite3-devel}
58 %{?with_gpgme:Requires: gpgme >= 1:0.9.0}
59 Requires(post,postun):  scrollkeeper
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 %description
63 Balsa is an e-mail reader.  This client is part of the GNOME
64 desktop environment.  It supports local mailboxes, POP3 and
65 IMAP.
66
67 %description -l es.UTF-8
68 Balsa es un lector de e-mail. Es parte del entorno GNOME. Soporta
69 cajas de correo electrónico locales, POP3 y IMAP.
70
71 %description -l pl.UTF-8
72 Balsa to klient e-mail. Jest częścią środowiska GNOME. Obsługuje POP3,
73 IMAP oraz lokalne skrzynki pocztowe. 
74
75 %description -l pt_BR.UTF-8
76 Balsa é um leitor de e-mail, parte do ambiente de desktop GNOME.
77 Suporta caixas de correio locais, POP3 a IMAP.
78
79 %prep
80 %setup -q
81 %patch0 -p1
82 %patch1 -p1
83 %patch2 -p1
84
85 %build
86 %{__intltoolize}
87 %{__glib_gettextize}
88 %{__libtoolize}
89 %{__aclocal}
90 %{__autoconf}
91 %{__autoheader}
92 %{__autoconf}
93 %configure \
94         --with-gss \
95         --with-ssl \
96         %{!?with_esmtp:--without-esmtp} \
97         %{!?with_gtkhtml:--disable-gtkhtml}\
98         %{?with_gpgme:--with-gpgme} \
99         %{?with_compface:--with-compface} \
100         %{?with_gtksourceview:--with-gtksourceview} \
101         %{?with_gtkspell:--with-gtkspell} \
102         %{?with_sqlite:--with-sqlite} \
103         %{?with_ldap:--with-ldap}
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 %find_lang %{name} --with-gnome --all-name
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %post
118 %scrollkeeper_update_post
119
120 %postun
121 %scrollkeeper_update_postun
122
123 %files -f %{name}.lang
124 %defattr(644,root,root,755)
125 %doc AUTHORS ChangeLog NEWS README TODO
126 %attr(755,root,root) %{_bindir}/*
127 %{_sysconfdir}/sound/events/*
128 %{_datadir}/%{name}
129 %{_datadir}/sounds/%{name}
130 %{_libdir}/bonobo/servers/*.server
131 %{_datadir}/idl/*.idl
132 %{_mandir}/man1/*
133 %{_omf_dest_dir}/%{name}
134 %{_desktopdir}/*.desktop
135 %{_pixmapsdir}/*
136 %{_iconsdir}/hicolor/48x48/mimetypes/*.png
This page took 0.213525 seconds and 4 git commands to generate.