]> git.pld-linux.org Git - packages/automoc4.git/blob - automoc4.spec
0e929ecb1ea3f2b9c2b03d2e401eccb37c311625
[packages/automoc4.git] / automoc4.spec
1
2 %define         qtver   4.4.1
3
4 Summary:        Automoc4 - automatically adding Qt moc files rules for CMake
5 Summary(pl.UTF-8):      Automoc4 - automatyczne dodawanie reguł dla plików Qt moc do CMake
6 Name:           automoc4
7 Version:        0.9.88
8 Release:        2
9 License:        BSD
10 Group:          Development/Tools
11 Source0:        ftp://ftp.kde.org/pub/kde/stable/automoc4/%{version}/%{name}-%{version}.tar.bz2
12 # Source0-md5:  91bf517cb940109180ecd07bc90c69ec
13 URL:            http://techbase.kde.org/Development/Tools/Automoc4
14 BuildRequires:  QtCore-devel >= %{qtver}
15 BuildRequires:  cmake >= 2.6.1-2
16 BuildRequires:  qt4-build >= %{qtver}
17 BuildRequires:  qt4-qmake >= %{qtver}
18 BuildRequires:  rpmbuild(macros) >= 1.293
19 Obsoletes:      kde4-automoc
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 automoc4 is a tool to add rules for generating Qt moc files
24 automatically to projects that use CMake as the buildsystem.
25
26 %description -l pl.UTF-8
27 automoc4 to narzędzie dodające automatycznie reguły do tworzenia
28 plików Qt moc do projektów wykorzystujących CMake jako swojego
29 systemu budowania.
30
31 %prep
32 %setup -q
33
34 %build
35 install -d build
36 cd build
37 %cmake .. \
38         -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
39         -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG" \
40         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
41         -DCMAKE_VERBOSE_MAKEFILE=ON \
42 %if "%{_lib}" != "lib"
43         -DLIB_SUFFIX=64 \
44 %endif
45         -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4
46
47 %{__make}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} -C build install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %post   -p /sbin/ldconfig
59 %postun -p /sbin/ldconfig
60
61 %files
62 %defattr(644,root,root,755)
63 %attr(755,root,root) %{_bindir}/automoc4
64 %dir %{_libdir}/automoc4
65 %{_libdir}/automoc4/Automoc4*.cmake
66 %{_libdir}/automoc4/automoc4.files.in
This page took 0.055909 seconds and 2 git commands to generate.