]> git.pld-linux.org Git - packages/autoconf.git/blob - autoconf.spec
- s-/usr/share-%{_datadir}-
[packages/autoconf.git] / autoconf.spec
1 Summary:        GNU autoconf - source configuration tools
2 Summary(pl):    GNU autoconf - narzêdzie do automatycznego konfigurowania ¼róde³
3 Name:           autoconf
4 Version:        2.13
5 Release:        8
6 Copyright:      GPL
7 Group:          Development/Building
8 Group(pl):      Programowanie/Budowanie
9 Source:         ftp://prep.ai.mit.edu/pub/gnu/%{name}-%{version}.tar.gz
10 Patch0:         autoconf-tmprace.patch
11 Patch1:         autoconf-info.patch
12 Patch2:         autoconf-mawk.patch
13 Patch3:         autoconf-man.patch
14 Patch4:         autoconf-notmp.patch
15 Patch5:         autoconf-pinard.patch
16 Patch6:         autoconf-fhs.patch
17 Requires:       gawk
18 Requires:       m4
19 Requires:       mktemp
20 Prereq:         /sbin/install-info
21 BuildRoot:      /tmp/%{name}-%{version}-root
22 Buildarch:      noarch
23
24 %description
25 GNU's "autoconf" is a tool for source and Makefile configuration. It
26 assists the programmer in creating portable and configurable packages, by
27 allowing the person building the package to specify various configuration
28 options. 
29
30 "autoconf" is not required for the end user - it is needed only to
31 generate the configuration scripts. 
32
33 %description -l pl
34 GNU autoconf jest narzêdziem wykorzystywanym do automatycznego
35 konfigurowania kodów ¼ród³owych pakietów programów oraz do generowania na
36 podstawie automatycznie rozoznanego ¶rodowiska plików Makefile i innch
37 zale¿nych od zawarto¶ci systemu w którym ma przebiegaæ proces kompilacji.
38 Pomaga programi¶cie w konfigurowaniu i tworzeniu opragramowania daj±cego siê
39 przenie¶æ na ró¿ne platformy. Umo¿liwia wybór wielu opcji podczas procesu
40 przygotowania do kompilacji.
41
42 GNU autoconf nie jest generalnie potrzebny dla u¿ytkownika koñcowego, a
43 tylko podczas generowania samych skryptów autokonfiguracyjnych.
44  
45 %prep
46 %setup -q
47 %patch0 -p1
48 %patch1 -p1
49 %patch2 -p1
50 %patch3 -p1
51 %patch4 -p1
52 %patch5 -p1
53 %patch6 -p1
54
55 %build
56 ./configure \
57         --prefix=/usr \
58         --infodir=%{_infodir} \
59         --mandir=%{_mandir}
60 make datadir=%{_libdir}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 install -d $RPM_BUILD_ROOT%{_datadir}/{info,man/man1}
65
66 make install \
67         prefix=$RPM_BUILD_ROOT/usr \
68         datadir=$RPM_BUILD_ROOT%{_libdir} \
69         infodir=$RPM_BUILD_ROOT%{_infodir} \
70         mandir=$RPM_BUILD_ROOT%{_mandir} \
71 install install-sh $RPM_BUILD_ROOT%{_libdir}/autoconf
72
73 install {autoconf,autoheader,autoreconf,autoscan,autoupdate,ifnames}.1 \
74         $RPM_BUILD_ROOT%{_mandir}/man1
75
76 gzip -9nf $RPM_BUILD_ROOT%{_infodir}/autoconf.info* \
77         $RPM_BUILD_ROOT%{_mandir}/man1/*
78
79 %post
80 /sbin/install-info %{_infodir}/autoconf.info.gz /etc/info-dir
81
82 %preun
83 if [ "$1" = "0" ]; then
84         /sbin/install-info --del %{_infodir}/autoconf.info.gz /etc/info-dir
85 fi
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %files
91 %defattr(644,root,root,755)
92 %attr(755,root,root) /usr/bin/*
93
94 %{_infodir}/autoconf.info*
95 %{_mandir}/man1/*
96
97 %{_libdir}/autoconf
98
99 %changelog
100 * Fri Apr 30 1999 Artur Frysiak <wiget@pld.org.pl>
101   [2.13-7]
102 - added autoconf-pinard.patch from grep 2.3 
103   (fixed lookup for opendir and gethostbyname)  
104   
105 * Tue Apr 27 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
106   [2.13-6]
107 - added patch with complet set autoconf man pages (from Debian),
108 - added patch for looking for gawk before mawk in ./configure
109   (autoconf-mawk.patch from rawhide),
110 - added patch wich adds removing temporary files used by auconf
111   scripts (autoconf-notmp.patch from rawhide),
112 - recompiled on new rpm.
113
114 * Wed Jan 26 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
115   [2.13-1d]
116 - added Group(pl).
117
118 * Wed Dec 29 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
119   [2.12-7]
120 - standarized {un}registering info pages 
121   (added autoconf-info.patch).
122
123 * Mon Sep 21 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
124   [2.12-5]
125 - added -q %setup parameter,
126 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
127 - added using %%{name} and %%{version} in Source,
128 - modified pl translation,
129 - added full %attr description in %files.
130
131 * Thu Aug 27 1998 Cristian Gafton <gafton@redhat.com>
132 - patch for fixing /tmp race conditions
133
134 * Fri Jun 12 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
135   [2.12-5]
136 - added pl transaltion,
137 - added %defattr support.
138
139 * Sun Oct 19 1997 Erik Troan <ewt@redhat.com>
140 - spec file cleanups
141 - made a noarch package
142 - uses autoconf
143 - uses install-info
144
145 * Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
146 - built with glibc
This page took 0.316692 seconds and 4 git commands to generate.