]> git.pld-linux.org Git - packages/atl2.git/blob - atl2.spec
- cleanup, working URL
[packages/atl2.git] / atl2.spec
1 #
2 # Conditional build:
3 %bcond_without  dist_kernel     # allow non-distribution kernel
4 %bcond_with     verbose         # verbose build (V=1)
5 #
6 %define         _rel    1
7 Summary:        Attansic(R) L2 Fast Ethernet Adapter driver for Linux
8 Summary(pl.UTF-8):      Sterownik do kart Attansic(R) L2 Fast Ethernet Adapter
9 Name:           kernel%{_alt_kernel}-net-atl2
10 Version:        1.4.0.20
11 Release:        %{_rel}@%{_kernel_ver_str}
12 License:        GPL v2
13 Group:          Base/Kernel
14 Source0:        http://starowa.one.pl/~uzi/pld/atl2-%{version}.tar.gz
15 # Source0-md5:  196771fa8e7164d4c9beabcfdf4058b5
16 URL:            http://www.attansic.com/
17 %{?with_dist_kernel:BuildRequires:      kernel%{_alt_kernel}-module-build >= 3:2.6.20.2}
18 BuildRequires:  rpmbuild(macros) >= 1.379
19 Requires(post,postun):  /sbin/depmod
20 %if %{with dist_kernel}
21 %requires_releq_kernel
22 Requires(postun):       %releq_kernel
23 %endif
24 Provides:       kernel(atl2)
25 Obsoletes:      atl2
26 Obsoletes:      linux-net-atl2
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This package contains the Linux driver for the Attansic(R) L2 Fast
31 Ethernet Adapter.
32
33 %description -l pl.UTF-8
34 Ten pakiet zawiera sterownik dla Linuksa do kart sieciowych
35 Attansic(R) L2 Fast Ethernet Adapter.
36
37 %prep
38 %setup -q -n atl2-%{version}
39
40 cat > src/Makefile <<'EOF'
41 CFILES = at_main.c at_hw.c at_param.c at_ethtool.c kcompat.c  
42 obj-m := atl2.o
43 atl2-objs := $(CFILES:.c=.o)
44 EOF
45
46 %build
47 %build_kernel_modules -C src -m atl2
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 %install_kernel_modules -m src/atl2 -d kernel/drivers/net -n atl2 -s current
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %post
57 %depmod %{_kernel_ver}
58
59 %postun
60 %depmod %{_kernel_ver}
61
62 %files
63 %defattr(644,root,root,755)
64 %doc atl2.7 COPYING readme release_note.txt ldistrib.txt
65 /etc/modprobe.d/%{_kernel_ver}/atl2.conf
66 /lib/modules/%{_kernel_ver}/kernel/drivers/net/atl2*.ko*
This page took 0.071638 seconds and 4 git commands to generate.