]> git.pld-linux.org Git - packages/apache-mod_ntlm.git/blob - apache-mod_ntlm.spec
- BR s@%{apxs}@apache-apxs@g
[packages/apache-mod_ntlm.git] / apache-mod_ntlm.spec
1 # TODO: review security issues
2 %define         mod_name        ntlm
3 %define         apxs            /usr/sbin/apxs
4 Summary:        This is the NTLM authentication module for Apache
5 Summary(pl.UTF-8):      Moduł uwierzytelnienia NTLM dla Apache
6 Name:           apache-mod_%{mod_name}
7 Version:        0.1
8 Release:        0.1
9 Epoch:          1
10 License:        GPL
11 Group:          Networking/Daemons
12 Source0:        http://dl.sourceforge.net/modntlm/mod_%{mod_name}2-%{version}.tgz
13 # Source0-md5:  8abe4f235af6825f723412e187cac96b
14 #Patch0:        %{name}-security.patch
15 URL:            http://modntlm.sourceforge.net/
16 BuildRequires:  apache-apxs >= 2.0
17 BuildRequires:  apache-devel >= 2.0
18 BuildRequires:  rpmbuild(macros) >= 1.268
19 Requires:       apache(modules-api) = %apache_modules_api
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
23 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
24
25 %description
26 This is an authentication module for Apache that allows you to
27 authenticate HTTP clients using samba or windows-like server (using
28 NTLM protocol).
29
30 %description -l pl.UTF-8
31 To jest moduł uwierzytelnienia dla Apache pozwalający na
32 uwierzytelnianie klientów HTTP poprzez sambę lub serwer na Windows (z
33 użyciem protokołu NTLM).
34
35 %prep
36 %setup -q -n mod_%{mod_name}2-%{version}
37 #%patch -p1
38
39 %build
40 %{__make} APXS=%{apxs}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
45
46 install .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
47 echo 'LoadModule %{mod_name}_module modules/mod_%{mod_name}.so' > \
48         $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/90_mod_%{mod_name}.conf
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %post
54 %service -q httpd restart
55
56 %postun
57 if [ "$1" = "0" ]; then
58         %service -q httpd restart
59 fi
60
61 %files
62 %defattr(644,root,root,755)
63 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*_mod_%{mod_name}.conf
64 %attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.057019 seconds and 3 git commands to generate.