]> git.pld-linux.org Git - packages/apache-mod_ntlm.git/blob - apache-mod_ntlm.spec
- working Source URL
[packages/apache-mod_ntlm.git] / apache-mod_ntlm.spec
1 %define         mod_name        ntlm
2 %define         apxs            /usr/sbin/apxs
3 Summary:        This is the NTLM authentication module for Apache
4 Summary(pl):    Modu³ autentykacji NTLM dla Apache
5 Name:           apache-mod_%{mod_name}
6 Version:        0.3
7 Release:        3
8 License:        GPL
9 Group:          Networking/Daemons
10 Source0:        http://dl.sourceforge.net/modntlm/mod_%{mod_name}-%{version}.tar.gz
11 URL:            http://modntlm.sourceforge.net/
12 BuildRequires:  %{apxs}
13 BuildRequires:  apache(EAPI)-devel
14 Requires(post,preun):   %{apxs}
15 Requires:       apache(EAPI)
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
19
20 %description
21 This is an authentication module for Apache that allows you to
22 authenticate HTTP clients using samba or windows-like server (using
23 NTLM protocol).
24
25 %description -l pl
26 To jest modu³ autentykacji dla Apache pozwalaj±cy na autentykacjê
27 klientów HTTP poprzez sambê lub serwer na Windows (z u¿yciem protoko³u
28 NTLM).
29
30 %prep
31 %setup -q -n mod_%{mod_name}-%{version}
32
33 %build
34 PATH=$PATH:/usr/sbin %{__make}
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 install -d $RPM_BUILD_ROOT%{_pkglibdir}
39
40 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %post
46 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
47 if [ -f /var/lock/subsys/httpd ]; then
48         /etc/rc.d/init.d/httpd restart 1>&2
49 fi
50
51 %preun
52 if [ "$1" = "0" ]; then
53         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
54         if [ -f /var/lock/subsys/httpd ]; then
55                 /etc/rc.d/init.d/httpd restart 1>&2
56         fi
57 fi
58
59 %files
60 %defattr(644,root,root,755)
61 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.067359 seconds and 3 git commands to generate.