]> git.pld-linux.org Git - packages/apache-mod_ntlm.git/blob - apache-mod_ntlm.spec
- Release 3.
[packages/apache-mod_ntlm.git] / apache-mod_ntlm.spec
1 %define         mod_name        ntlm
2 %define         apxs            /usr/sbin/apxs
3 Summary:        This is the NTLM authentication module for Apache
4 Summary(pl):    Modu³ autentykacji NTLM dla Apache
5 Name:           apache-mod_%{mod_name}
6 Version:        0.3
7 Release:        3
8 License:        GPL
9 Group:          Networking/Daemons
10 Source0:        http://prdownloads.sourceforge.net/modntlm/mod_%{mod_name}-%{version}.tar.gz
11 BuildRequires:  %{apxs}
12 BuildRequires:  apache(EAPI)-devel
13 Prereq:         %{_sbindir}/apxs
14 Requires:       apache(EAPI)
15 URL:            http://modntlm.sourceforge.net/
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
19
20 %description
21 This is an authentication module for Apache that allows you to
22 authenticate HTTP clients using samba or windows-like server (using
23 NTLM protocol).
24
25 %description -l pl
26 To jest modu³ autentykacji dla Apache pozwalaj±cy na autentykacjê
27 klientów HTTP poprzez sambê lub serwer na Windows (z u¿yciem protoko³u
28 NTLM).
29
30 %prep
31 %setup -q -n mod_%{mod_name}-%{version}
32
33 %build
34 PATH=$PATH:/usr/sbin %{__make}
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 install -d $RPM_BUILD_ROOT%{_pkglibdir}
39
40 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
41
42 %post
43 %{_sbindir}/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
44 if [ -f /var/lock/subsys/httpd ]; then
45         /etc/rc.d/init.d/httpd restart 1>&2
46 fi
47
48 %preun
49 if [ "$1" = "0" ]; then
50         %{_sbindir}/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
51         if [ -f /var/lock/subsys/httpd ]; then
52                 /etc/rc.d/init.d/httpd restart 1>&2
53         fi
54 fi
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.183374 seconds and 3 git commands to generate.