]> git.pld-linux.org Git - packages/apache-mod_ntlm.git/blob - apache-mod_ntlm.spec
- updated to 0.4
[packages/apache-mod_ntlm.git] / apache-mod_ntlm.spec
1 %define         mod_name        ntlm
2 %define         apxs            /usr/sbin/apxs
3 Summary:        This is the NTLM authentication module for Apache
4 Summary(pl):    Modu³ uwierzytelnienia NTLM dla Apache
5 Name:           apache-mod_%{mod_name}
6 Version:        0.4
7 Release:        1
8 License:        GPL
9 Group:          Networking/Daemons
10 Source0:        http://dl.sourceforge.net/modntlm/mod_%{mod_name}-%{version}.tar.gz
11 # Source0-md5:  5e9b8d1abf872926d6ff01a05a7deb2a
12 Patch0:         %{name}-security.patch
13 URL:            http://modntlm.sourceforge.net/
14 BuildRequires:  %{apxs}
15 BuildRequires:  apache(EAPI)-devel
16 Requires(post,preun):   %{apxs}
17 Requires:       apache(EAPI)
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
21
22 %description
23 This is an authentication module for Apache that allows you to
24 authenticate HTTP clients using samba or windows-like server (using
25 NTLM protocol).
26
27 %description -l pl
28 To jest modu³ uwierzytelnienia dla Apache pozwalaj±cy na
29 uwierzytelnianie klientów HTTP poprzez sambê lub serwer na Windows (z
30 u¿yciem protoko³u NTLM).
31
32 %prep
33 %setup -q -n mod_%{mod_name}-%{version}
34 %patch -p1
35
36 %build
37 PATH=$PATH:/usr/sbin %{__make}
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 install -d $RPM_BUILD_ROOT%{_pkglibdir}
42
43 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %post
49 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
50 if [ -f /var/lock/subsys/httpd ]; then
51         /etc/rc.d/init.d/httpd restart 1>&2
52 fi
53
54 %preun
55 if [ "$1" = "0" ]; then
56         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
57         if [ -f /var/lock/subsys/httpd ]; then
58                 /etc/rc.d/init.d/httpd restart 1>&2
59         fi
60 fi
61
62 %files
63 %defattr(644,root,root,755)
64 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.055953 seconds and 3 git commands to generate.