]> git.pld-linux.org Git - packages/apache-mod_fcgid.git/blob - apache-mod_fcgid.spec
- rebuild with new apache
[packages/apache-mod_fcgid.git] / apache-mod_fcgid.spec
1 %define         mod_name        fcgid
2 %define         apxs            /usr/sbin/apxs
3 Summary:        A binary compatibility alternative to Apache module mod_fastcgi
4 Summary(pl):    Binarnie kompatybilna alternatywa dla modu³u Apache'a mod_fastcgi
5 Name:           apache-mod_%{mod_name}
6 Version:        1.03
7 Release:        2
8 License:        GPL v2
9 Group:          Networking/Daemons
10 Source0:        http://fastcgi.coremail.cn/mod_%{mod_name}.%{version}.tar.gz
11 # Source0-md5:  dbcd5c96f8d6c6fcb7471abf527d176f
12 Source1:        %{name}.conf
13 Patch0:         %{name}-apr-status-is-success.patch
14 URL:            http://fastcgi.coremail.cn/
15 BuildRequires:  %{apxs}
16 BuildRequires:  apache-devel >= 2.0.52-2
17 BuildRequires:  libtool
18 BuildRequires:  sed >= 4.0
19 Requires:       apache(modules-api) = %apache_modules_api
20 Requires:       apache >= 2.0.52-2
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
24 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
25
26 %description
27 A binary compatibility alternative to Apache module mod_fastcgi.
28 mod_fcgid has a new process management strategy, which concentrates on
29 reducing the number of fastcgi server, and kick out the corrupt
30 fastcgi server as soon as possible.
31
32 %description -l pl
33 Binarnie kompatybilna alternatywa dla modu³u Apache'a mod_fastcgi.
34 mod_fcgid to nowa strategia zarz±dzania procesami, koncentruj±ca siê
35 na redukcji liczby serwerów fastcgi i usuwaniu uszkodzonych serwerów
36 fastcgi najszybciej jak to mo¿liwe.
37
38 %prep
39 %setup -q -n mod_%{mod_name}.%{version}
40 %patch0 -p1
41
42 %build
43 %{__make} \
44         top_dir=%{_pkglibdir} \
45         APXS=%{_apxs} \
46         INCLUDES="-I%(%{apxs} -q INCLUDEDIR)"
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
51
52 install .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
53 install %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/httpd.conf/70_mod_%{mod_name}.conf
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %post
59 if [ -f /var/lock/subsys/httpd ]; then
60         /etc/rc.d/init.d/httpd restart 1>&2
61 fi
62
63 %preun
64 if [ "$1" = "0" ]; then
65         if [ -f /var/lock/subsys/httpd ]; then
66                 /etc/rc.d/init.d/httpd restart 1>&2
67         fi
68 fi
69
70 %files
71 %defattr(644,root,root,755)
72 %doc AUTHOR ChangeLog
73 %config(noreplace) /etc/httpd/httpd.conf/70_mod_fcgid.conf
74 %attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.081515 seconds and 4 git commands to generate.