]> git.pld-linux.org Git - packages/apache-mod_epp.git/blob - apache-mod_epp.spec
- restart apache in %postun rather in %preun as the config file, loading module
[packages/apache-mod_epp.git] / apache-mod_epp.spec
1 # TODO:
2 # - example/minimal configuration file
3 %define         mod_name        epp
4 %define         apxs            /usr/sbin/apxs
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        An EPP (Extensible Provisioning Protocol) implementation for Apache2
7 Summary(pl):    Implementacja EPP (Extensible Provisioning Protocol) dla Apache2
8 Name:           apache-mod_%{mod_name}
9 Version:        1.2
10 Release:        1
11 License:        Apache
12 Group:          Networking/Daemons
13 Source0:        http://dl.sourceforge.net/aepps/mod_%{mod_name}-%{version}.tar.gz
14 # Source0-md5:  c21073a4025d79f3ac1c293b58132ed7
15 Source1:        http://dl.sourceforge.net/aepps/epp-erd-20030122.tar.gz
16 # Source1-md5:  3d7720410e83fe6e90742119892011e2
17 URL:            http://aepps.sourceforge.net/
18 BuildRequires:  %{apxs}
19 BuildRequires:  apache-devel >= 2.0.43
20 BuildRequires:  rpm-perlprov
21 BuildRequires:  rpmbuild(macros) >= 1.268
22 Requires:       apache(modules-api) = %apache_modules_api
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
26 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
27
28 %description
29 This Apache 2.0 module implements the EPP over TCP protocol as defined
30 in draft-ietf-provreg-epp-tcp-05.txt and the session management parts
31 of draft-ietf-provreg-epp-0(6|7).txt.
32
33 This is *not* a full implementation of EPP, this module just makes it
34 possible to write an EPP server as a set of CGI scripts.
35
36 %description -l pl
37 Ten modu³ Apache 2.0 jest implementacj± protoko³u EPP po TCP zgodn± z
38 dokumentem draft-ietf-provreg-epp-tcp-05.txt oraz czê¶ciami
39 dotycz±cymi zarz±dzania sesj± z draft-ietf-provreg-epp-0(6|7).txt.
40
41 *Nie* jest to pe³na implementacja EPP, ten modu³ jedynie umo¿liwia
42 pisanie serwera EPP jako zestawu skryptów CGI.
43
44 %prep
45 %setup -q -n mod_%{mod_name}-%{version} -a1
46 sed -i -e 's#MD5_DIGESTSIZE#APR_MD5_DIGESTSIZE#g' *.c
47
48 %build
49 %{apxs} -c mod_%{mod_name}.c
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_bindir},%{_sysconfdir}/httpd.conf,%{_examplesdir}/%{name}-%{version}}
54
55 libtool --mode=install install mod_%{mod_name}.la $RPM_BUILD_ROOT%{_pkglibdir}
56 rm -f $RPM_BUILD_ROOT%{_pkglibdir}/*.{l,}a
57
58 install epptelnet.pl $RPM_BUILD_ROOT%{_bindir}
59 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
60
61 echo 'LoadModule %{mod_name}_module modules/mod_%{mod_name}.so' > \
62         $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/68_mod_%{mod_name}.conf
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %post
68 %service -q httpd restart
69
70 %postun
71 if [ "$1" = "0" ]; then
72         %service -q httpd restart
73 fi
74
75 %files
76 %defattr(644,root,root,755)
77 %doc README TODO epp-erd*
78 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*_mod_%{mod_name}.conf
79 %attr(755,root,root) %{_pkglibdir}/*.so
80 %attr(755,root,root) %{_bindir}/*
81 %{_examplesdir}/%{name}-%{version}
This page took 0.078794 seconds and 4 git commands to generate.