]> git.pld-linux.org Git - packages/anubis.git/blob - anubis.spec
- bcond descs; patches need update
[packages/anubis.git] / anubis.spec
1 #
2 # TODO: update patches
3 #
4 # Conditional build:
5 %bcond_with     gnutls          # use GnuTLS library instead of OpenSSL
6 %bcond_without  tcp_wrappers    # disable using tcp_wrappers for access control
7 %bcond_without  pam             # disable using of PAM authentcation
8 %bcond_without  gpgme           # disable using gpgme library for signing/encrypting with gnupg
9 %bcond_without  pcre            # disable using pcre library
10 %bcond_with     mysql           # enable MySQL support
11 %bcond_with     postgres        # enable PostgreSQL support
12 #
13 %include        /usr/lib/rpm/macros.perl
14 Summary:        An outgoing mail processor, and the SMTP tunnel
15 Summary(pl):    Procesor wychodz±cej poczty i tunel SMTP
16 Name:           anubis
17 Version:        3.9.94
18 Release:        0.8
19 License:        GPL
20 Group:          Applications/Mail
21 Source0:        ftp://mirddin.farlep.net/pub/alpha/anubis/%{name}-%{version}.tar.gz
22 # Source0-md5:  1557c499d73265aac1f87c61c5695b50
23 Source1:        %{name}.init
24 Source2:        %{name}.pamd
25 Patch0:         %{name}-info.patch
26 Patch1:         %{name}-configure_gpgme.patch
27 Patch2:         %{name}-boundary.patch
28 Patch3:         %{name}-nolibnsl.patch
29 Patch4:         %{name}-securityfixes.patch
30 URL:            http://www.gnu.org/software/anubis/
31 BuildRequires:  gettext-devel >= 0.12.1
32 BuildRequires:  autoconf >= 2.54
33 BuildRequires:  automake >= 1.7
34 BuildRequires:  bison
35 %{?with_gnutls:BuildRequires:   gnutls-devel}
36 %{?with_gpgme:BuildRequires:    gpgme-devel >= 0.3.12}
37 %{?with_tcp_wrappers:BuildRequires:     libwrap-devel}
38 %{!?with_gnutls:BuildRequires:  openssl-devel >= 0.9.7d}
39 %{?with_postgres:BuildRequires: postgres-devel}
40 %{?with_mysql:BuildRequires:    mysql-devel}
41 BuildRequires:  rpm-perlprov
42 BuildRequires:  texinfo
43 PreReq:         rc-scripts
44 Requires(post,preun):   /sbin/chkconfig
45 Requires:       identserver
46 Requires:       pam >= 0.77.3
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 GNU Anubis is an outgoing mail processor. It goes between the MUA
51 (Mail User Agent) and the MTA (Mail Transport Agent), and can perform
52 on the fly various sorts of processing and conversion on the outgoing
53 mail in accord with the sender's specified rules, based on a highly
54 configurable regular expressions system. It operates as a proxy
55 server, independently from mail user agents. GNU Anubis can edit
56 outgoing mail headers, encrypt and/or sign mail with the GNU Privacy
57 Guard, build secure SMTP tunnels (Simple Mail Transport Protocol)
58 using the TLS/SSL encryption even if your mail user agent doesn't
59 support it, or tunnel a connection through a SOCKS proxy. Moreover,
60 GNU Anubis supports the remailers (it allows sending mail in an
61 anonymous way).
62
63 Remember, that to use per-user configuration files ident server has to
64 be running. Without it only system-wide configuration file is used.
65
66 If you want to use GNU Anubis with mutt mail client, install msg2smtp
67 package.
68
69 %description -l pl
70 GNU Anubis zajmuje siê przetwarzaniem poczty wychodz±cej. Znajduje siê
71 on pomiêdzy MUA (Mail User Agent) i MTA (Mail Transport Agent) i mo¿e
72 wykonywaæ w locie ró¿ne rodzaje przetwarzania i konwersji poczty
73 wychodz±cej zale¿nie od podanych regu³, bazuj±cych na wysoce
74 konfigurowalnym systemie wyra¿eñ regularnych. GNU Anubis dzia³a jako
75 serwer proxy, niezale¿nie od programów pocztowych. Potrafi on zmieniaæ
76 nag³ówki listów, szyfrowaæ lub podpisywaæ jest przy pomocy GNU Privacy
77 Guard, tworzyæ bezpieczne tunele SMTP u¿ywaj±c szyfrowania TLS/SSL
78 nawet, gdy Twój program pocztowy nie ma takich mo¿liwo¶ci. Mo¿liwe
79 jest te¿ tunelowanie po³±czeñ przez SOCKS proxy.
80 Co wiêcej, GNU Anubis wspiera tak¿e remailery (czyli pozawala na
81 anonimowe wysy³anie poczty).
82
83 Pamiêtaj, ¿e aby u¿ywaæ plików konfiguracyjnych u¿ytkowników, serwer
84 ident musi byæ aktywny. Inaczej, u¿yty bêdzie tylko g³ówny plik
85 konfiguracyjny.
86
87 Je¶li chcesz u¿ywaæ GNU Anubis z klientem poczty mutt, zainstaluj
88 pakiet msg2smtp.
89
90 %package -n msg2smtp
91 Summary:        msg2smtp takes mail at input and relays it to an SMTP server
92 Summary(pl):    msg2smtp wysy³a pocztê przyjmowan± na wej¶ciu do serwera SMTP
93 Group:          Applications/Mail
94
95 %description -n msg2smtp
96 The msg2smtp script is a bridge between MUA programs which use
97 "sendmail" command to send mail (such as Mutt) and smtp servers. It is
98 particularly useful when used in connection with GNU Anubis mail
99 processor.
100
101 %description -n msg2smtp -l pl
102 Skrypt msg2smtp jest pomostem miêdzy programami pocztowymi u¿ywaj±cymi
103 polecenia "sendmail" do wysy³ania listów (np. Mutt), a serwerem smtp.
104 Jest on szczególnie przydatny w po³±czeniu z procesorem poczty GNU
105 Anubis.
106
107 %prep
108 %setup -q
109 #%patch0 -p1
110 #%patch1 -p1
111 #%patch2 -p1
112 #%patch3 -p1
113 #%patch4 -p1
114
115 %build
116 %{__gettextize}
117 %{__aclocal} -I m4
118 %{__autoconf}
119 %{__automake}
120 %configure \
121 %{!?with_gnutls:        --without-gnutls} \
122 %{!?with_gnutls:        --with-openssl} \
123 %{?with_pam:            --with-pam} \
124 %{?with_pcre:           --with-pcre} \
125 %{!?with_gpgme:         --without-gpgme} \
126 %{?with_mysql:          --with-mysql} \
127 %{?with_postgres:       --with-postgres} \
128 %{?with_tcp_wrappers:   --with-tcp-wrappers} \
129         --disable-dependency-tracking
130
131 %{__make}
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,/etc/pam.d,%{_sysconfdir},%{_bindir}}
136
137 %{__make} install \
138         DESTDIR=$RPM_BUILD_ROOT
139
140 install ./contrib/msg2smtp.pl $RPM_BUILD_ROOT%{_bindir}
141 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/anubis
142 install ./examples/2anubisrc $RPM_BUILD_ROOT%{_sysconfdir}/anubisrc
143 %{?with_pam:install %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/anubis}
144 cp -f ./examples/1anubisrc examples/anubisrc
145
146 %find_lang %{name}
147
148 %clean
149 rm -fr $RPM_BUILD_ROOT
150
151 %post
152 /sbin/chkconfig --add anubis
153 if [ -f %{_localstatedir}/lock/subsys/anubis ]; then
154         /etc/rc.d/init.d/anubis restart >&2
155 else
156         echo "Run \"/etc/rc.d/init.d/anubis start\" to start anubis." >&2
157 fi
158 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
159
160
161 %preun
162 if [ "$1" = "0" ]; then
163         if [ -f %{_localstatedir}/lock/subsys/anubis ]; then
164                 /etc/rc.d/init.d/anubis stop
165         fi
166         /sbin/chkconfig --del anubis
167 fi
168
169 %postun
170 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
171
172 %files -f %{name}.lang
173 %defattr(644,root,root,755)
174 %doc AUTHORS README INSTALL NEWS ChangeLog TODO examples/anubisrc
175 %{?with_pam:%doc examples/pam}
176 %attr(754,root,root) /etc/rc.d/init.d/anubis
177 %attr(600,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/anubisrc
178 %{?with_pam:%attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/anubis}
179 %attr(755,root,root) %{_sbindir}/anubis
180 %{_mandir}/man1/*
181 %{_infodir}/*info*
182
183 %files -n msg2smtp
184 %defattr(644,root,root,755)
185 %doc contrib/msg2smtp.txt
186 %attr(755,root,root) %{_bindir}/msg2smtp.pl
This page took 0.049741 seconds and 4 git commands to generate.